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resumo 

 

 

O fabrico aditivo tem sido um tema cada vez mais popular na 

indústria devido às suas capacidades. Esta dissertação foca-se no 

funcionamento e numa das fases do desenvolvimento de uma máquina 

de fabrico do tipo fusão em leito de pó. Engloba as tecnologias existentes 

de fabrico aditivo, as vantagens e desvantagens da tecnologia e a 

afinação dos parâmetros laser da máquina concebida e construída no 

Departamento de Engenharia Mecânica da Universidade de Aveiro. É 

descrito o estado inicial da máquina, as dificuldades encontradas e as 

alterações e afinações feitas. 

No final, embora com ainda vários assuntos pendentes, a 

máquina apresenta um sistema laser operacional e capaz de fundir pós 

metálicos. 
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Additive manufacturing has been a growing trend in the industrial and 

academic space due to its promising and current capabilities. This 

dissertation focuses on how a powder bed fusion machine operates and 

especially on the fine tuning of its laser parameters. The machine in 

question was developed and produced in the Mechanical Engineering 

Department of the University of Aveiro. This dissertation contents include 

the machine’s initial state, the challenges encountered, and the 

modifications and calibrations done. 

In the end, although with some challenges left for future works, the 

machine is left with a functional laser system capable of melting metallic 

powders.  
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1.  Introdução 

Esta dissertação foca na finalização e aperfeiçoamento de uma máquina de fabrico aditivo 

de metais desenvolvida e construída no Departamento de Engenharia Mecânica da 

Universidade de Aveiro, focando principalmente na colocação em funcionamento, calibração e 

afinação do sistema laser.  

 

O objetivo desta dissertação centra-se em torno da fusão de pós metálicos, implicando a 

otimização dos parâmetros laser da máquina tal como a finalização do sistema laser, que não 

se encontrava operacional. 

 

Esta dissertação irá abordar inicialmente o estado da arte do fabrico aditivo, 

posteriormente irá ser introduzida a máquina em questão, depois serão abordadas as 

alterações e aperfeiçoamentos feitos à máquina, e finalmente será apresentado um manual de 

instruções para a operação da máquina. Na conclusão serão abordados alguns pendentes e 

propostas de melhoria para trabalhos futuros. 

 

 

2.  Revisão do Estado da Arte 

 

 

2.1 Fabrico Aditivo e a sua evolução 

 

O fabrico aditivo ou manufatura aditiva é uma tecnologia de construção de peças e objetos 

tridimensionais pelo método de adicionar material, contrastando com o tradicional fabrico 

subtrativo, o qual produz o objeto pretendido a partir de um bloco de material bruto que irá 

ser desbastado até se obter o objeto final. 
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O fabrico aditivo cria o objeto ou peça partindo de uma matéria-prima tal como pós, 

filamentos ou soluções metálicas ou poliméricas, adicionando o material necessário para se 

obter o objeto pretendido, como ilustrado pela Figura 11 .  

 

 

É considerado que o início do fabrico aditivo se deu em 1987 com a comercialização da 

primeira máquina de fabrico aditivo a SLA-1 pela 3D Systems (Figura 2)2 .O equipamento 

operava seguindo os princípios da esteriolitografia, (SLA - stereolithography apparatus), 

patenteada por Chuck Hull em 1984, em que o objeto era dividido em camadas que depois são 

projetadas por um laser ultravioleta sobre uma resina fotopolimerizável, dando assim forma 

ao objeto camada a camada 3. Com a introdução da SLA-1 também foi introduzido o formato de 

ficheiro STL que até à data ainda é usado na indústria 2.  

Figura 1- Fabrico subtrativo e aditivo 1 

Figura 2 - SLA-1 da 3D Systems 2 
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Em outubro de 1986 Carl R. Deckard apresentou uma patente para um novo método de 

fabrico aditivo conhecido como sinterização seletiva por laser (SLS - selective laser sintering), 

um método em que as camadas do objeto eram formadas por pós sinterizados por um laser.4 

Este processo é comum em máquinas de maior qualidade que produzem peças metálicas, 

poliméricas e cerâmicas. 

 

Em 1991 foi feita uma nova introdução importante para o mercado do fabrico aditivo, a 

introdução do método de modelação por deposição de material fundido (FDM – (fused 

deposition modeling) pela StrataSys 5. Este método cria as diferentes camadas do objeto 

fundindo o material a adicionar e depositando-o sobre a camada anterior, um dos métodos 

mais populares até à data (Figura 3). 

 

Inicialmente o mercado do fabrico aditivo estava muito restrito e protegido por patentes, 

o que manteve o custo da tecnologia elevado, no entanto, com o avanço do tempo estas patentes 

foram expirando, e continuam a expirar, o que levou ao aumento da concorrência e por sua vez 

fez com que estas tecnologias se tornassem mais económicas de operar e adquirir, tendo-se 

assim dado uma expansão do fabrico aditivo 6. 

  

Figura 3 – FDM Fused Deposition Modeling 22 
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2.2 Aplicações do fabrico aditivo 

 

 Uma das principais aplicações do fabrico aditivo é a prototipagem rápida, devido à sua 

capacidade de transformar modelos e objetos digitais em peças reais e palpáveis de forma 

rápida e baixo custo. Estes modelos servem para atestar os 3F’s (Forma, Fit (montagem; 

alojamento) e Função). Inicialmente somente era possível atestar a forma devido à fragilidade 

dos objetos produzidos, mas com os avanços nos métodos e materiais tornou-se possível 

também produzir peças para atestar a sua funcionalidade e ajustamento a outros componentes 

7.  

 

 A otimização topológica é um processo de obter geometrias que minimizam a 

quantidade de material, por questões de peso ou custo e maximizam as suas propriedades. 

   

 

O fabrico aditivo possibilitou a produção mais eficiente e económica de peças topologicamente 

otimizadas. De facto, estes componentes, em regra geral, apresentam geometrias muito 

complexas e difíceis de executar com métodos de fabrico tradicionais (Figura 4) 8.  

Muitas geometrias que previamente à introdução do fabrico aditivo eram impossíveis de 

fabricar ou simplesmente demasiado complexas tornaram-se possíveis e viáveis através deste 

novo método. 

   

Figura 4 – Design generativo 23 
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 Outra aplicação do fabrico aditivo é a criação de canais de arrefecimento curvos em 

moldes de injeção de plásticos, os quais melhoram significativamente a qualidade e eficiência 

de um molde de injeção9. Tradicionalmente os canais de arrefecimento de moldes são 

constituídos por uma serie de furos retos, facto que causa gradientes térmicos na superfície do 

molde que, por sua vez, reduz a qualidade da peça injetada. O fabrico aditivo possibilita a 

criação de canais curvos e mais complexos que arrefecem a peça a injetar de forma mais 

uniforme, evitando assim defeitos na mesma (Figura 5) 10.  

  

 

 A expansão do mercado do fabrico aditivo também possibilitou a produção mais 

económica de pequenas series de produtos, produtos que somente seriam económicos em 

grandes quantidades são possíveis de produzir rentavelmente à pequena escala. 

  

Figura 5 – Canais Conformáveis num molde  

a) Canal reto tradicional; b) Canal conformável que 

acompanha a cavidade do molde; c) Vista em corte dos 

canais. 9 
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2.3 Vantagens do fabrico aditivo 

 

  Uma das vantagens do fabrico aditivo é que este produz as peças ou objetos 

num só passo, a “impressão”. Fabricar as peças de uma só vez permite aumentar a 

complexidade das mesmas sem grande alteração do tempo de fabrico, por exemplo adicionar 

um chanfro ou furo no centro de uma peça. Tradicionalmente uma pequena adição ao design 

básico significa um aumento significativo dos passos e métodos para o fabrico da peça, e por 

sua vez o tempo e custo de produção, desta forma é possível produzir peças mais complexas 

sem o custo acrescentado que tradicionalmente se aplica 7 11. 

   

  Uma outra vantagem do fabrico aditivo são os benefícios para o ambiente, visto 

que a fabrico aditivo utiliza somente o material necessário para a formação da peça ou objeto 

que se pretende fabricar, eliminando assim o desperdício. Este fenómeno é especialmente 

relevante em peças grandes de elevada complexidade que embora a sua grande dimensão tem 

volumes finais reduzidos. A otimização topológica e design generativo também contribuem 

para a economia de matéria-prima, reduzindo a quantidade de material necessária para a 

formação da peça (Figura 6) 8.  

   

Figura 6 – Evolução de uma peça com otimização de topologia 12 
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  Outra grande vantagem do fabrico aditivo é a sua velocidade de produção, em 

especial na produção de protótipos, a impressão 3D facilita a criação de modelos reais de 

modelos digitais, facilita a iteração de design, dimensões e tolerâncias. Isto e especialmente útil 

em áreas onde o fabrico de modelos é dispendioso e crucial ao desenvolvimento de produto 7.  

   

 

2.4 Desvantagens do fabrico aditivo 

 

  Uma das desvantagens do fabrico aditivo é a quantidade limitada de materiais 

disponíveis para fabrico aditivo, embora haja cada vez mais variedade de pós, resinas e 

filamentos para impressão 3D, como por exemplo filamentos de fibra de carbono contínua e 

pós de titânio. 

 

  Comparado com o fabrico tradicional as dimensões máximas dos componentes 

ainda são reduzidas, não só devido ao tempo de produção, mas também a dimensão máxima 

das máquinas 11 . 

De momento a maior impressora 3D é a 3Dirigo da Universidade de Maine, que imprimiu um 

barco com 7.62 m de comprimento e pesa 2268 kg (Figura 7). 

  

Figura 7 – Barco produzido pela 3Dirigo 24 
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 Com a tecnologia atual as peças produzidas são normalmente anisotrópicas e com 

precisão dimensional e acabamentos de superfície inferiores aos obtidos por métodos 

tradicionais, sendo assim muitas peças de fabrico aditivo pós-processadas com métodos de 

fabrico tradicionais 11 13 Na Figura 8 e Figura 9 é possível observar os resultados de ensaios de 

tração em provetes imprimidos em diferentes direções. Como é possível observar na Figura 9 

os provetes foram mais fortes quando as camadas se encontravam paralelas à tensão aplicada 

no provete.  

 

 

De uma das vantagens do fabrico aditivo, a produção de uma peça na sua totalidade e 

de uma só vez, vem também uma das suas desvantagens, a dificuldade de otimizar o processo 

para grandes quantidades de componentes. No fabrico tradicional cada processo é otimizado 

para produzir um certo efeito no produto final podendo assim se criar linhas de produção para 

a produção em serie, o que leva à diminuição do tempo de produção, no fabrico aditivo o 

processo é único, não especializado para nenhuma operação em concreto, levando assim a 

tempos de produção demorados em produções em escala 11. Na Figura 10 é possível observar 

a comparação do tempo de produção por fabrico aditivo contra o fabrico tradicional para uma 

determinada peça 14 .  

Figura 9 – Orientação das camadas 

nos provetes 13 
Figura 8 – Resultados dos ensaios 

de tração 13 
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Figura 10 – Tempo de resposta 

 Extrusão de material (Azul) e injeção de plástico (Vermelho)  14 
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2.5 Tecnologias existentes 

  

 Neste capítulo serão apresentadas as diferentes tecnologias de fabrico aditivo seguindo 

a classificação ISO/ASTM 52900:2015. 

 

1. Extrusão de Material (Material Extrusion) 

 

A tecnologia mais utilizada na impressão 3D amadora, em que o 

material, normalmente um filamento polimérico, é aquecido e 

extrudido por um orifício onde se liga ao restante material extrudido 

formando assim as camadas da peça 15 (Figura 11). 

Esta tecnologia é aplicável a materiais poliméricos, metálicos e 

cerâmicos. 

  

Figura 11 - Extrusão de Material 15 
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2. Jato de material (Material Jetting) 

 A tecnologia de jato de material opera através da foto polimerização de 

material depositado por uma cabeça de impressão, normalmente são 

usadas resinas foto polimerizáveis 15 (Figura 12). 

Esta tecnologia é aplicável a materiais poliméricos. 

 

3. Fusão de leito em pó  

 

A tecnologia de fusão de leito em pó baseia-se consecutiva fusão de 

finas camadas de pó, através do uso de um laser ou feixe de eletrões 15 

(Figura 13). 

 

Esta tecnologia é aplicável a materiais poliméricos, metálicos e 

cerâmicos. 

Figura 12 - Jato de material 15 

Figura 13 - Fusão de leito em pó 15 
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4. Jato de Aglutinante (Binder Jetting) 

 

O jato de aglutinante opera de forma semelhante à fusão de leito em pó, 

no entanto usa uma cabeça de impressa que introduz um agente 

aderente que adere as partículas de pó em vez de o fundir 15 (Figura 

14). 

Esta tecnologia é aplicável a materiais poliméricos, metálicos e 

cerâmicos. 

 

 

  

 

5. Foto polimerização em tina (Vat Photopolymerization) 

 

Na foto polimerização em tina, uma fonte de laser ou luz ultravioleta 

cura uma resina nas sucessivas camadas do objeto a imprimir 15 (Figura 

15). 

Esta tecnologia é aplicável a materiais poliméricos. Normalmente 

resinas, bio resinas e polímeros foto polimerizáveis. 

 

Figura 14 - Jato de Aglutinante 15 
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6. Laminagem de folhas (Sheet Lamination) 

 

A laminagem de folhas consiste na fusão de várias folhas de forma a 

obter o objeto desejado 15 (Figura 16). 

Esta tecnologia é aplicável a materiais poliméricos, metálicos e 

cerâmicos, também é aplicável em alguns compósitos.  

 

 

 

  

Figura 15 - Foto polimerização em tina 15 

Figura 16 - Laminagem de folhas 15 
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7. Deposição direta de energia (Direct Energy Deposition) 

 

A deposição direta de energia usa material na forma de filamento que é 

fundida numa cabeça de deposição por um laser ou feixe de eletrões 15 

(Figura 17). 

 

Esta tecnologia é aplicável a materiais metálicos. 

 

 

2.6 Fusão em leito de pó  

 

Visto que a máquina na qual este trabalho se foca é do tipo fusão em leito de pó será agora 

abordado mais em detalhe o funcionamento e tipos de máquina. 

 

Existem vários tipos de máquinas de fusão em leito de pó, entre elas sinterização seletiva 

a laser (SLS), fusão seletiva a laser (SLM), sinterização direta de metal a laser (DMLS), 

sinterização seletiva a calor (SHS) e fusão por feixe de eletrões (EBM). Este processo 

funciona através da formação por camadas de uma peça, fundindo partículas de pó por 

ação de uma fonte de calor normalmente um feixe laser ou um feixe de eletrões. 

 

Figura 17 - Deposição direta de energia 15 
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Estas máquinas geralmente dispõem de uma varredora que varre o pó sobre a superfície 

de impressão, sobre a qual posteriormente irá incidir a fonte de calor. Este processo é 

repetido várias vezes aplicando camada de pó sobre camada de pó 16 (Figura 18). 

 

 

Sinterização ou Fusão 

  Ambos o processo de fusão e de sinterização são muito usados no fabrico 

aditivo, especialmente nos sistemas de fusão em leito de pó usando lasers ou feixes de 

eletrões. 

 Muitas vezes estes termos geram alguma confusão à volta de que tipo de processo se 

trata, como por exemplo: fusão seletiva a laser e sinterização seletiva a laser (SLM e 

SLS). 

  A principal diferença entre fusão e sinterização é a forma como as partículas se 

unem. Na sinterização a união é feita através da fusão superficial dos pós metálicos, ou 

seja, somente ocorre fusão à superfície de cada partícula, nunca entrando a sua 

totalidade em estado líquido.  

  Nos processos de fusão ocorre a liquefação total das partículas, formando assim 

uma só estrutura metálica contínua 17.  

 

Figura 18 - Fusão em leito de pó 25 
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Como é possível observar na Figura 19 é possível ver a fusão superficial no método SLS e 

a fusão total no método SLM e DMLS. 

  

Figura 19 – Fusão e sinterização ao microscópio eletrónico 26 
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3.  Desenvolvimento 

 

3.1 Introdução à máquina de fabrico aditivo 

 

A máquina de teste é do tipo fusão em leito de pó, tendo sido desenvolvida, projetada e 

construída por alunos do Departamento de Engenharia Mecânica da Universidade de Aveiro. 

Para introduzir o funcionamento da máquina esta será dividida em 4 subconjuntos, 

nomeadamente, o laser, a componente mecânica, o quadro elétrico, sensores e atuadores, e o 

software de controlo. 

 

A Figura 20 apresenta o estado inicial da máquina, que não se encontrava operacional, 

tendo sido necessário finalizar partes da mesma.  

Nesta máquina a alimentação da mesa de produção é efetuada por uma varredora que 

transporta o pó existente em uma primeira cavidade (designada por mesa de alimentação ou 

mesa de pó), depositando uma camada fina do pó metálico sobre a mesa de produção (Figura 

21). Esta camada de pó na mesa de produção é depois fundida por um feixe laser. De seguida, 

a mesa de produção desce um incremento e a mesa de pó sobe um incremento. A varredora 

volta a transportar pó da mesa de pó para a mesa de produção e o processo repete-se até se 

finalizar a peça.  

Figura 20 – Estado inicial da máquina 
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 3.1.1 O laser 

 

O sistema laser é constituído por 2 componentes: a cabeça galvanométrica “Raylase AM 

module”, também conhecida por defletor laser, que direciona o feixe do laser para a mesa de 

produção, e o “IPG YLR-200-AC”, fonte de geração do feixe laser. 

 

O feixe laser é gerado no IPG e redirecionado para o AM module usando uma fibra ótica, de 

onde é depois direcionado para a mesa de produção, na qual irá fundir os pós metálicos. 

  

Figura 21 – Máquina em corte e alguns componentes 
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 O sistema de deflexão do laser é um protótipo de um “AM Module” da marca Alemã 

Raylase, (Figura 22). Este modulo deflete o feixe laser, conduzido por uma fibra ótica desde a 

fonte do laser, com uso a espelhos no seu interior e permite assim avançar no plano X e Y na 

mesa de trabalho, (Figura 23). Este modulo tem também uma lente Z motorizada que permite 

alterar o foco do laser. Possui uma área de trabalho de 400 mm x 400 mm e uma distância focal 

de 470 mm. 

O modulo necessita de 2 conexões de cabos marcados como SL2, uma ligação fibra ótica, 

uma de corrente elétrica e duas ligações para água de arrefecimento.  

Figura 22 – Raylase AM Module 27 

Figura 23 – Processo de Fusão em leito de pó 28 
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 A fonte que gera o laser é o “IPG YLR-200-AC” da marca IPG Photonics, uma fonte de 

laser de itérbio contínua com um comprimento de onda de 1,07 ± 0,01 µm e uma potência 

máxima de 200 W (Figura 24). Esta fonte tem dois modos de operação “Remote” e “Local” e as 

suas configurações são essenciais para a operação da máquina, tema que será abordado em 

mais detalhe à frente. O feixe laser aqui gerado é conduzido por uma fibra ótica até ao AM 

module. 

  

Figura 24 – IPG YLR-200-AC 
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3.1.2 Sistema Mecânico 

 

A varredora, cuja função é transportar pó desde a mesa de pó até à mesa de produção, é 

atuada por um motor trifásico, está configurada para operar com uma mesa de trabalho 

reduzida de modo a poderem ser feitos ensaios utilizando menos pó do que com a mesa de 

trabalho de 250 mm x 250 mm originalmente prevista.  

Este sistema funciona usando um fuso trapezoidal com 900 mm de comprimento e 5 mm 

de passo, um motor trifásico IEC IE3 90L de 1,5 kW, 1500 RPM B5 230/400 V 50 Hz, guias 

lineares de 30 mm de diâmetro e uma varredora modular que permite substituir a superfície 

de contacto facilmente (Figura 25) de forma a poderem ser testadas várias geometrias de 

varredora 18 19.  

O curso da varredora é controlado por dois fins de curso Honeywell GLLA01A1B ajustáveis 

conforme a necessidade de curso da varredora (Figura 26). 

Figura 25 – Varredora 

Figura 26 – Fim de curso 

Honeywell 29 
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 Embora o sistema seja robusto e simples a obtenção de camadas de pó regulares 

provou-se uma dificuldade devido a dificuldade de garantir o paralelismo entre a varredora e 

a mesa de produção, o que causa camadas desniveladas e com espessuras diferentes, como é 

possível verificar na Figura 27. 

 

O sistema das mesas de produção e pó é operado por 2 motores de passo usando fusos de 

5 mm, ambas as mesas usam barras de TEFLON para conter o pó e manter uma atmosfera 

inerte no interior. A mesa de pó usa um motor de passo 34HS38-4204D-E1000 da marca 

StepperOnline sem redução e a mesa de produção usa um motor de passo 23HS22-2804D-

PG15-E1000 com uma redução de 15:1 (Figura 28).  

 

Figura 27 – Pó metálico sobre a mesa de produção 
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 Sobre as mesas de pó originais (250 mm x 250 mm) foi aplicada uma nova mesa com 

duas mesas cilíndricas de 60 mm (Figura 29). Aplicando dois pistões nas mesas originais da 

máquina 19.  

Figura 28 – Sistema de 

motorização das mesas de pó e 

produção 

Figura 29 – Mesa de produção reduzida 
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A câmara de produção cobre as mesas, a varredora e suporta a cabeça galvanométrica. A 

sua principal função é criar uma atmosfera inerte no seu interior de forma a possibilitar a fusão 

dos pós metálicos sem se oxidarem (Figura 30). Tal como muitas partes da máquina foi 

construída por alunos da unidade curricular tecnologia de processos de ligação ao longo dos 

anos e também alterada algumas vezes desde a sua construção. Teve de ser alterada para 

acomodar um novo apoio para o AM module, devido a um erro de produção prévio.  É 

constituída por perfil metálico quadrado e por chapas galvanizadas quinadas e soldadas. Foi 

isolada com lã de rocha e vedada o melhor possível com silicone de alta temperatura.  Na porta 

foi aplicado um vedante para tentar manter um ambiente inerte no interior. 

  

Figura 30 – Sistema da varredora e camara de produção exposta 
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3.1.3 Quadro Elétrico 

O quadro elétrico (Figura 31), cujo esquema elétrico se encontra em Anexo B, tem como 

principais componentes uma placa NI cDAQ (Compact data aquisition), os controladores dos 

motores de passo das mesas e o variador de velocidade da varredora. 

 

 

A placa NI cDAQ, modelo NI 9174 (Figura 32) é um sistema modular de aquisição de dados 

e controlo que comanda o sistema da varredora, mesas de pó e produção. A NI 9174 está 

equipada com os módulos NI 9401 e NI 9403 (Figura 33) com 8 e 32 entradas e saídas digitais 

respetivamente. A NI 9401 foi instalada posteriormente quando foi determinado que a NI 9403 

não conseguia criar os sinais PWM (Pulse Width Modulation) necessários para os controladores 

dos motores de passo.  

 

Figura 31 – Quadro elétrico  

Figura 32 – NI 9174 30  
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Este conjunto NI cDAQ comunica com o computador, onde se encontra a interface LabView 

para o controlar, que irá ser abordada num próximo capítulo, através de um cabo USB. 

 

Os controladores dos motores de passo comandam os motores da mesa de pó e construção 

recebendo sinais da NI 9401 e da NI 9403. 

 

Para controlar a mesa de produção é utilizado um controlador CL54T (Figura 34) da marca 

StepperOnline, este opera sob o princípio que cada pulso que receba nos seus canais Pull+/Pull- 

equivale a um certo grau de rotação segundo a direção definida por Dir+/Dir- e somente 

quando o sinal Enable+/Enable- está ativo. 

Existem dois destes controladores no interior do quadro elétrico e possuem uma interface 

RS485 para a sua configuração, para além dos interruptores de configuração neles presentes. 

  

Figura 33 – NI 940331 

Figura 34 – Controlador de 

motor de passo CL57T 32 
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O variador de velocidade RS510 3PH-440V-1.5kW da marca RS-PRO controla o motor 

trifásico da varredora, recebe sinais da NI 9403 para avançar ou recuar a varredora e tem os 

seus parâmetros de arranque e velocidade configurados internamente (Figura 35).  Os fins de 

curso da varredora limitam diretamente este variador de velocidade. 

 

 

Existem no total 5 fontes de alimentação no quadro elétrico. São duas fontes MeanWell, de 

5V e 48V, a de 5V para os sinais digitais e a de 48V para alimentar a cabeça galvanométrica; 

uma fonte de 24V que alimenta o sistema NI cDAQ; e duas fontes da marca StepperOnline de 

24V e 48V que alimentam os controladores das mesas de construção e pó respetivamente. 

 

3.1.4 Sistema de controlo 

 

A nível de controlo existem dois sistemas a controlar, a NI cDAQ, que controla o sistema 

motor da máquina, e o sistema laser composto por IPG e AM Module. A NI cDAQ é controlada 

pelo computador local através de um cabo USB e o sistema IPG e AM Module são controlados 

pela placa SP-ICE3 que se encontra instalada no mesmo computador. Posteriormente irão ser 

abordados os softwares de cada sistema.  

 

 

 

Figura 35 – Variador de Velocidade RS Pro 33 
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A NI cDAQ comunica por USB com o computador que opera o programa LabView 20. 

O programa LabView tem 2 modos de operação principais, automático e manual, sendo que 

até à data a máquina somente conseguiu operar em modo manual, nunca tendo sido testado o 

automático (Figura 36). O modo automático baseia-se na iteração de uma camada sempre que 

o software do laser o requisitar. O modo manual permite a operação manual de todos os 

sistemas ligados a NI cDAQ.  

 

  

Figura 36 – Sinótico LabView 
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A placa SP-ICE 3 é a placa que controla o sistema laser da máquina. Está instalada no 

computador e pode ser configurada usando o programa NIConfig. O software para a sua 

operação é o WeldMark 3 (Figura 37), que permite importar ou desenhar geometrias que 

depois irão ser executadas pelo sistema laser. A SP-ICE 3 conecta com o laser IPG através da 

ficha X907 e com o a cabeça galvanométrica através da X904 e X905 (Figura 38).  

  

Figura 37 – Software WeldMark 3 
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3.2 Afinações e alterações feitas na máquina 

 

 

No início desta dissertação, havia ainda sistemas que não estavam operacionais e outros 

que necessitavam de ser refeitos. O principal em falta era atribuir ao sistema de controlo da SP 

ICE 3 a capacidade de ligar e desligar o feixe de laser, estabelecendo a comunicação entre a 

placa SP ICE 3 e a fonte do Laser IPG. Após o estabelecida a comunicação foi necessário 

determinar o ponto focal da cabeça galvanométrica e efetuar a sua calibração. 

 

 

  

Figura 38 – Entradas e saídas da placa SP ICE 3 da 

Raylase  
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3.2.1 Comunicação SP ICE 3 IPG 

 

Para estabelecer a comunicação teve de ser solicitada ajuda ao fabricante, Raylase, e ao 

vendedor de ambos estes componentes, Lasermaq Lda. Foi necessário aceder à interface do 

laser IPG pela sua ficha RJ45 e configurados os parâmetros (Figura 39), no browser do 

computador. Para criar a ligação física de comunicação entre a SP-ICE 3 e o Laser IPG foi 

seguido o manual enviado pelo fabricante em Anexo A.   

 

  

Figura 39 – Configurações do Laser IPG 
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3.2.2 Distância focal 

 

Uma vez estabelecida a comunicação com a fonte do laser foi possível para o sistema de 

controlo operar o laser e a cabeça galvanométrica e foram feitos alguns ensaios. Verificou-se 

que o laser somente marcava as chapas colocadas na mesa de produção utilizando uma 

potência superior a 50 %. Segundo indicações do fabricante, este laser deveria conseguir 

marcar o metal com potências em torno de 15 %. Como isto não se verificou tentou-se 

determinar se o laser estava focado. Para tal, foi ativado o laser e movimentada uma chapa para 

cima e baixo ao longo do feixe, observado a intensidade da luz emitida pela chapa, e assim foi 

possível visualizar que o local de intensidade máxima não era na superfície da mesa de 

produção, mas sim aproximadamente 150 mm acima do nível da mesa. Conclui-se assim que a 

distância focal desta cabeça galvanométrica não era a inicialmente considerada na construção 

da máquina. Para se poder operar este sistema seria então necessário determinar a distância 

focal e posteriormente alterar a distância entre a mesa de produção e a cabeça galvanométrica 

de forma a acomodar a distância focal correta. 

 

A distância focal de uma lente é a distância entre a lente e o ponto onde a luz que ela 

converge tem o menor diâmetro. Na Figura 40 é possível ver a representação gráfica deste 

fenómeno, onde se observa uma convergência até ao ponto focal e uma divergência após o 

mesmo. Visto que se trata de um laser pode-se assumir que a densidade energética é máxima 

no ponto focal e o diâmetro do feixe mínimo.  

 

 

Figura 40 – Ponto e distância focal 34 
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Para determinar a distância focal da cabeça galvanométrica, foi utilizado o seguinte método 

experimental  

 

 

 Colocar uma chapa de aço inoxidável a uma determinada cota acima da mesa de 

produção; 

 Executar a marcação dos caracteres e linhas e geometrias correspondentes à cota 0 mm 

(Figura 41); 

 Baixar a mesa de suporte da chapa em teste 2 mm, no sentido de se afastar da emissão 

do laser, ou seja, aumentando a distância entre a chapa e a cabeça galvanométrica; 

 Executar novamente a marcação correspondente à cota (“2 mm”) a que a chapa se 

encontra (Figura 41); 

 Repetição do processo de baixar a chapa e de marcação da mesma. (4, 6, 8, .. mm); 

 Retirar a chapa marcada e analisar visualmente, a olho nu, a existência e qualidade das 

marcações nas diferentes cotas; 

 Interpretação dos resultados obtidos 

o Tendo em consideração que o diâmetro do feixe é mínimo e a sua densidade 

energética máxima no ponto focal pode-se concluir que na cota da distância 

focal as marcações irão ser mais definidas e com maior intensidade; 

 Realização de um novo teste com potências e cotas iniciais diferentes; 

 

 

Figura 41 – Padrão de teste  
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Visto que as marcações que iriam ser feitas na chapa ocupam uma determinada área no 

campo de trabalho do laser foi feito um teste para aferir se o laser fazia marcações homogéneas 

nessa zona. Como é possível observar na Figura 41 e na Figura 42 as marcações são 

homogéneas em toda a área. 

 

No teste 5 foi feito um varrimento que iniciou a uma cota de 148 mm e com 20 % de 

potência. Como é possível verificar na Figura 43 as marcações tornam-se mais pronunciadas 

ao logo do varrimento, assumindo-se assim que o feixe está a convergir ao longo deste teste, 

no entanto não é possível verificar a divergência do mesmo. 

Figura 42 – Teste 6 

Figura 43- Teste 5 



35 

 

 

 

Considerando que no Teste 5 não foi possível verificar a divergência do laser no teste 7 

(Figura 44) foi reduzida a cota da posição inicial de forma a se poder identificar a convergência 

e divergência do feixe laser. Embora seja notável alguma maior definição dos resultados entre 

4 mm e 10 mm abaixo da cota inicial não é facilmente identificável quais apresentam maior 

intensidade. 

 

O teste 8 (Figura 45) foi executado com a mesma potência do teste 5 e 7, no entanto com 

uma cota inicial ainda inferior à do teste 7, numa tentativa de observar a divergência do feixe. 

No entanto não foi possível retirar conclusões.  

 

Figura 44 – Teste 7 

Figura 45 – Teste 8  
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Observando os resultados dos três testes apresentados, conclui-se que não era facilmente 

visualizável a diferença das marcações, então foi reduzida a potência de 20 % para 15 %. 

 

Na Figura 46 é possível visualizar o teste 9, executado a 15 % de potência do laser, que 

iniciou a 148 mm acima da mesa de produção. É notável que as marcações entre 12 mm e 16 

mm abaixo da cota de início são mais visíveis, no entanto não é possível observar a divergência 

visto que o teste acaba na cota menos 16 mm.  

   

 

Foi então reduzida a cota de início do teste para 142 mm no teste 10.1 (Figura 47), 

executado também com 15 % de potência. É possível verificar uma clara convergência e 

divergência do feixe e que a maior intensidade se apresenta entre 4 mm e 14 mm abaixo da 

cota inicial.  

Figura 46 – Teste 9 

Figura 47 -Teste 10.1 
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Este teste foi repetido mais uma vez para assegurar a exatidão dos resultados (Figura 48). 

 

Também foram executados testes com menores potências de forma a tentar determinar 

com mais precisão o ponto focal, mas conclui-se que com potências inferiores a 15 % e com 

uma velocidade de 100 mm/s já não era possível ver nenhuma marcação na chapa.  

 

 Analisando os dados retirados dos testes foi construída a Tabela 1 com os dados da cota 

de início do teste e as cotas máximas e mínimas do início da convergência e da divergência do 

feixe laser. Conclui-se então que o ponto focal se encontrava aproximadamente 133 mm acima 

da mesa de produção. Este valor foi comunicado ao fabricante que criou um ficheiro de 

calibração que posteriormente foi inserido nas configurações do WeldMark. 

 

Tabela 1 – Resultados dos testes do ponto focal 

 

Teste Potência Velocidade 
[mm/s] 

Início 
[mm] 

Min. 
[mm] 

Max. 
[mm] 

Ponto 
Focal 
[mm] 

Teste 5 20% 100 148 Inconclusivo 
 

Teste 7 20% 100 142 Inconclusivo 
 

Teste 8 20% 100 138 Inconclusivo 
 

Teste 9 15% 100 148 12 16 134 
Teste 10.1 15% 100 142 4 14 133 
Teste 10.2 15% 100 142 4 14 133 
Teste 11 12.5% 100 142 Não visível 

 

Figura 48 – Teste 10.2 
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Com os resultados deste ensaio o fabricante determinou que, possivelmente, a distância 

focal deste AM module seria de 470 mm. Com esta informação o apoio do AM module foi 

alterado de forma a posicionar esta cabeça galvanométrica 470 mm acima da mesa de 

produção (Figura 49). 

 

 

3.2.3 Calibração do AM Module 

Neste capítulo ir-se-á abordar como foi executada e como se procedeu à calibração do AM 

Module. 

 

Para assegurar o correto funcionamento do sistema laser é necessário afinar os parâmetros do 

mesmo, nomeadamente aqueles referentes ao AM Module da Raylase. O ajuste do AM module 

foca-se em dois aspetos principais, a calibração do eixo Z, que calibra o foco do laser e a 

calibração XY que compensa a distorção do feixe laser ao longo da área de trabalho.  

 

A calibração do eixo Z faz-se com um offset global de Z, que determina uma posição ideal única 

para a lente do Z que depois se aplicará a toda a área de trabalho, ou com uma calibração 

“Multipoint Z”, em que se determina uma posição da lente de Z para vários pontos em toda a 

área da mesa de produção. 

 

A calibração dos eixos XY corrige as deformações causadas pelos espelhos XY e pela lente F-

Theta, esta calibração pode ou ser feita com o uso de um simples ganho que determina um valor 

Figura 49 – AM Module com suporte modificado 
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para escalar os objetos a projetar conforme se afastam do centro da mesa de produção, ou com 

uso a um XY-Multipoint em que é definido um ganho e escala para vários pontos em toda a área 

da mesa de produção. 

 

 

Neste trabalho a calibração do Z foi feita usando um offset global de Z, dado à pequena área de 

trabalho do laser, e um XY-Multipoint, para garantir a precisão do laser nos extremos da área 

de trabalho. 

  

Figura 50 – Distorções do campo de trabalho  
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3.2.3.1 Calibração do eixo/lente Z 

 

 

O primeiro passo para a calibração do sistema AM module é garantir que a face inferior do 

AM module se encontra a uma distância de 470 mm da mesa de trabalho, com uma tolerância 

inferior a 2 mm. Caso esta distância esteja errada ou o AM module não esteja paralelo à mesa 

de trabalho serão visíveis assimetrias no mapa de correção XY que se abordará na calibração 

XY-Multipoint. Para proceder à afinação desta distância foram usados os parafusos de afinação 

localizados no suporte do AM module (Figura 51) e um esquadro. 

 

Após garantir que o AM module se encontra paralelo e a 470 mm da mesa de trabalho 

desenhou-se um quadrado no software WeldMark 3, e projetou-se o laser sobre uma folha 

previamente impressa a preto com uma potência de entre 13 % a 15 % com variadas 

velocidades até se encontrar uma velocidade em que o quadrado ficasse melhor visível (Figura 

52). 

 

Figura 51 – Mecanismo de ajuste da distância focal 

Figura 52 – Ensaios sobre folhas impressas a preto 
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Quando encontrada uma configuração de velocidade e potência em que se visualiza bem o 

quadrado, estes parâmetros (velocidade e potência) devem ser inseridos no “Test Pattern” , 

canto superior direito da Figura 53. A sequência de parametrização continua com o seguinte: 

 “Current Job”->”SP-ICE 3”->” 2D_ASV-30-Y_0300-1200HP_364_WD470” 

 Selecionar “Calibrate” 

 Selecionar “No” na “Multipoint correction” 

 Selecionar “Yes” no “Fine Focal Point adjustment”.  

 

 

Uma vez aberta a configuração do ponto focal e selecionado “Change Lens Offset” deve ser 

incrementado o valor de “Lens Offset” em valores de 0.05 mm a 0.1 mm fazendo várias 

marcações com “Mark center test pattern”, movimentando a folha após cada marcação (Figura 

54). No final deve ser selecionado o valor de “Z-Lens-Offset” em que a marcação do quadrado 

se tornou mais nítida.  

Figura 53 – Ajuste do ponto focal no software WeldMark 3 



42 

 

 

 

 

3.2.3.2 Calibração dos Eixos XY 

 

Após concluída a calibração da Lente Z é possível passar à calibração dos eixos XY, sendo 

que para este ajuste é necessária a ferramenta “Multipoint Editor” da Raylase. Esta 

calibração esta detalhada em 21 . 

 

O primeiro passo é arrancar com o software “MultiPoint Editor” e aí abrir o ficheiro de 

calibração do AM Module (C:\ProgramData\Raylase\Correction Files\2D_ASV-30-Y_0300-

1200HP_364_WD470.fc3). Os passos seguintes são: 

  fazer “Discover” 

 conectar a Placa SP-ICE3 

Uma vez ligado à placa SP-ICE3 e com o ficheiro de calibração aberto passa-se à 

configuração da marcação, usando o parâmetro “Z Lines” no “Pattern” e 9X9 como “Grid 

Points”, deixando todos os restantes parâmetros inalterados somente inserido o “Mark  

Figura 54 – Calibration Wizard 
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Speed” e “Power” que também foram usados na calibração da lente Z. Para proceder à 

marcação basta armar o laser e proceder à marcação. (Figura 55) 

 

Uma vez feita a marcação, poderá passar-se à medição do comprimento das linhas Z e inserir 

os seus resultados premindo em “New Measurment tables” e inserindo o valor das medições 

nos respetivos locais. Posteriormente carregando em “Apply”, depois guardando o novo 

ficheiro de correção com um nome diferente do original. 

 

Uma vez concluído este processo, o mesmo deve ser repetido duas a três vezes para assegurar 

que a calibração foi bem feita. No final, quando os resultados forem consistentes, deve ser 

carregado o novo ficheiro de correção no software WeldMark, através da opção “Change”. 

(Figura 56). 

 

Figura 55 – Calibração XY com MultiPoint Editor 
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Uma vez ajustada a distância focal entre a mesa de produção e a cabeça galvanométrica 

foram feitos ensaios com pós metálicos. Espalhou-se manualmente o pó de aço inoxidável 

(Figura 57) MetcoAdd 316L -A da empresa Oerlikon metco (Figura 59) sobre uma chapa de aço 

macio, com espessuras de aproximadamente 50 μm e foram testadas varias velocidades e 

potências laser (Figura 58). 

 

 

Figura 56 – Seleção do ficheiro de correção  

Figura 57 – Pó metálico espalhado sobre uma chapa de aço macio 



45 

 

 

 

 

Após se ensaiarem com várias velocidades e potências foi possível obter excelentes 

resultados usando 40 % de potência e uma velocidade de 100 mm/s (Figura 60). 

 

Figura 59 – Pó MetcoAdd 316L -A 

Figura 58 – Pós metálicos fundidos 
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Na Figura 61 é possível observar o pó fundido ao microscópio ótico. Trata-se de operar o 

laser contínuo de fibra de itérbio de 200 W, usando apenas 40% de potência à velocidade de 

varrimento do feixe de 100 mm/s, em impressão numa camada de aproximadamente 50 μm. 

 

Tendo sido provado que o equipamento consegue fundir pó metálico de aço inoxidável AISI 

316L importa explicar o funcionamento do equipamento (secção seguinte). 

Figura 60 – Escrita com pó metálico 

Figura 61 – Escrita com pó 

metálico ao microscópio ótico 
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3.3 Método de operação da máquina 

 

A máquina de fabrico aditivo encontra-se agora operacional em modo manual. O processo 

de funcionamento é o seguinte 

 

 Ligar o seccionador geral que está no quadro elétrico da máquina, certificando-se 

que o botão de emergência não está premido. De facto, sempre que a luz dos leds 

indicadores de segurança estiver ligada, tal significa que a máquina está em 

paragem de emergência. Se for o caso, carregar no botão verde (operadores do 

sistema de segurança – Figura 63) para a colocar novamente em funcionamento.  

 Ligar o sistema de refrigeração (chiller) CW-3000 da cabeça 

galvanométrica (Figura 62) 

 

 

 

 

Figura 62 – Quadro Elétrico 
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 Ligar o laser em modo “Remote” rodando a chave para o lado 

esquerdo, Figura 64, e premindo o botão “Ativar fonte laser” (Figura 

63). 

 Ligar o computador 

 Iniciar os programas WeldMark e “LabView MFA”, que se 

encontram no ambiente de trabalho. 

 

Figura 63 – Sistema de 

refrigeração CW-3000 
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O programa elaborado em Labview está já com janelas preparadas para vários tipos de 

funcionamento, no entanto, neste documento somente o modo manual será abordado pois é o 

único completamente funcional. Assim, após arranque do programa o primeiro passo consiste 

em selecionar o modo “manual” na página “Sinóptico”. Seguidamente descrevem-se as várias 

aplicações necessárias ao processamento: 

 

 Movimentação das plataformas de pó e construção 

 

i. Selecionar a página da plataforma que se tenciona operar “Plataforma 

de Pó” ou “Plataforma de Construção” (Figura 65) 

ii. Selecionar “Enable Motor” 

iii. Definir o sentido do movimento 

iv. Definir a distância a percorrer 

v. Definir a velocidade (ex: 2000 Hz, mais detalhes em Anexo C) 

vi. Selecionar “Fazer movimento pó” e com isso dá-se o movimento 

vii. Desselecionar “Enable motor”  

Figura 64 – Gerador laser IPG 

YLR-200-AC 
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O acionamento mecânico das mesas é efetuado por um sistema motor-acoplamento rígido-fuso 

de aço-porca de bronze. Naturalmente, há folga na ligação fuso/porca, pelo que se deve ter em 

consideração este facto quando se fazem inversões de sentido. Obviamente, durante o 

movimento no mesmo sentido, que é o que se passa durante o fabrico aditivo propriamente 

dito, a folga não existe. 

 

 Movimento da varredora 

i. Selecionar a página da varredora 

ii. Para avançar a varredora pressionar “Avançar” 

iii. Para recuar a varredora pressionar “Recuar” 

iv. Os indicadores luminosos indicam o estado dos sensores fins de curso 

da varredora (Figura 66) 

O software Weldmark está amplamente documentado em Anexo D. A utilização básica do 

programa e a marcação de peças faz-se da seguinte forma: 

Figura 65 – Subida e descida das mesas no software LabView 

Figura 66 – Movimento da Varredora 
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  Iniciar o Software Weldmark 3 (Figura 67) 

  Desenhar a geometria pretendida usando as Ferramentas de Desenho 

e opção de “Dimensões” e alterar parâmetros laser em “Propriedades” 

(25 % e 250 mm/s são o suficiente para marcar metais tais como o aço 

macio e o inoxidável). 

  Iniciar a fonte do laser pressionado o botão “Ativar fonte laser” que se 

encontra no quadro elétrico da máquina (Figura 63).  A fonte do laser 

deve apresentar uma luz verde.  

  Ligar a emissão com o botão “Arm all lasers” / ”Emission Enable” no 

software. A fonte do laser deverá nessa altura ter uma luz cor de laranja 

ligada, que indica que o laser está pronto a disparar. 

  Selecionar a opção QuickMark. A marcação é efetuada. 

  Desativar o sistema abrindo a porta da máquina ou pressionando o 

botão de emergência. 

 

 

Para desligar a máquina a sequência consiste em desligar a fonte do laser, o computador, o 

Sistema de refrigeração e por fim o seccionador geral.  

Figura 67 – Software WeldMark 3 com descritivos 
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4.  Conclusão 

 

Este trabalho relatou uma parte do processo de evolução da máquina de fabrico aditivo 

desenvolvida e concebida no Departamento de Engenharia Mecânica da Universidade de 

Aveiro, da sua melhoria, as suas oportunidades de melhoria e a sua calibração e afinação. 

 

As principais conclusões são as seguintes: 

 Foi determinado o ponto focal do laser e efetuada a sua calibração, pelo que esta 

dissertação poderá servir como guia para ajustes futuros da máquina.  

 É possível operar a máquina em modo manual e fundir uma camada de pó de aço AISI 

316 sobre uma chapa de aço macio.  

 Com laser contínuo de fibra de itérbio de 200 W, usando apenas 40% de potência à 

velocidade de varrimento do feixe de 100 mm/s, o resultado visual da impressão numa 

camada de aproximadamente 50 μm é de excelente qualidade, conforme visível na 

Figura 61. 

 A máquina conseguiu obter excelentes resultados visuais na deposição de uma camada 

metálica, mesmo sem qualquer gás de proteção. Naturalmente, poderão existir 

problemas de porosidade ou oxidação que não foram explorados. A olho nu, o resultado 

está perfeito. 

 

Em suma, cumpriu-se os objetivos de colocar em operação o sistema laser da máquina e da sua 

calibração, bem como se validou a capacidade de máquina de fundir pó metálico de aço 

inoxidável AISI 316.  

 

Numa perspetiva de continuidade do desenvolvimento da máquina nos seguintes 

parágrafos irão ser abordados alguns pendentes da máquina, bem como propostas de melhoria 

para trabalhos futuros. 

Para ocorrer a fusão de pós na máquina é necessário que a espessura da camada de pó seja 

controlada, para isso é importante colocar em operação o sistema de zeros máquina que se 

encontra instalado, mas, no entanto, não se encontra operacional. 

Para garantir uma camada de pó homogénea também irá ser necessário fazer alterações ao 

sistema da varredora visto que o atual não se mantém paralelo à mesa, desgastando-a e criando 

uma camada irregular (Figura 27). 



53 

 

 

Em relação à mesa de produção existe um problema de nivelamento idêntico, pelo que seria 

útil a alteração da mesa atual de forma a possibilitar o seu nivelamento. O sistema de 

nivelamento pode ser tão simples como o apresentado na Figura 68, o qual consiste na adição 

de 2 parafusos à mesa atual de forma a se poder nivelar a mesa com 4 parafusos. 

 

   

Quanto ao software de controlo ainda está pendente a integração do LabView com o software 

WeldMark, para ser possível operar a máquina em modo automático. 

Figura 68 – Proposta de sistema de nivelamento da 

mesa de produção 
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6. Anexos 

 

 

Anexo A: Manual Ligação IPG SP ICE 3 
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Anexo B:  Esquema Eletrico 
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CL57T(V3.0) Closed-loop Stepper Driver

Notice
Read this manual carefully before any assembling and using. Incorrect handling of products in this manual
can result in injury and damage to persons and machinery. Strictly adhere to the technical information
regarding installation requirements.

This manual is not for use or disclosure outsides of STEPPERONLINE except under permission. All rights
are reserved. No part of this manual shall be reproduced, stored in retrieval form, or transmitted by any
means, electronic, mechanical, photocopying, recording, or otherwise without approval from
STEPPERONLINE. While every precaution has been taken in the preparation of the
book,STEPPERONLINE assumes no responsibility for errors or omissions.
Neither is any liability assumed for damages resulting from the use of the information contained herein.

This document is proprietary information of STEPPERONLINE that is furnished for customer use ONLY.
Information in this document is subject to change without notice and does not represent a commitment on the
part of STEPPERONLINE. Therefore, information contained in this manual may be updated from time-to time
due to product improvements, etc., and may not conform in every respect to former issues.
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1. Introductions
This Closed Loop Stepper Driver, offers an alternative for applications requiring higher performance and
higher reliability than open loop stepper system, and it remains cost-effective. The matched stepper motors
are NEMA17,23 and 24 combined with an internal encoder which is used to close the position, velocity and
current loops in real time.

1.1 Features

 Input voltage 24-48VDC, output peak current 0-8.0A
 Closed-loop, eliminates loss of synchronization
 No Tuning and always stable
 Do not need a high torque margin
 Broader operating speed range
 Reduced motor heating and more efficient
 Smooth motion and super-low motor noise
 Protections for over-voltage, over-current and position following error

1.2 Applications

Its great features of quicker response and no hunting make STEPPERONLINE’s closed loop stepper driver is
ideal for applications such as bonding and vision systems in which rapid motions with a short distance are
required and hunting would be a problem. And it is ideal for applications where the equipment uses a
belt-drive mechanism or otherwise has low rigidity and you don't want it to vibrate when stopping.

2. Specifications

2.1 Electrical Specifications

Parameters
CL57T

Min Typical Max Unit
Output Current 0 - 8 A
Supply Voltage 24 36 48 VDC

Logic signal current 7 10 16 mA
Pulse input frequency 0 - 200 kHz
Minimal pulse width 2.5 - - μS

Minimal direction setup 5.0 - - μS
Isolation resistance 500 MΩ

2.2 Environment

Cooling Natural Cooling or Forced cooling

Operating Environment

Environment Avoid dust, oil fog and corrosive gases
Ambient Temperature 0°C － 65°C (32°F - 149°F)

Humidity 40%RH－90%RH
Operating Temperature 0°C － 50°C (32°F - 122°F)

Vibration 10-50Hz / 0.15mm
Storage Temperature -20°C － 65°C (-4°F - 149°F)

Weight Approx. 280 g (9.9 oz)
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2.3 Mechanical Specifications

(unit: mm [1inch=25.4mm])

Figure 1: Mechanical specifications
* Side mounting recommended for better heat dissipation

2.4 Elimination of Heat

 CL57T reliable working temperature should be < 60℃ (140°F)
 It is recommended to mount the drive vertically to maximize heat sink area. Use forced cooling method

to cool if necessary.

3. Connection Interface and LED Indication

The CL57T has four connector blocks P1&P2&P3&P4 (see above picture). P1 is for control signals
connections, P2 is for power and motor connections, P3 is for encoder signals input connections, and P4 is
for connecting with PC tuning software. The following tables are brief descriptions of the four connectors.
More detailed descriptions of the pins and related issues are presented in section 4, 5, 9.
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3.1 Connector P1 Interface

3.1.1 Pin Assignments of P1

Pin Name I/O Details

PUL+ I
Pulse signal:
(1) In single pulse (pulse & direction) control mode, this input represents pulse signal.
A pulse signal is active at the rising or falling voltage edge (set by DIP switch SW8).
(2) In double-pulse (CW/CCW) control mode (set by DIP switch SW7), this signal input
represents clockwise (CW) pulse, and is active at both high voltage level and low
voltage level.
(3) 4.5-5V for voltage HIGH, 0-0.5V for voltage LOW (same for DIR signals).
(4) Pulse width should be set to 2.5μs or longer.

PUL- I

DIR+ I
Direction signal:
(1) . In single pulse (step & direction) control mode, this signal’s low and high voltage
levels represent the two directions of motor rotation (e.g. clockwise and
counterclockwise).
(2) In double-pulse (CW & CCW) control mode, this signal represents counterclockwise
(CCW) rotation. It is active at both voltage high level and low level.
(3) Minimal DIR signal setup time should be at least 5μs.
(4) You can reverse the default rotation direction by toggling the SW5 DIP switch.

DIR- I

ENA+ I
Enable signal: This signal is used for enabling/disabling the drive. High voltage level of
4.5-24VDC (NPN control signal) for enabling the drive and low voltage level of
0-0.5VDC for disabling the drive. PNP and Differential control signals are on the
contrary, namely Low level for enabling. By default this signal is left UNCONNECTED
& ENABLED.

ENA- I

ALM+ O Configurable Digital Output Signal: A configurable OC output signal. It takes a sinking
or sourcing 20mA current at 5-24V. It can to be configured as one of the 3 types,
ALARM (default), IN POSITION, or BRAKE CONTROL through PC software.ALM- O

!
Notice Notes: (1) shielding control signal wires is suggested;

(2) To avoid interference, don’t tie PUL/DIR control signal and motor wires together;

3.1.2 Control Signal Wiring(P1)

The CL57T can accept differential and single-ended inputs (including open-collector and PNP output). The

CL57T has 3 optically isolated logic inputs which are located on connector P1 to accept line drive control

signals. These inputs are isolated to minimize or eliminate electrical noises coupled with the drive control

signals. Recommend using line drive control signals to increase noise immunity for the drive in interference

environments. In the following figures, connections to open-collector and PNP signals are illustrated.
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Figure 2: Connections to PNP signal Figure 3: Connections to open-collector signal
(common-cathode) (common-anode)

3.2 Connector P2

3.2.1 Pin Assignments of P2

Pin Name Details

A+, A- Motor Phase A connections. Connect motor A+ wire to A+ Pin; motor A- wire to A-

B+, B- Motor Phase B connections. Connect motor B+ wire to B+ Pin; motor B- wire to B-

+Vdc Power supply positive connection. Suggest 24-48VDC power supply voltage

GND Power supply ground connection.

!
Warning Warning: Don’t plug or unplug the P1 & P2 terminal block to avoid drive damage or injury when

CL57T is powered on.

3.2.2 Motor and Power Supply Wiring(P2)

The CL57T can drive NEMA17, 23 and 24 closed loop stepper motor with encoder resolution of 1000 ppr.
The current loop PID will be adjusted automatically regarding to function of motor auto-identification and
parameter auto-configuration, to output optimal torque from wide-range motors. However, the user can also
configure the current in the tuning software. The configurable parameters include motor peak current, closed
loop holding current, micro step and etc.

!
Warning Warning: For NEMA17 closed loop motor, need to change the value of motor peak current from 80 to 30,

if not, it will burning the motor as too high current output.
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3.3 Connector P3

Drive Pin Name Description
EB+ Encoder B+ input
EB- Encoder B- input
EA+ Encoder A+ input
VCC +5V power output
EGND Signal ground

3.4 Connector P4

It is a RS232 communication port using to connect with PC software to configure the motor peak current,
closed loop holding current, microstep, active level.

RS232 Communication Port – RJ11
Pin Name I/O Description
1 NC - Not connected.
2 +5V O +5V power output.
3 TxD O RS232 transmit.
4 GND GND Ground.
5 RxD I RS232 receive.
6 NC - Not connected.

3.5 LED Light Indication

There are two LED lights for CL57T. The GREEN one is the power indicator which will be always on generally.
The RED one is a protection indicator which will flash 1,2 or 7 times in a 5-second period, when protection
enabled for a CL57T. Different number of flashes indicates different protection type (read section 8 for detail).

4. Power Supply Selection

The CL57T can power medium and small size closed loop stepper motors (frame size from NEMA17 to 34).
To get good driving performances, it is important to select supply voltage and output current(by configuring
motor peak current) properly. Generally speaking, supply voltage determines the high speed performance of
the motor, while output current determines the output torque of the driven motor (particularly at lower speed).
Higher supply voltage will allow higher motor speed to be achieved, at the price of more noise and heating. If
the motion speed requirement is low, it’s better to use lower supply voltage to decrease noise, heating and
improve reliability.

4.1 Regulated or Unregulated Power Supply

Both regulated and unregulated power supplies can be used to supply the driver. However, unregulated
power supplies are preferred due to their ability to withstand current surge and fast response for current
change. If you prefer to a regulated power supply, it is suggested to choose such a power supply specially
designed for stepper/servo controls Or, in the case when only normal switching power supplies are available,
it is important to use “OVERSIZE” high current output rating power supplies (for example, using a 4A power
supply for 3A stepper motor) to avoid problems such as cunt clamp. On the other hand, if unregulated supply
is used, one may use a power supply of lower current rating than that of motor (typically 50%～70% of motor
current). The reason is that the driver draws current from the power supply capacitor of the unregulated
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supply only during the ON duration of the PWM cycle, but not during the OFF duration. Therefore, the
average current withdrawn from power supply is considerably less than motor current. For example, two 3A
motors can be well supplied by one power supply of 4A rating.

4.2 Power Supply Sharing

Multiple CL57T drivers can share one power supply to reduce cost, if that power supply has enough power
capacity. To avoid cross interference, connect each stepper drive directly to the shared power supply
separately. To avoid cross interference, DO NOT daisy-chain connect the power supply input pins of the
Drivers. Instead connect them to power supply separately.

4.3 Selecting Supply Voltage

The CL57T is designed to operate within +24 - +48VDC voltage input. When selecting a power supply,
besides voltage from the power supply power line voltage fluctuation and back EMF voltage generated
during motor deceleration needs also to be taken into account. Ideally it is suggested to use a power supply
with the output of +36VDC, leaving room for power line voltage fluctuation and back -EMF.

Higher supply voltage can increase motor torque at higher speeds, thus helpful for avoiding losing steps.
However, higher voltage may cause bigger motor vibration at lower speed, and it may also cause
over-voltage protection or even driver damage. Therefore, it is suggested to choose only sufficiently high
supply voltage for intended applications.

5. DIP Switch Configurations
This drive uses an 8-bit DIP switch to set microstep resolution, motor direction, auto tuning switch and so on.

5.1 Microstep Resolution(SW1-SW4)

Microstep resolution is set by SW1, 2, 3, 4 of the DIP switches as shown in the following table:

Steps/Revolution SW1 SW2 SW3 SW4
Software Configured (Default 1600) on on on on

800 off on on on

1600 on off on on

3200 off off on on

6400 on on off on

12800 off on off on

25600 on off off on

51200 off off off on

1000 on on on off
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2000 off on on off

4000 on off on off

5000 off off on off

8000 on on off off

10000 off on off off

20000 on off off off

40000 off off off off

5.2 Other DIP Switch Setting(SW5-SW8)

Function On Off

SW5 Default Direction CW (clock-wise) CCW (counter-clock-wise)

SW6 Auto Tuning No Yes

SW7 Pulse Model CW/CCW(double pulse) PUL/DIR(single pulse)

SW8 Pulse Edge Falling Rising

!
Notice Notes: (1) The factory setting of DIP switch are ‘on off on on off off off off’;

(2) The default direction is related to the DIR level, you can toggle SW5 to change it .

6. Typical Connection

A complete closed loop stepper system should include closed loop motor, drive, power supply and controller
(pulse generator). A typical connection is shown as figure 4.

Figure 4: Typical connection
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7. Sequence Chart of Control Signals

In order to avoid some fault operations and deviations, PUL, DIR and ENA should abide by some rules,
shown as following diagram:

Figure 5: Sequence chart of control signals

Remark:
a）t1: ENAmust be ahead of DIR by at least 5s.. Usually, ENA+ and ENA- are NC (not connected). See
“Connector P1 Configurations” for more information.
b) t2: DIR must be ahead of PUL effective edge by 5s to ensure correct direction;
c) t3: Pulse width not less than 2.5s;
d) t4: Low level width not less than 2.5s.
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8. Protection and Troubleshooting

To improve reliability, the drive incorporates some built-in protections features.

Blink
time(s)

Sequence wave of red LED Description Trouble shooting

1
0.2S

5S

Over-current
Turn off the power immediately.
a) Check wiring is short-circuited or not;
b) b) Check motor is short-circuited or not.

2
0.2S0.3S

5S

Over-voltage
Turn off the power immediately.
a) Check if the power voltage is higher
than over-voltage point

3 Chip error
Restart the power supply, if the drive is still
alarm, please contact after-sale

4
Fail to lock
motor shaft

a) The drive is not connected to a motor;
b) If alarm is occurred when connect a
motor , set DIP switch SW6 to ‘on’ and
restart power supply; If it still alarm, please
check the motor power cable.

5
EEPROM
error

Restart the power supply, if the drive is still
alarm, please contact after-sale

6
Fail to auto
tuning

Set DIP switch SW6 to ‘on’

7
0.2S0.3S

5S Position
following error

a) The acceleration time setting is too
small,increase the value of appropriately;
b)Motor torque is not enough or motor
speed is too high;
b) Motor wiring error, check wiring

Always -
PCB board is
burned out

Contact after-sale
a) Power supply connection is wrong
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9. Warranty

STEPPERONLINE warrants its products against defects in materials and workmanship for a period of 12
months from shipment. During the warranty period, STEPPERONLINE will either, at its option, repair or
replace products which proved to be defective. To obtain warranty service, a returned material authorization
number (RMA) must be obtained before returning product for service.

Exclusions: The above warranty does not extend to any product damaged by reasons of improper or
inadequate handlings by customer, improper or inadequate customer wirings, unauthorized modification or
misuse, or operation beyond the electrical specifications of the product and/or operation beyond
environmental specifications for the product.

If your product fail during the warranty period, please contact your seller for how and where to ship the failed
product for warranty or repair services first,you can also e-mail at Technical@stepperonline.com to obtain a
returned material authorization number (RMA ) before returning product for service. Please include a written
description of the problem along with contact name and address.

mailto:technical@stepperonline.com


 

 

 

 

Anexo D:  Manual WeldMark  

 

 



Software Manual
weldMARK™ 3



This manual has been created by RAYLASE for their customers and employees.
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information contained herein without notice.
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1 INTRODUCTION
 

1.1 The weldMARK™ Software Package
 

1.1.1 Function overview
 

1.1.2 COM Automation Server API
 

1.1.3 TCP/IP test client
 

weldMARK™ is a powerful and flexible laser processing software suite. The software package 
sets new standards with its flexible, powerful and easy to learn user interface. It is easy for the 
user to create or import text, barcode or graphic elements and to use them to create a com-
plete marking job. Objects and laser-specific parameters can be edited with simple entries.

The weldMARK™ software package supports the following RAYLASE control cards: 
SP-ICE, SP-ICE-1 PCI PRO and RLC-USB.

The weldMARK™ software package consists of the following modules:

￭ weldMARK™ graphical user interface 
￭ COMServer (ActiveX) interface
￭ TCP/IP Test Client
￭ weldMARK™ COM-Tester

The sections below provide a brief description of these modules.

The following weldMARK™ functions are particularly important:

￭ Opening up to ten jobs simultaneously, easy selection of opened jobs with just one mouse 
click

￭ Support for various laser types, precise control of laser parameters
￭ Creation of linear, rectangular, polygonal, drill and Bezier objects
￭ Output of drill objects as single points or grid points
￭ Scaling, moving and rotation of objects on screen
￭ Use of objects as templates in the background for easy positioning of marking objects
￭ Import of wide types of vector and bitmap files
￭ Support for all TrueType™ fonts installed on the computer (displayed filled or as contour)
￭ Serialization functions for text and barcode objects
￭ Easy creation of automation scripts
￭ Programming of alarms, warnings, user entries for job numbers and batch numbers
￭ Control of rotary tables, XY tables or one-dimensional movements using the integrated 

4-Axis motor control
￭ Detection of object movements with an optional encoder
￭ Password protection: Restriction of users for performing pre-prepared jobs
￭ weldMARK™ includes all the elements and tools required for the integration into an auto-

mated process environment. Most procedures can efficiently be operated from within the 
program itself.

￭ Support of 2-Axis standard Scan Heads and 3-Axis subsystems (AXIALSCAN, AXIALSCAN 
motorized, FOCUSSHIFTER)

weldMARK™ provides a COM automation server interface. This enables external programs to 
access the library functions in weldMARK™. For more detailed information, refer to the 
COM-Server manual, which is available from RAYLASE.

The TCP/IP test client allows the weldMARK™ software's server interface to be tested by a 
remote computer. Any errors detected can be corrected over the network using the TCP/IP test 
client.

The Appendix includes instructions for starting and using the TCP/IP test client.
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1.1.4 weldMARK™ COM Sample Program
 

1.2 Laser Safety
 

 

1.3 Manufacturer
 

1.4 Customer Service
 

The weldMARK™ software is supplied with a COM sample program with source text. Use this 
simple COM automation server program as a template for programming your own application 
programs.

The user is responsible for safe operation and for safeguarding the surrounding area against 
hazards that can be caused by laser radiation. OEM customers must ensure compliance with 
all local and national regulations.

WARNING:
Turn on the PC before turning on the laser system. This prevents the laser from behaving in an 
uncontrolled manner when the PC is turned on.

Check your application carefully before using the laser system. Defective software can block 
the entire system and lead to uncontrolled operation of laser or Scan Head.

RAYLASE AG
Argelsrieder Feld 2-4
82234 Wessling
Germany
Tel.: +49 (0) 81 53 - 88 98 - 0
Fax: +49 (0) 81 53 - 88 98 - 10
http://www.raylase.de
E-mail: info@raylase.de

RAYLASE Customer Service can assist you with any queries or problems with the subsystem 
or this manual. Before contacting Customer Service, assure whether your question can be 
resolved with the provided instructions on CD.

If you need further assistance, you can contact RAYLASE Customer Service from Monday to 
Friday between 08:00 and 17:00.

Germany (Wessling)
Tel.: +49 (0) 81 53 - 88 98 – 0
E-Mail: support@raylase.de

...simply request the Customer Service
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2 REQUIREMENTS AND INSTALLATION
 

2.1 Hardware requirements
 

2.2 Software installation
 

2.3 Dongle Variations
 

This chapter provides you with an overview of the system requirements and the necessary 
steps to be taken to install weldMARK™.

The following hardware configuration is required at the least:

￭ Intel Pentium or compatible computer with operating system Windows Vista or 
Windows 7 (32bit).

￭ CD-ROM drive for installing the software
￭ 1024 MB RAM or more is recommended
￭ 150 MB free disk space on the local drive

To install weldMARK™ proceed with the following steps:

￮ Start your computer and log in as administrator.
￮ Insert the weldMARK™ installation CD in the CD-ROM drive.

The installation routine starts automatically.
￮ Click on the Software installation button and after that click on the Installation weldMARK button.
￮ Follow the instructions on the screen.

The weldMARK™ software runs with the supplied hardware key (dongle) only. The dongle is 
plugged into a free USB port on the computer. Every computer having weldMARK™ installed 
requires a separate dongle. The following table shows different dongle variations and the acti-
vated functional range.

Feature Standard Premium 3D

MARK + + +

RUN + + +

RUN FROM HARDWARE + + +

AUTOMATION + + +

CALIBRATION + + +

MOTF + +

PREVIEW MARK + + +

HOST-INTERFACE + + +

MULTIPLE CARDS + + +

SAVE TO CONTROLLER (Download to HW) + + +

MOTORCONTROL + + +

TILING + + +

POLYLINE, PREVIEW Outline, WS Rotation + + +

FOCUS SHIFTER + +

AXIALSCAN motorized + +

IPG LASER + + +

SPI LASER + + +

SERIAL LASER + + +
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BEZIER OBJECT + + +

NEW BITMAP ALGORITHMS + + +

NEW IMPORT FILTER + + +

LAYERS + + +

ANCHOR POINT + + +

MIRROR GROUP + + +

JOB DEPENDANT OFFSETS + + +

JOB WORKSPACE ROTATION + + +

FONT COMPILER (Tools) + + +

CORRECTION EDITOR (Tools) + + +

F-THETA COR (Tools) + + +

MASTER-SLAVE + +

Vector Graphic DESIGNER + + +

SKY WRITING + + +

GENERATE CORRECTION (3D) +

Digital Scan Heads + +

2.5D with Acial Scan Heads +

3D MARKING +

3rd Axis Multipoint Correction + +

SP-ICE 2 (MONITOR) + + +

MARK & PREVIEW + + +

FINE FOCAL POINT ADJUSTMENT + +

IMPORT TXT AS POLYLINE +

SPOT OFFSET + + +

TREPANNING +

DEEP CUTTING + +

Feature Standard Premium 3D
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3 INTRODUCTION TO THE SOFTWARE PACKAGE

3.1 Starting and Exiting weldMARK™

Starting weldMARK™
 

Exiting weldMARK™
￮ Select File >Exit.

3.2 Basic Concepts
 

Select Start >All Programs >RAYLASE >weldMARK. The program starts with the set access 
level ( ➜ page 24, Changing the Access Level).

When you start weldMARK™ a new job is created automatically. You can disable this and spec-
ify that weldMARK™ should start with a particular existing job. ( ➜ page 197, Settings for the 
Job File)

Marking objects Marking objects represent the graphical elements and texts to be marked by the 
laser.
The following object types are available in weldMARK™:
￭ Graphic objects, i.e. imported vector or bitmap graphics
￭ Line
￭ Rectangle
￭ Polygon
￭ Polyline
￭ Bezier
￭ Text
￭ Barcode...
￭ Drill...
￭ Vector-Object
➜ page 25, Working with Objects

Template A template is an object that won't be marked. For example, it can be used to align 
objects.
➜ page 118, Templates

Automation-Objects Automation objects allow communication with the user via dialogue windows and 
allow control of external components.
➜ page 25, Working with Objects

Profile Every marking object is assigned a profile, which specifies the parameters for the 
laser marking.
➜ page 135, Using Profiles

Job A job is a collection of objects and settings. The settings determine the actions of 
the Scan Head, the laser and the additional equipment.
➜ page 165, Job Settings, run Job
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3.3 Access levels
 

  

3.3.1 "All Editing Functions" Access Levels 

weldMARK™ has three access levels that allow different types of access to the software's 
functions. The program starts with the preset access level ( ➜ page 24, Changing the Access 
Level). When changing access levels, password protection can be applied ( ➜ page 203, 
System Security Settings).

Access levels Description

All editing functions All software functions can be used without restrictions.
➜ page 12, "All Editing Functions" Access Levels

Operator interface only Only saved jobs can be opened and executed. These jobs cannot be 
modified.
➜ page 22, "Operator interface only" Access Level

Touchscreen interface Only saved jobs can be opened and executed. These jobs cannot be 
modified.
The design of this access level is optimized for touchscreens. Mouse 
control is also possible.
➜ page 23, "Touchscreen interface" Access Level
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(1) Title bar
 

(2) Job-Manager
  

(3) Menu bar
 

  

The title bar shows the name of the current job, the company name, the dongle type and the 
name of the program.

The Job Manager shows the name of the current job with the ele-
ments of the job settings below. Additionally the installed control 
cards are listed.

To view or edit a job setting, double click on the corresponding ele-
ment. Right clicking on the element will display a pop-up menu 
containing element-specific options.

➜ page 165, Editing the Job Settings

The menu bar contains the following menus (some menu commands are only available after 
setting the corresponding function or setting up the corresponding hardware drivers):

File menu

New Opens a new job with a blank 
workspace.

Up to ten jobs can be opened 
simultaneously.

Open Job... A previously saved job can be 
opened.

Close Jobs Closes the current job.

Close All Jobs Closes all open jobs.

Import... Allows you to select and import objects in different file formats.

Export... Allows you to export the currently selected weldMARK™objects in various 
file formats.

Import and Export 
Profiles...

Opens the Import/Export Wizard for profiles. Profiles can be exported from 
or imported to the Profile Manager.

Save Job Saves the current job. The first time you save a new job, the Save Job as 
window will be opened. File name and storage location have to be 
specified.

Save Job as... Allows you to save an open job under a new name.

Save Job to Embedded 
Controller

Jobs can be saved to a stand alone control card and executed from there 
without the need for a PC ( ➜ page 180, Enabling "Save to stand alone 
control card" Mode).

Print Setup... Allows you to enter settings for the printer you want to use.

Print Allows you to enter print settings, change printer settings and start printing 
the current job.

Exit Exits the weldMARK™ program.
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Menu Edit

Undo Reverses the last action performed. You can undo the last ten actions.

Cut Removes all selected objects from the job and sends them to the clipboard.

Copy Copies all selected objects to the clipboard.

Insert Point Pastes objects copied or cut in weldMARK™ into the current job.

Paste Special Allows objects on the clipboard to be pasted into the current job as image 
or text objects. 
This command enables you to paste objects from other applications.

Delete Element Deletes all selected objects.

Select All Selects all objects contained in the current job.

Snap To Guidelines If this function is enabled, objects that are moved get aligned with the 
guidelines.

Snap To Grid If this function is enabled, objects that are moved get aligned with the grid 
lines.

View menu

Host-Monitor This command shows and hides the Job-Manager. The host monitor allows 
you to observe the communication between a host and weldMARK™ 
( ➜ page 197, Editing the Host Interface Settings). This option is only 
available if the remote interface is activated.

Job Manager This command shows and hides the Job-Manager.

Object-Manager This command shows and hides the Object-Manager. See ➜ page 136, 
Marking Object Profile.

Profile-Manager This command shows and hides the Profile-Manager. See ➜ page 141, 
Showing and hiding the Profile Manager.

Digital Scan Head Monitor This command shows and hides the Digital Scan Head Monitor. 
See ➜ page 200, Digital Scan Head Status Monitor Window.

Motor-Manager Only available if a motor control card is installed.
Opens the window for operating the optional stepper motor control card.

Guidelines Shows or hides guidelines.

Grid Shows or hides gridlines.

Rulers Shows or hides rulers.

Millimeters Selects the unit for the ruler display and for the input dialogue boxes.

Inches 

Bits 
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Objects menu

Add The following submenus are available:

Automation... Opens a window for selecting an automation object.

Barcode... Inserts the selected object in the center of the 
work-space.Automation

Line

Polygon

Rectangle

Text

Polyline

Bezier

Vector

Convert To Template Converts the selected object into a template. The template is automatically 
added to the Job Manager.

Lock Object/
Unlock Object

Locks or releases the selected object for editing.

Lock All/
Unlock All

Locks or releases all objects in the job for editing.

Defaults... Allows you to make default settings for various object types ( ➜ page 27, 
Object Defaults).

Dimensions... Allows you to change the size, shape and position of the selected objects.

Properties... Allows you to edit various parameters of the selected objects.

Vector Design Opens the Vector Graphic Designer ( ➜ page 32, Vector Graphic Designer 
(VGD)).

Profiles menu

Add to Profiles... The parameters of the selected object can be combined under a profile 
name and added to the Profile Manager under that name.

Organize Profiles... Allows you to specify the folder structure for the profiles.
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Job Menu

Preview Creates a frame representing the rectangular boundaries of the selected 
objects using the visible pointer and opens the "Preview" window. This 
window allows you to adjust the boundaries of the objects to the target 
object.
(To activate the visible pointer ➜ page 218, Configuring a Laser Driver).

QuickMark Allows you to start execution of either the selected objects or all objects 
included in the job. Automation objects are skipped.

Run... Allows you to start execution of the current job including all marking and 
automation objects.

Run from Hardware… To ensure that jobs are executed without interruption, they are first sent to 
the control card and then started. This function is particularly useful when 
using a slow PC.
( ➜ page 178, Run from Hardware)

Convert Template to 
Object

Converts the selected template into a marking object.

Jobs View of open jobs.

Settings... Allows you to make job-specific settings.

Tools Menu

Configure Tools Allows you to add external programs to the Tools menu.

Align... Allows you to align selected objects with one another based on particular 
settings.

Open App.Data Folder Opens the directory where weldMARK™ automatically saves specific files 
for windows.

Grid/Guidelines... Allows you to set parameters for the grid and for guidelines.

Configure I/O Cards... Starts the Configuration Wizard for the I/O card.

I/O Card&Diagnostics... Allows you to check the ports of the standard I/O board. 

Laser Diagnostics Tool Allows you to set parameters for laser radiation and to test the position and 
effect of the laser beam.

Reduce power to minimum Using this menu item, the laser power can be set to the registered 
minimum laser power [minbits] in the config file. 
This function is not available for CO2 lasers.

Generate Correction... Opens a menu for creating 3D Correction Files via STL files.
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System Menu

Preferences... You can set various preferences in weldMARK™.

Properties... Displays the properties of the operating system and relevant hardware for 
weldMARK™.

Globals... Allows you to enter general settings for laser power, marking speed and 
marking offset. weldMARK™ can be adjusted for changing external 
parameters, for example, diminishing laser power.

Run from Host... Sets weldMARK™ to host mode, enabling it to accept commands from 
external host programs.
The menu item is only available if the remote interface is enabled.

Security Access level Allows you to change the access level. Any changes 
take effect immediately.

Change Password You can set a password for changing the access 
level, changing the password or cancelling password 
protection.

Startup Options Sets the access level used to start the program.

Backup... Opens the Browse for Folder window. In the tree structure of this window, 
you can select a storage location for the backup file containing the 
weldMARK™ system settings.

Restore... Opens the Restore Application Settings window. In this window, you can 
select a backup file. Opening the file restores the saved system settings for 
weldMARK™.

Help Menu

Content & Index Opens the weldMARK™ online help.

Online Updates... Displays information about the current program version.
Clicking on Check for Updates calls up the RAYLASE homepage, provided 
you are connected to the Internet.

About... Displays the currently installed weldMARK™ version number. The Info 
button can be used to obtain additional copyright information.
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(4) Toolbars
 

  

The toolbars provide fast access to frequently used functions.

The toolbar below the menu bar contains the following standard commands:

New Mark on the Fly

Open Job... QuickMark

Save in Starting execution

Save as Run from Hardware 

Print Show/Hide Job Manager

Cut Show/Hide Profile Manager

Copy Text attribute bold

Insert Point Text attribute italics

Delete Element Align text left

Undo Center text

Import... Align text right

Export... Change Access Level

Nd:YAG only
Reduce laser power to minimum

Change Password
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(5) Rulers
 

(6) Profile-Manager
  

The toolbar on the left-hand side of the screen contains functions for adding, selecting and 
manipulating objects:

Select objects Insert text object

Zoom in Insert barcode object

Zoom out Insert automation object

Full view Insert drill object

Insert line object Show/Hide 
guidelines

Only available if 
guidelines have 
been entered.

Insert rectangle object Snap To 
Guidelines

Insert polygon object Show/Hide grid

New polyline Snap To Grid

Insert Bezier object Align...

New vector object Dimensions

The rulers can be displayed with the following units: "Millimeters", "Inches" or "Bits". The rulers 
are scaled automatically based on the Correction File for the deflection unit lens.

The Profile Manager displays a hierarchical overview of the profile 
folders and profiles created by the user. Profiles can be applied to 
selected objects or to all objects in a job. To do this, right click on 
the corresponding profile and select the required option in the pop-
up menu. Double clicking on the profile allows you to modify its 
parameters.

Related Sections:

➜ page 135, Using Profiles
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(7) Object-Manager
 

(8) The "Jobs" Tab
 

(9) Workspace
 

The Object Manager lists all marking and automation objects in the 
job. The objects appear in the order in which they were created and 
in which they will be executed. You can change the order of the 
objects using the blue arrow buttons in the Object Manager screen.

You can select a contiguous list of objects using the Shift key, or a 
non-contiguous list using the Ctrl key. To select a contiguous list, 
hold down the Shift key and click on the first object in the list and 
then the last object in the list. To select a non-contiguous list, click 
the first object, then hold down the Ctlr key and select the other 
objects you want to add. A selected contiguous list can be changed 
to a non-selected list.

The number of objects within a job is given in the title line of the 
Object Manager. You can select an object by clicking the Object 
Manager or by entering the appropriate index in the Index field.

Using the option Mark outline certain objects can be tagged to be 
contour marked or not. Select this option for when an object that has 
no contour (such as a Bitmap object) is to be marked.

Select the option Mark fill to mark the content of objects that have 
the fill feature.

( ➜ page 25, Working with Objects)

The tabs at the bottom of the screen provide an overview 
of the currently open jobs and allow you to select these 
jobs directly.    

The size of the workspace can be set individually or automatically adjusted to the size of the 
operating field of the deflection unit( ➜ page 166, Job Settings - "Page Setup"). The maximum 
size of the workspace is determined by the size of the deflection unit's operating field. Objects 
that are partly located outside the workspace are not marked.
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Popup Menu
   

The following functions are available:
 

The pop-up menu provides fast access to frequently used functions for editing objects.

￮ Right click on an object to open the pop-up menu.

QuickMark… (F8) Allows you to start execution of either the selected objects or all objects 
included in the job. Automation objects are skipped. 

PreviewMark... (F4) Creates a frame representing the rectangular boundaries of the selected 
objects using the visible pointer and opens the "Preview" window. This 
window allows you to adjust the boundaries of the objects to the target 
object.
(To activate the visible pointer ➜ page 218, Configuring a Laser Driver).

Cut Removes all selected objects from the job and sends them to the clipboard.

Copy Copies all selected objects to the clipboard.

Convert To Template Converts the selected object into a template. The template is automatically 
added to the Job Manager.

Lock Object/ 
Unlock Object

Locks or releases the selected object for editing.

Delete Element Deletes all selected objects.

Add to Profiles... The parameters of the selected object can be combined under a profile 
name and added to the Profile Manager under that name.

Copy Profile Copies the profile for the selected object to the clipboard.

Paste Profile Applies the profile saved to the clipboard to the selected object.

Dimensions (F5) Allows you to change the size, shape and position of the selected objects.
➜ page 102, The "Dimensions" Toolbox

Properties (F2) Allows you to edit various parameters of the selected objects.
➜ page 27, Object Defaults
➜ page 136, Marking Object Profile

Design / Teach-In (F6) Only for Bezier and Vector Graphic objects.
The shape of selected objects can be changed.
➜ page 32, Vector Graphic Designer (VGD)

Only available for polyline and Bezier objects.
The shape of selected objects can be changed.
➜ page 54, Setup of a Polyline object
➜ page 57, Modifying a Bezier Object

Set Anchor Specifies the point of reference of the object.

Tile Used to divide oversized objects that are bigger than the marking area.
➜ page 109, Manual Tiling
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3.3.2 "Operator interface only" Access Level
 

The following functions are available:
 

This access level allows the user to open and execute prepared jobs. The jobs to be executed 
must be located in the pre-set folder ( ➜ page 197, Settings for the Job File).

File >Open Job... A previously saved job can be opened.

File >Exit Exits the weldMARK™ program.

Reduce laser power to mini-
mum

Nd:YAG only
Reduce laser power to minimum

Mark on the Fly Mark on the Fly

Job >Run... Allows you to start execution of the current job including all 
marking and automation objects.

Change Access Level If password protection is activated, you need to enter the 
password to change access level.
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3.3.3 "Touchscreen interface" Access Level
  

 

The following functions are available:
 

This access level allows the user to open and execute prepared jobs. The jobs to be executed 
must be located in the pre-set folder ( ➜ page 197, Settings for the Job File).
The design of the user interface is optimized for touchscreens. Mouse control is also possible.

Job Manager A previously saved job can be opened. Only one job at a time can be 
opened.

Run Job Executes the open job.

Stop Stops execution of the job.

Job Status Shows the workspace and the marking objects positioned on it.

System Status The fields show the status of interlocks 1 to 8. Depending on the setting, a 
particular status can be a prerequisite for marking individual or all objects. 
The names of the interlock fields can be changed.

Options Allows you to adjust the job for changed external conditions ( ➜ page 202, 
Global Settings) or to change the access level ( ➜ page 24, Changing the 
Access Level).

Shutdown The weldMARK™ program will end and Windows will close.
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3.3.4 Changing the Access Level

"All editing functions" or "Operator interface only" Access Level
   

"Touchscreen interface" Access Level
 

￮ Select the Menu Item System >Security >User 
Access or click on the Change Access icon.
If password protection is activated, you will be 
prompted to enter the password. 
The dialogue on the right opens.

￮ Choose the desired access level.

￮ Touch the OPTIONS button.
The dialogue on the right opens.

￮ Touch the FULL ACCESS button.
If password protection is activated, you 
will be prompted to enter the password.

Change Access 
Level
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4 WORKING WITH OBJECTS
 

4.1 Basic Principles

4.1.1 Selecting and deselecting Objects
   

Selecting Objects with the Selection Tool
 

Selecting Objects using the Object Manager
 

Selecting all Objects
￮ Select Edit >Select All option from the menu.

Deselecting Objects 
    

This chapter provides an overview of the objects available in weldMARK™ and describes how 
to use them.

Objects must be selected in order to edit them or display their properties. You can select multi-
ple objects at the same time. Selected objects are identified by squares (resizing handles) 
around them and by emphasis in the Object Manager.

￮ Select the Selection tool icon in the toolbar.
￮ Click on the desired object with the arrow cursor.
￮ To select multiple objects drag the cursor with pressed down right mouse button over all 

objects that need to be selected. Alternatively hold down the shift button and select each 
object with the cursor that needs to be selected.

￮ Click on the desired object in the Object Manager.
￮ To select multiple objects, click on the first object in the Object Manager. Hold down the Ctrl 

key and then click on all of the other objects you want to select.

￮ Select the Selection tool icon in the toolbar.
￮ With the arrow cursor, click on a point outside the object or object group, or click on a free 

space in the Object Manager.

Selection tool

Arrow cursor

Selection tool
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4.1.2 Moving Objects
 

4.1.3 Locking and unlocking Objects
   

   

4.1.4 Object Types
The following object types are available in weldMARK™:

￮ Select the desired objects.
￮ Click on the objects and, with the mouse button held down, drag them to the desired 

position or use the Nudge tool ( ➜ page 106, Nudging Objects).

Locked objects cannot be edited or deleted. This prevents the object or its properties from 
being inadvertently modified.

￮ Click on the object to be locked.
￮ Select Objects >Lock Object option from the menu.

The resizing handles of locked objects appear as 
unshaded squares.

￮ You can use the Objects >Unlock Object command to 
release the object for editing.

The resizing handles for unlocked objects appear as 
shaded squares.

Unlocked 
object

Locked object 

Marking 
objects

Graphic objects

Line The adjacent marking object types can be selected.

Rectangle

Polygon

Polyline

Bezier

Text

Barcode...

Drill...

Vector

Automation-
Objects

Automation... Automation objects allow communication with the user and 
allow control of external components.

Lock Object
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4.1.5 Object Defaults
 

 

  

4.1.6 Object Properties
 

The following properties can be set for all object types:

Notes
Notes can be added to objects as follows:

  

Object defaults are set for some objects. For example, when creating new polygons the num-
ber of corners is preset. You can change these object defaults as follows:

￮ Select 
Objects >Defaults.
The dialogue on the right opens. 
The table below lists all object types for 
which object defaults exist.

S089

Polygon ➜ page 50, Defaults for Polygon Objects

Text ➜ page 59, Defaults for Text Objects

1D Barcode ➜ page 70, Defaults for 1D Barcode Objects

Data Matrix ECC200 ➜ page 75, Default settings for Data Matrix Objects

Bitmap Graphic ➜ page 42, Properties of a Bitmap Object

Wait for External Signal ➜ page 120, Defaults for "Wait for External Signal"

Set I/O port ➜ page 122, Defaults for "Set I/O port"

Show Messagebox ➜ page 125, Defaults for "Show Messagebox"

Vector Graphic ➜ page 30, Defaults for Vector Graphic Objects

You can change the properties of objects as follows:

￮ Right click on a object.
￮ Select Properties....
￮ Carry out the required changes. Refer to the following sections to see which properties are 

possible for which object types.

￮ Right click on the object to which you want 
to add a note.

￮ Select Properties.... 
￮ Select Notes tab.
￮ The dialogue on the right opens.
￮ Enter the desired text.
￮ Confirm your entry with the OK button.

S013
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External Control
 

  

 

( ➜ page 226, Standard I/O Card / Interlock Card)

During execution of the job, each individual marking object can be marked or skipped depend-
ing on external signals. The settings for this can be called up as follows:

￮ Right click on the object to which you want 
to add an external marking control.

￮ Select Properties....
￮ Select Ext. Control tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S242

External control activated If this function is enabled, the I/O ports are checked before marking the 
selected object. If they accord with the setting in IN1-IN6, the object is 
marked, otherwise it is skipped.

I/O port Selection of the input ports on either the control card or the standard 
I/O card, that need to be checked.

IN1–IN6
PA0–PA5

Specification for port status (high / low).
If the specification is met, the object is marked. If the specification is not 
met, the object is skipped The port status values can either be read from 
the standard I/O card or from the control card (SP-ICE or RLC-USB).

MOTF control The marking process of an object can be started with a definable amount of 
units (impulses, mm or Inch) which are read from a pulse transmitter.
➜ page 110, Tiling and the "Mark-on-the-Fly" function
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4.2 Importing and editing Vector Graphic Objects

4.2.1 Importing Vector Graphic Files
 

    

 

Mathematically, Vector Graphics are defined as a sequence of points connected by lines to 
each other. Vector Graphics can be scaled as required without loss of quality. They are ideally 
suited for use with laser processing systems as the deflection unit is a vector output device.

￮ Select File >Import Job.
The dialogue on the right 
opens.

The table below contains 
explanations to the Vector 
Graphic formats that can be 
imported.

Since import parameter can 
be defined as default setting, 
they are described with the 
default settings.( ➜ page 30, 
Defaults for Vector Graphic 
Objects).

S090

File types CAD Drawings File formats and export formats of different CAD programs
(*.dgw; *.dxf; *.plt; *.hgl; *.hg; *.hpg; *.plo; *.hp; *.hp1;
*. hp2; *.hpgl ; *. hpgl2; *.gl2; *.pm; *.spl; *.rtl; *.cgm; *.svg) 
Editing with the Vector Graphic Designer is not possible, with only 
these file formats.

weldMARK™ 3 Object weldMARK™ format for objects (*.wlo).

HPGL Plotter File The industry standard (*.plt); this format is primarily used for 
output to a pen plotter. 
Note that the resolution of the plotter file to be imported must 
match to the resolution set in weldMARK™ so that the output size 
will be displayed in weldMARK™ correctly. The resolution in 
weldMARK™ depends on the F-Theta lens used. It is referred to 
as the calibration factor and can be seen under System 
>Preferences in Hardware tab.

Windows Enhanced 
Meta File

A format developed by Microsoft (*.emf). It can be used to store 
both Vector Graphic information and bitmaps embedded in the 
file.
When Vector Graphic objects are copied to the clipboard, EMF 
format is used. 

Windows MetaFile A format developed by Microsoft (*.wmf), the precursor of the 
EMF format.

AutoCAD An export format (*.dxf), normally from AutoCAD.

Encapsulated 
PostScript

A graphic format, optimized for importing into other documents 
(*.eps).

further ➜ page 41, Importing Bitmap Files

additional import options ➜ page 30, Defaults for Vector Graphic Objects

Import...
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4.2.2 Defaults for Vector Graphic Objects
 

  

 

This section describes how you can call up and modify the defaults for Vector Graphic objects. 
The defaults apply to all new Vector Graphic objects.

￮ Select 
Objects >Defaults.

￮ Select the Vector Graphic Default option.
The dialogue on the right opens. 
Refer to the table below for explanations.

S016

Enable 3D Import This option has to be checked, to import 3D Vector Graphic objects.
➜ page 158, Importing 3D Vector-Objects

Center Positions the object in the center of the workspace.

Import ".txt" as Polyline 3D coordinates within a txt-file are imported as polyline.

Mirror about X Axis The object is automatically mirrored upon importing. The options are 
summable.Mirror about Y Axis

Import As CAD Imports a CAD-file.

Units The unit with which the data is interpreted can be specified in this field. This 
setting should match the setting that was used when exporting.

Scale units by: A factor with which the data is scaled upon import can be defined here.

Apply to Z Axis Must be selected when 3D data is scaled in the Z axis.

Delete Duplicates Vector objects with the same coordinates can be automatically removed, 
upon import with this function.

Import Layout Allows for a specific layout of the file to be imported. Layout "0" is used as 
default. The correspondent layout number has to be used, to import 
another layout.

Join Polylines/Bezier This function activates a filter, that is active during the import.
It joins all polylines and Bezier objects, if their starting and ending points 
are identical.

Disable AutoCAD filter Enables or disables the appearance the AutoCAD filter.

Optimize for Filling Optimizes the imported object for the filling.
Particularly useful when the spot offset function is used.

Single Layer This function combines all single layers to one overall level and it is 
especially recommended when filling or spot offset functions are applied.

Style Defines which filling style is used.

Fill spacing The distance between the individual fill lines can be set for all new text 
objects. Entering "0" means that the characters will not be filled.

Offset Defines the offset from the filling to the contour.

Slope 1 Defines the angle between parallel lines.

Slope 2 Defines the angle between cross hatches.
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Mark object Enabling this function means that the object will be marked. This function is 
enabled by default.

Mark fill If this function is enabled, the object fill will be marked. The function can 
only be selected if a fill has been set. This function is disabled by default.

Skip Frame Inverts the filling of a vector object with multiple layers.
All previously unfilled areas are filled, and vice versa.

Mäander This function refers to bidirectional parallel lines and/or crosshatches.
When changing the direction the end of a fill line is connected to the 
beginning of the next fill line without the laser stopping or turning off.

Offset follow surface For 3D objects the position of the offset is adjusted to the 3D surface.

Text as Graphic Text within the graphic object should be part of the filled layout.

Maximized Fill Use if graphic has closed and non-closed contour.
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4.2.3 Vector Graphic Designer (VGD)
 

 

The Vector Graphic Designer can be used to adjust Vector Graphic objects to the requirements 
needed for marking with the laser. The following examples represent a few possibilities:

￭ The position of a graphics' elements can be changed in order to adjust to the component to 
be marked.

￭ To remove single elements or complete layers from the marking process, they can be 
deleted.

￭ The elements of the graphic can be arranged in up to 8 layers. It is possible to allot one of 
8 pens to each layer (SET_PEN). The marking parameters of each single pen can be set in 
the profile settings.

￭ The marking sequence and direction can be modified to optimize the marking speed. Thus 
the marking speed can be optimized.

￭ New elements can be inserted, like text, ellipses, circles or points.
￭ Layers can be joined or split.
￭ 2D vector objects can be projected onto a 3D surface with a STL file.

To access the Vector Graphic Designer, follow the instructions:

￮ Right click on a Vector Graphic object.
￮ Select Design.

The Vector Graphic Designer is parted into six areas. The following chart gives a short descrip-
tion of them. For detailed information, refer to the related sections.

Image Drawing (1) This area shows a preview of the Vector Graphic object.

Nodes Tree (2) The node tree lists all elements of the selected vector object and 
simultaneously defines the marking sequence and distribution of levels.

Modify (3) This area provides several functions to edit the selected object.

Move (4) This area provides several functions to adjust the position of elements or 
the active point. Furthermore, the zoom can be changed.

Change view plane (5) The axis view of an 3D-Vector object can be selected. (Top-View, 
Side-View, Front-View)

Additional functions (6) Additional functions can be activated for several topics in this area. 
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(1) Image Drawing
 

(2) Nodes Tree
 

(3) Modify
 

In the Image Drawing area, single elements of the Vector Graphic object can be selected and 
dragged by the mouse.

After opening the Vector Graphic Designer, the starting point of the graphic is automatically 
chosen as active point. By clicking the left mouse-button, another point can be selected as 
active point.

By using the right mouse-button, the focus can be changed. It does not influence the position of 
the object.

Editing functions can be activated by clicking in the image drawing area or by pressing the F9 
key. If the Image Drawing view is active, the mouse wheel can be used to zoom the focus in 
and out.

In the Nodes Tree view, it is easy to select single points or groups of points of an element for 
editing. Depending on the selected items, different editing functions are available in the Modify 
area.
The nodes tree allows for a detailled view on different layers. By clicking the "+"-symbol the 
nodes tree kann be extended up to the coordinate layer.

Node up/ Node 
down

Change of the position in the node and also in the marking sequence.

Add Function Inserts the content from the Function field into the selected node.

Duplicate Creates a copy of the selected function, that can be inserted.

Delete Deletes the selected node. 
The function SET_PEN can not be deleted since it is associated with the current 
layer.
Points can only be deleted if they are not required for the definition of the function. 

Group Layers Group all function from the same layer in the nodes tree.

Join Layers Join all function from the same layer in the nodes tree. The marking sequence is 
optimized this way.

Split Layer Splitting the selected layer into two nodes. Splitting will take place between the 
active node and the following node.

Join Polyline Joining the selected node with the previous node, for polylines.

Split Polyline Splitting the selected polyline into two separate lines. The distribution is made by 
duplicating the selected node. The first and last node can not be used.

Function The Function field contains a list of the supported functions and their parameters.
First, it displays the type of the selected node in the Nodes Tree. 
Furthermore, the field is used to choose the function to be added to the Nodes Tree. 
 above

Change... Applying all changes made. The same effect is achieved by pressing the Enter key 
or clicking into another field with the mouse button.

Optimize Applying the chosen optimizations to the selected layers. 
➜ page 34, (6) Additional functions

Reverse Points Reversing the sequence of points of any function and thus changing the marking 
sequence.
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(4) Move
  

(5) Change view plane

(6) Additional functions
    

Zoom all (F5) Clicking on this button zooms the preview to display the whole Vector Graphic 
object.

Arrow Keys By using the arrow keys, the selected function and its sub functions can be moved in 
the preview.

￭ If the selected node is a point (Level 2), only that point is selected.
￭ If the selected node is an object (Level 1), the first point will be selected and all 

other points from the objects are in the valid selection area.
￭ If the selected node is a layer (Level 0), the first point of the first object will be 

selected and all other points from the layer are in the valid selection area.

Zoom If this option is selected, the focus can be zoomed in and out via the 
arrow keys.

Pan If this option is selected, the arrow keys move the whole workspace.

Step By this options field, the step width of the arrow key movement can be 
defined. 
1x = 0.1 mm, 10x = 1 mm.
Note: Alternatively the switch to 10x can be done via the shift key.

An object can be viewed from different directions with this function. Available options are 
"Active Plane: XY", "XZ" and "YZ". Depending on the chosen option, 2 of the 3 axis are figura-
tively put in front, so the user can view the object from the sides, from above or from the front 
for example.

S249

S250

Show points If this function is enabled, points are shown in the preview. 
This function is enabled by default.

Select Points Only In 
TreeView

If this function is enabled, the selection of the active point can only be made in 
the nodes tree. Thus, the accidental selection of a wrong point can be avoided, 
even if the point density is high.
This function is disabled by default.

Show Points Order If this function is enabled, the marking sequence of the points is shown in the 
preview. All points that define a function are shown in the Image Drawing, not 
only the points intended to be marked. 
This function is disabled by default.

Center Active Points This function always displays the active point in the center of the preview. 
This function is disabled by default.

Zoom Window 
Center

This function zooms in the focus up to the size of the whole Image Drawing field.

Point Size By selecting a value between 1 and 10, the size of the points in the preview can 
be adjusted. 

Raw Vector-Object It’s possible to modify or move Vector Graphic objects without the Vector 
Graphic Designer via dimension tools. 
Thus the object can be positioned out of the preview window. 
If Raw Vector Object function is enabled, the Vector Graphic object is displayed 
in its original form and position.

Snap Mouse Moves 
To [mm]

If this function is enabled, the mouse is moving in steps of 1 mm. 
The function is only available if Raw Vector Object is enabled.

Warn "Out Of Card 
Bounds"

If this function is enabled, the borders of the marking field are shown by dotted 
lines. If Show Points is enabled, points outside the marking field are shown in 
red color. 
This function is disabled by default.
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Use Pens Colors in 
Layers

If this function is enabled, the diverse pen colors are shown in the Nodes Tree 
and the Image Drawing. Otherwise they are all shown in black color. 
This function is enabled by default.

Partial Redraw 
(Fast Drawing)

If this function is enabled, only the selected point, function or layer is redrawn 
while moving the mouse, so that the rest is masked. The rest is masked. This 
function improves speed and display time and is disabled by default. Can be 
used to avoid burning effects caused by poly delay. 
Note: 
Curved lines will be combined by straight lines within minimal point distance.

S251

S252

Tab 3. Optimizing and tab 4. Polyline contain a number of optimization options which are taken 
into account when the button Optimize is pressed. 

➜ page 33, Optimize

All optimizations are applied only to the selected layer or the layer the currently active node 
belongs.

To optimize all layers of the Vector Graphic object at once, enable the function 
Optimize To Last Layer.

Remove 
MOVE_TO(s)

If this function is enabled, pairs of MOVE_TO, LINE_TO, POLYLINE_TO and 
BEZIER_TO functions are combined into a single polyline or Bezier function. 
If the object contains functions, that are named above, this function needs to be 
enabled when using the Sort By Starts-Ends Of Functions function.

Delete Duplicate 
Functions

All functions with identical X/Y values will be deleted if this function is enabled.

Join Polyline & Bezier 
functions

If this function is enabled, polyline functions that have common ending 
respectively starting points are joined to longer chains of polylines.

Sort By Starts-Ends 
of Functions

If this function is enabled, the optimal marking path can be found to reduce the 
marking time. The functions are automatically brought into the optimal order.
If the object contains MOVE_TO, LINE_TO, POLYLINE_TO or BEZIER_TO 
functions, Remove MOVE_TO (s) has to be enabled as well.

Continue From 
Current Node

If this function is enabled, the optimization starts from the current node instead of 
the first node of the layer.

Optimize To Last 
Layer

If this function is enabled, all layers of the Vector Graphic object are optimized at 
once.

Convert Bezier/ 
Ellipse/ Arc/ Chord/ 
Pie To Polyline

If this function is enabled, Bezier, Ellipse, Arc, Chord and Pie functions are 
converted into polyline functions. 

Min. PointDdistance If this function is enabled, the points that are closer than the selected minimal 
distance are removed. 

S251

S252

These tabs are used for creation and editing of 3D vector objects only.

The Surface to Object button is only available until an imported STL file is combined with a vec-
tor object. During this period offset values are used onto the position of the STL files directly.

If the option View 3D is checked, other options on different tabs can not be used.

Surface File STL surface file selection

Surface Units Defines the unit of measurement of the imported surface file.

Offset Object / 
Surface to Object

Activates the object offset by the defined value / 
Maps the 2D file onto the 3D surface.
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4.2.4 Properties of a Vector Graphic Object
 

  

Offset X/Y/Z Offsets the selected object, or imported STL file, along the correspondent axis of 
coordination. To move the objects, the highest layer has to be chosen in the 
nodes tree.

View 3D Activates Rotation X/Y/Z.

Rotation X/Y/Z Specification of the angle in degrees to rotate the object along the specific axis.

Properties are assigned to Vector Graphic objects, which determine how the objects are dis-
played on the screen and how the behave during laser processing. These properties are 
divided up as follows:

Profile A marking profile is assigned to the object. The 
parameters of this profile can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the object. ➜ page 37, Settings for a 
Vector Graphic Object

Source Allows you to see the path to the source file. ➜ page 38, Source File for a 
Vector Graphic Object

Fill Fill parameters for the object can be entered. ➜ page 86, Object Fill

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

CAD For Vector Graphic objects special settings can be 
adjusted.

➜ page 39, CAD Settings of a 
Vector Graphic Object

Tiling while 
marking

Used to mark oversized objects that are bigger than 
the marking area.

➜ page 111, Automatic Tiling
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Settings for a Vector Graphic Object
 

   

 

Every Vector Graphic object is assigned specific settings that can be called up and, if neces-
sary modified as follows:

￮ Right click on a Vector Graphic object.
￮ Select Properties.... 
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen.

Mark object If this function is enabled, the object contour is marked. This function is 
enabled by default.

Mark fill If this function is enabled, the object fill will be marked. The function can 
only be selected if a fill has been set. This function is disabled by default.

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. This function is disabled by default.

Inline Parameter Switching Only for vector objects with a contour composed of several pens. This can 
be the case as following:

a)
Import of a vector object, that has 
been split into multiple layers with a 
graphic program beforehand.

b)
Import of a single layer file, that has 
to be split into multiple layers with the 
Vector Graphic Designer ➜ page 32, 
Vector Graphic Designer (VGD).
> Split Polyline
> Change Pen color

If this functions is active, the laser is not switched of, while marking the 
contour at the transition from one pen to another, but it is switched to the 
new marking parameters "on the fly".

Mark to If more than one control card is installed, this drop-down menu sets the 
desired control card for marking the object.

Object-specific Preview Preview option that is used before the actual marking in the job. After 
choosing this option, specific parameters are available ( ➜ page 164, 
Object Preview).
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Source File for a Vector Graphic Object 
 

  

 

Vector graphic objects are created in external programs and imported into weldMARK™. The 
path to the source file can be displayed as follows:

￮ Right click on a Vector Graphic object.
￮ Select Properties....
￮ Select Source tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

Image rules For graphic objects no rules can be configured.

String position This field specifies the path to the source file.
If the Vector Graphic file has been imported with the CAD drawings filter 
( ➜ page 30, Defaults for Vector Graphic Objects), the graphic is saved 
within the job.
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CAD Settings of a Vector Graphic Object
 

   

 

* These options are only available for Vector Graphic objects imported as CAD drawing.

For Vector Graphic objects of the type CAD an additional tab CAD is available. This tab is 
called up as follows:

￮ Right click on a Vector Graphic 
object.

￮ Select Properties....
￮ Select CAD tab.

The dialogue on the right opens. 
Refer to the table below for 
explanations.

S229

Layers All layers of the Vector Graphic object are listed.

Pen Colors A specific pen can be defined for each layer. Therefor eight predefined 
pens are available (Pen 1 to Pen 8). Via the profile settings it is possible to 
set marking parameters for each pen separately ➜ page 136, Marking 
Object Profile).

Mark Layer Via this field marking can be activated or deactivated for each layer 
separately.

Extract to New Object By clicking this button, the selected layer is removed from the Vector 
Graphic object and added as a new object to the object manager.

Extract <-> Restore all This option separates single layers into single objects. The function must 
be confirmed with Apply.

Min. Diameter Circular objects that fall below this diameter are converted into drill objects.



Chapter 4 Working with Objects

40 RAYLASE weldMARK 3 MN013 / v3.5.0

4.2.5 Exporting Vector Graphics
 

 

Vector graphic objects can be exported for use in other programs.

￮ Right click on the Vector Graphic you want 
to export.

￮ Select File >Export.

The dialogue on the right opens. Refer to 
the table below for explanations.

S018

Save in Folder in which the graphic should be saved.

File name The object name is suggested as the file name. However, you can overwrite this 
with the name of your choice.

Save as type The graphic can be saved in the following formats:

PLT HPGL Plotter File

WLO weldMARK™ object-format
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4.3 Importing and editing Bitmap Objects

4.3.1 Importing Bitmap Files
 

  

 

A bitmap is a rectangular grouping of pixels. For laser marking, the bitmap must be rastered. 
As the Scan Head is a vector output device, this raster has to be simulated. To do this, the 
laser beam moves repeatedly over the image and marks a series of pixels each time. This pro-
cess can take a long time. It normally takes longer to mark a bitmap representation of an object 
than a vector representation. However, some images only allow bitmap marking, e. g. 
photographs.

weldMARK™ supports the import of bitmap files with monochrome, gray or colored content. 
Once imported, all images are automatically converted into gray scale images.

￮ Select File >Import Job.

The dialogue on the right 
opens.

The table below contains 
explanations to the bitmap 
formats that can be imported.

Since import parameter can 
be defined as default setting, 
they are described with the 
default settings.( ➜ page 45, 
Defaults for Bitmap Objects).

S015

Files of 
type

Windows Bitmap 
(BMP) 

A Windows bitmap format. 

JPEG Bitmap (JPG) Compressed bitmap format.s.

CompuServe Bitmap 
(GIF)

PaintBrush (PCX) A PaintBrush bitmap format.

Further ➜ page 29, Importing Vector Graphic Files
➜ page 29, Importing and editing Vector Graphic Objects
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4.3.2 Properties of a Bitmap Object
 

  

Settings of a Grayscale Bitmap Object
 

  

  

Properties are assigned to bitmap objects, which determine how the objects are displayed on 
the screen and how the behave during laser processing. These properties are divided up as 
follows:

Profile A marking profile is assigned to the object. The 
parameters of this profile can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the object. ➜ page 42, Settings of a 
Grayscale Bitmap Object

Source Allows you to see the path to the source file. ➜ page 44, Source File for a 
Bitmap Object

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

Tiling while 
marking

Used to mark oversized objects that are bigger than 
the marking area.

➜ page 111, Automatic Tiling

Every bitmap object is assigned specific settings that can be called up and, if necessary, 
modified as follows:

￮ Right click on a bitmap object.
￮ Select Properties....

Select Settings tab.
The dialogue on the right opens. 
Refer to the table below for explanations.

S017

Name The object name entered in this text box is used to list the object in the Object 
Manager. The name also appears in all information and dialogue boxes related to 
the object.

Mark Style Default setting for bitmap graphics is "Dot Matrix".

Pixel density Pixel density specifies in which resolution the picture will be marked. If the option 
Auto scaling is activated, the picture size remains the same, even if the Pixel density 
is changed.

Auto scaling

Contrast The difference between lightest and darkest pixels can be modified.

Brightness The brightness of the marking result can be changed. If the value is increased, the 
laser rests longer on each pixel; the marking result will be brighter or darker 
depending on the material.

Mark object Enabling this function means that the object will be marked. This function is enabled 
by default.

Display vector 
jumps

If this function is enabled, the vector jumps between the individual part of the object 
are displayed on screen. This function is disabled by default.
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Bitmap mode Depending on the kind of the bitmap object and the preset laser type, the following 
modes can be selected ( ➜ page 44, Selectable bitmap modes).

PWM If this function is enabled, the levels of gray are generated 
through the exposure time. The Scan Head rests at each pixel 
for a various time.

PWM-2 If this function is activated the levels of gray are generated  
through the laser power. The Scan Head processes the pixels 
with a constant speed.

Analog If this function is selected, the laser power is controlled via an 
analogue signal (0V to10V).

Digital If this function is selected, the laser power is controlled via a 
digital signal (8bit digital output).

Error Diffusion If this function is selected, the bitmap object is converted into a 
monochrome bitmap using the default error diffusion 
algorithm. Black pixels are positioned in a way that the picture 
seems to consist of shades of grey.

Invert pixels Creates a negative of the original bitmap object.

Single direction Bitmap objects are marked line by line, where at the marking is performed in 
alternating direction. If this function is enabled, marking is only performed in one 
direction, which can improve the marking quality (deactivation of the hysteresis of 
the scanner mirrors).

Ign. black pixels Activates the Min. Pixel field (see below).

Invert corners When rotating bitmap objects, pixels, which do not exist in the original, can be 
generated in the corners. The color of these superfluous pixels can be set to 
black (no marking) or white.

Vertical scan Turns the pixel processing by 90 degrees. This way the picture is processed 
vertically instead of the default given horizontal way.

Shift correction Mechanical inertia and laser specific delay may cause hysteresis errors in 
bidirectional operation, especially when marking with high speed.
Via the parameter Shift Correction this hysteresis can be compensated.

not corrected compensated correction value too high

Bitmapline delay Via this parameter an idle time after each bitmap line is defined. The next line is 
not marked until the set time has elapsed.

Max. pixel 
exposuretime

With this parameter the maximum and minimum time, that the laser can use to 
mark one point, can be set. Through the parameters the marking intensity can be 
adjusted, so that the graphic quality is affected.Min. pixel 

exposuretime

Min. pixel Via this parameter a minimal grey value is defined. Only pixels of the bitmap 
object of the same or a higher value are marked. If more than three pixels can be 
ignored, a jump command is performed to the next pixel to be marked 
automatically. This may increase the marking speed.
The value for Min. pixel ranges from 0 to 1000.
If the value is set to 0 or 1, no pixels are skipped.

Format The recognized file format of the bitmap object is displayed.

Mark to If more than one control card is installed, this drop-down menu sets the desired 
control card for marking the object.
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 Settings for a monochrome Bitmap Object

Monochrome bitmap objects have the following different parameters.

Generally the option Mark on dark material is available for bitmap files. to invert the levels of 
gray. 

Selectable bitmap modes
  

● = selectable, 1 = DAC,  2 = PortB,  3 = not possible for combination with monochrome bitmaps
4 = SPI Basic Interface,  5 = SPI Extended Interface

Source File for a Bitmap Object
 

  

 

Dot spacing Spacing of the picture dots. Consistent with the Pixel density of bitmap objects with 
levels of gray.

Pulse on time Through the parameters the length of the laser pulse and the following pause can be 
adjusted.Pause

Pulses per dot The parameter defines how many pulses are sent out for each marked pixel.

Laser type Setting for laser 
power

Bitmap mode

PWM PWM-2 Analog Digital Error Diffusion3

CO2 PWM ● ● ●

YAG Analog 1 ● ● ●

Digital 2 ● ● ●

IPG Digital 2 ● ● ●

SPI Analog 1 ●   ● 4   ● 5 ●

Bitmap objects are created in external programs and imported into weldMARK™. The path to 
the source file can be displayed as follows:

￮ Right click on a bitmap object.
￮ Select Properties....
￮ Select Source tab.

The dialogue on the right opens. 
Refer to the table below for explanations.
When the "Outline PLT file" is checked, a 
pop-up window will be shown and a corre-
sponding PLT file can be selected. 

80

The name of the outline "*.PLT" file is saved 
within the bitmap object data in the 
weldMARK job

80

Image rules For graphic objects no rules can be configured.

String position This field specifies the path to the source file.

Save within job With this option the bitmap file is saved within the job. If the option is 
deselectedm the bitmap file will be loaded upon every start of the job. In 
case the job is moved to another computer, the file needs to be available 
from there.

Outline PLT File Activates the option to connect a PLT-File with Bitmap to be used as 
outline preview and shows path of the linked PLT file. 
See ➜ page 163, Preview Mark
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4.3.3 Defaults for Bitmap Objects
 

  

 

This section describes how the defaults for bitmap objects can be called up and changed. The 
defaults apply to all new bitmap objects.

￮ Select Objects >Defaults... option from the 
menu.
The dialogue on the right opens.
Refer to the table below for explanations.

S016

Contrast The ratio between dark and light pixels in the image can be changed. 

Brightness The brightness of all pixels in the bitmap image can be changed. 

Pixel density The pixel density can be set in an area between 10 and 2400 dpi.

Max. pixel exposuretime With this parameter the maximum and minimum time, that the laser can 
use to mark one point, can be set. Through the parameters the marking 
intensity can be adjusted, so that the graphic quality is affected.

Min. pixel exposuretime

Bitmapline delay Via this parameter an idle time after each bitmap line is defined. The next 
line is not marked until the set time has elapsed.

Min. pixel Via this parameter a minimal grey value is defined. Only pixels of the 
bitmap object of the same or a higher value are marked. If more than three 
pixels can be ignored, a jump command is performed to the next pixel to be 
marked automatically. This may increase the marking speed. 
The value for Min. pixel ranges from 0 to 1000. If the value is set to 0 or 1, 
no pixels are skipped.

Ign. black pixels During marking, the laser beam ignores pixels that have a 100% black 
value and are not marked therefore. This reduces the processing time. 

Invert pixels Creates a negative of the original bitmap object. 

Single direction Bitmap objects are marked line by line, where at the marking is performed 
in alternating direction. If this function is enabled, marking is only 
performed in one direction, which can improve the marking quality 
(deactivation of the hysteresis of the scanner mirrors).

Vertical scan Turns the pixel processing by 90 degrees. This way the picture is 
processed vertically instead of the default given horizontal way.
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4.4 Adding and editing Marking Objects
 

  

 

4.4.1 Line Objects
 

Adding a Line Object
  ￮ Select Objects >Add >Line option from the menu.

A new line is inserted in the center of the workspace.

Properties of a Line Object
 

  

Marking objects are objects that can be marked with a laser. weldMARK™ allows you to select 
the following marking object types:

Line

Rectangle

Polygon

Polyline

Bezier

Vector object

Text

Barcode...

Drill...

The sections below describe how marking objects are added to a job and how these objects 
can be modified subsequently.

A line is a one-dimensional object. It causes the laser to mark a straight line.

Properties are assigned to line objects, which determine how the objects are displayed on the 
screen and how the behave during laser processing. These properties are divided up as fol-
lows:

Profile A marking profile is assigned to the object. The 
parameters of this profile can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the object. ➜ page 47, Settings for a Line 
Object

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

Tiling while 
marking

Used to mark oversized objects that are bigger than 
the marking area.

➜ page 111, Automatic Tiling

New 
line
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Settings for a Line Object
 

  

 

Every line object is assigned specific settings that can be called up and, if necessary, modified 
as follows:

￮ Right click on a line object.
￮ Select Properties....
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S020

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen.

Mark object Enabling this function means that the object will be marked. This function is 
enabled by default.

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. This function is disabled by default.

Mark to If more than one control card is installed, this drop-down menu sets the 
desired control card for marking the object.

Object-specific Preview Preview option that is used before the actual marking in the job. After 
choosing this option, specific parameters are available(➜ page 164, Object 
Preview).
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4.4.2 Rectangle Objects
A rectangle is a marking object with four corners.

Adding a Rectangle Object
 ￮ Select Objects >Add >Rectangle option from the menu.

A new rectangle object is inserted in the center of the workspace.

Properties of a Rectangle Object
 

  

Properties are assigned to rectangle objects, which determine how the objects are displayed 
on the screen and how the behave during laser processing. These properties are divided up as 
follows:

Profile A marking profile is assigned to the object. The 
parameters of this profile can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the object. ➜ page 49, Settings for a 
Rectangle Object

Fill A fill can be applied to the object. ➜ page 86, Object Fill

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

Tiling while 
marking

Used to mark oversized objects that are bigger than 
the marking area.

➜ page 111, Automatic Tiling

New 
rectangle
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Settings for a Rectangle Object
 

  

 

Every rectangle object is assigned specific settings that can be called up and, if necessary, 
modified as follows:

￮ Right click on a rectangle object.
￮ Select Properties.... 
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S021

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen.

Mark object If this function is enabled, the object contour is marked. This function is 
enabled by default.

Mark fill If this function is enabled, the object fill will be marked. The function can 
only be selected if a fill has been set. This function is disabled by default.

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. This function is disabled by default.

Mark to If more than one control card is installed, this drop-down menu sets the 
desired control card for marking the object.

Object-specific Preview Preview option that is used before the actual marking in the job. After 
choosing this option, specific parameters are available. 
( ➜ page 164, Object Preview)
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4.4.3 Polygon Objects
 

Defaults for Polygon Objects
 

  

  

Adding a Polygon Object
  ￮ Select Objects >Add >Polygon option from the menu.

A new polygon object is inserted in the center of the workspace.

Properties of a Polygon Object
 

  

A polygon object is an object that can be marked and has a definable number of sides of equal 
length. The distance from a corner to the center of the object is always the same.

This section describes how you can call up and modify the defaults for polygon objects. The 
defaults apply to all new polygon objects.

￮ Select Objects >Defaults... option from the 
menu.

￮ Select the object type Polygon.
￮ The dialogue on the right opens. 

Refer to the table below for explanations.

S089

    

Sides All new polygons are created with the number of corners entered.

Properties are assigned to polygon objects, which determine how the objects are displayed on 
the screen and how the behave during laser processing. These properties are divided up as 
follows:

Profile A marking profile is assigned to the object. The 
parameters of this profile can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the object. ➜ page 51, Settings for a 
Polygon Object

Fill A fill can be applied to the object. ➜ page 86, Object Fill

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

Tiling while 
marking

Used to mark oversized objects that are bigger than 
the marking area.

➜ page 111, Automatic Tiling

New 
polygon
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Settings for a Polygon Object
 

  

  

Every polygon object is assigned specific settings that can be called up and, if necessary, mod-
ified as follows:

￮ Right click on a polygon object.
￮ Select Properties.... 
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.
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Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen.

Mark object If this function is enabled, the object contour is marked. This function is 
enabled by default.

Mark fill If this function is enabled, the object fill will be marked. The function can 
only be selected if a fill has been set. This function is disabled by default.

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. This function is disabled by default.

Sides Specifies the number of sides of the polygon.

Start angle Specifies the angle position at which the first line segment begins. An angle 
of "0" corresponds to the 12:00 position on a clock.

End angle Specifies the angle position at which the first line segment ends.

Helix (Z-step after each 
side)

Only available for Scan Heads of the FOCUSSHIFTER type
( ➜ page 152, Trepanning Parameters).

Mark to If more than one control card is installed, this drop-down menu sets the 
desired control card for marking the object.

Object-specific Preview Preview option that is used before the actual marking in the job. After 
choosing this option, specific parameters are available ( ➜ page 164, 
Object Preview).
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4.4.4 Polyline Objects
 

Adding a Polyline Object
    

Properties of a Polyline Object
 

  

Polyline objects are markable objects consisting of at least 2 lines, which are connected by 
reversal points. The shape of the object can be adjusted according to the individual 
requirements.

￮ Select Objects >Add >Polyline option from the menu.
A new polyline object is inserted in the center of the workspace. At first, it appears as a 
small point, which can be edited individually.
➜ page 54, Setup of a Polyline object

Properties are assigned to polyline objects, which determine how the objects are displayed on 
the screen and how the behave during laser processing. These properties are divided up as 
follows:

Profile A marking profile is assigned to the object. The 
parameters of this profile can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the object. ➜ page 53, Settings for a 
Polyline Object

Fill A fill can be applied to polyline objects with a closed 
contour.

➜ page 86, Object Fill

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

Tiling while 
marking

Used to mark oversized objects that are bigger than 
the marking area.

➜ page 111, Automatic Tiling

New polyline
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Settings for a Polyline Object
 

  

 

Every polyline object is assigned specific settings that can be called up and, if necessary, 
modified as follows:

￮ Right click on a polyline object.
￮ Select Properties.... 
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S243

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen.

Mark object If this function is enabled, the object contour is marked. This function is 
enabled by default.

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. This function is disabled by default.

Mark to If more than one control card is installed, this drop-down menu sets the 
desired control card for marking the object.

Object-specific Preview Preview option that is used before the actual marking in the job. After 
choosing this option, specific parameters are available ( ➜ page 164, 
Object Preview).
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Setup of a Polyline object
 

  

  

Each new polyline object is added as a point. The shape can be modified as described in the 
following section:

￮ Click on a polyline 
object.

￮ Press key F6. 
The dialogue on the 
right opens. 
Refer to the table 
below for explanations.

S244

Polyline Editing Window 
(1)

This area shows all changes applied to the polyline object. By clicking on 
the OK or Apply button, the changes are saved. By clicking the Cancel 
button, the changes are discarded.
The laser displays the active point on the marking field. If the active point 
(blue color) is moved in the Polyline Editing Window, the display of the 
marking field will be updated. So, the object can be adjusted exactly in the 
area that is to be marked by using the visible pointer.

Add Line A new point is inserted behind the active point. The points are connected 
by a line.

Add Curve A new point is inserted behind the active point. The points are connected 
by a curve.

Delete Element Deletes the active point. 

Close Contour As described for the function Add Line, a new point is inserted behind the 
active point. Using this function, the new point is inserted exactly on the 
same position as point no.1 of the polyline object. Thus a closed contour is 
created. Areas with closed contours can be filled via the object properties if 
necessary. If one of these both points, the first or the last one, are moved 
afterwards, the contour may not be recognized as closed any more.

Preview Clicking on this button creates a preview of the polyline object in the 
marking field. 
This function is available only if a SP-ICE control card is used.
During the preview, no elements can be added or changed.

Arrow Keys The selected point can be moved via the arrow keys in the desired 
direction.

End If this function is activated, the active point and all subsequent points can 
be moved at once via the arrow keys.
Consequently, the first point can be selected to move the whole polyline 
object.

Zoom If this function is activated, the preview of the Bezier object can be zoomed 
in and out via the arrow keys.

1x By this options field, the step width of the arrow key movement can be 
defined. 
1x = 0.1 mm, 10x = 1 mm.

10x
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4.4.5 Bezier Objects
 

Adding a Bezier object
      

Properties of a Bezier Object
 

  

Previous Selects the previous or next point subject to the active point.

Next

Number of vectors Via this pop-up menu, the accuracy of the added curve can be defined. It 
sets how many vectors constitute the curve.

Raw Object It’s possible to modify or move polyline objects without the Polyline Editing 
Window via dimension tools. 
Thus the polyline object can be positioned out of the Polyline Editing 
Window. 
In this case activate function Raw Object to display the original Bezier 
object at its point of origin in the Bezier Editing Window.

Snap mouse moves to 
[mm]

If this function is activated, the point is snapped to a grid (1mm), when 
moving it via mouse.

A Bezier object is a markable object consisting of free-style spline curves. The curve linearity 
can be defined by moving the individual points.

￮ Select Objects >Add >Bezier option from the menu.
A new Bezier object is added to the center of the screen.

Bezier objects are assigned properties defining their displayed on the screen and the behavior 
during laser processing. These properties are divided up as follows:

Profile A marking profile is assigned to the object. The 
parameters of this profile can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the object. ➜ page 56, Settings of a 
Bezier Object

Fill A fill can be applied to Bezier objects with a closed 
contour.

➜ page 86, Object Fill

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

Tiling while 
marking

Used to mark oversized objects that are bigger than 
the marking area.

➜ page 111, Automatic Tiling

New 
Bezier Object
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Settings of a Bezier Object
 

  

  

Every Bezier object is assigned specific settings that can be called up and, if necessary, 
modified as follows:

￮ Right click on a Bezier object.
￮ Select Properties.... 
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S226

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen.

Mark object If this function is enabled, the object contour is marked. This function is 
enabled by default.

Mark fill If this function is enabled, the object fill will be marked. The function can 
only be selected if a fill has been set. This function is disabled by default.

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. This function is disabled by default.

Mark to If more than one control card is installed, this drop-down menu sets the 
desired control card for marking the object.

Object-specific Preview Preview option that is used before the actual marking in the job. After 
choosing this option, specific parameters are available ( ➜ page 164, 
Object Preview).
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Modifying a Bezier Object
 

  

  

Every new Bezier object is inserted with a standard shape. The shape can be modified as 
desired as described in the following:

￮ Left click on a Bezier object.
￮ Press key F6. 

The dialogue on the right opens. 
Refer to the table below for explanations.

S227

Bezier Editing Window (1) This area shows all changes applied to the Bezier object. By clicking on the 
OK or Apply button, the changes are saved. By clicking the Cancel button, 
the changes are discarded.
The laser displays the active point on the marking field. If the active point 
(blue color) is moved in the Bezier Editing Window, the display of the 
marking field will be updated. So, the object can be adjusted exactly in the 
area that is to be marked.

Add Point A new point is inserted behind the active point (no. 6 in the picture above).

Insert Point A new point is inserted in front of the active point.

Delete Deletes the active point.

Close Contour As described for the function Add point, a new point is inserted behind the 
last point. Using this function, the new point is inserted exactly on the same 
position as point no.1. Thus a closed contour is created. Areas with closed 
contours can be filled via the object properties if necessary. If one of these 
both points, the first or the last one, are moved afterwards, the contour may 
not be recognized as closed any more.

Preview Clicking on this button, creates a preview of the Bezier object on the 
marking field. 
This function is available only if a SP-ICE control card is used.
During the preview, no elements can be added or changed.

 Arrow Keys The selected point can be moved via the arrow keys in the desired 
direction.

To End If this function is activated, the active point and all subsequent points can 
be moved at once via the arrow keys.

Zoom If this function is activated, the preview of the Bezier object can be zoomed 
in and out via the arrow keys.

1x By this options field, the step width of the arrow key movement can be 
defined. 
1x = 0.1 mm, 10x = 1 mm.

10x

Previous Selects the previous or next point subject to the active point.

Next

Number of vectors Via this pop-up menu, the accuracy of the added curve can be defined. It 
appoints how many vectors generate the curve. If for example "1" is set, the 
points are linked with just on line.
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Raw Object It’s possible to modify or move Bezier objects without the Bezier Editing 
Window via dimension tools. 
Thus the Bezier object can be positioned out of the Bezier Editing Window. 

In this case activate function Raw Object to display the original Bezier 
object at its point of origin in the Bezier Editing Window.

Snap mouse moves to 
[mm]

If this function is activated, the point is snapped to a grid (1mm), when 
moving it via mouse.

Background All objects on the workspace are displayed as background to be able to 
align other objects.

Sample of a Bezier-line to draw the effective 
bitmap-outline for being used as a preview.

S025
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4.4.6 Text Objects
 

Defaults for Text Objects
 

 

 

Text objects can be created using either TrueType™ fonts or laser-optimized fonts. For 
TrueType™ Fonts, the characters are defined by their contour. The contour can be given a fill. 
For laser-optimized fonts, the characters are made up of lines or points. The laser-optimized 
fonts "Stroke" and "SEMI Dot Matrix" are included in the weldMARK™ installation package.

This section describes how you can call up and modify the defaults for text objects. The 
defaults apply to all new text objects.

￮ Select Objects >Defaults... option from 
the menu.

￮ Select the object type Text.

The dialogue on the right opens.
Refer to the table below for explanations.

S025

Font The character set for all new text objects can be selected.

Style Defines which filling style is used.

Fill spacing The distance between the individual fill lines can be set for all new text 
objects. Entering "0" means that the characters will not be filled.

Offset Defines a spacing between the filling and the contour.

Mark object If this function is enabled, the contour lines for the characters will be 
marked. This function is enabled by default.

Mark fill If this function is enabled, the character fill will be marked. The function can 
only be enabled if a fill spacing > 0 has been set.
This function is disabled by default.
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Adding a Text Object
    

 

Properties of a Text Object
 

  

￮ Select Objects >Add >Text option from the 
menu.
The dialogue on the right opens. 
Refer to the table below for explanations.

S026

(1) Selection of the font to be used for the new text object.

(2) Content of the new text object (string).

  

Text alignment buttons for multi-line texts (left aligned, centered, right 
aligned).

The Windows character map is called up to make it easier to enter special 
characters. ( ➜ page 68, Unicode Character Map)

Add The new object is included in way, so that the first letter is in the center of 
the workspace.

Text objects are assigned properties defining their displayed on the screen and the behavior 
during laser processing. These properties are divided up as follows:

Profile A marking profile is assigned to the object. The 
parameters of this profile can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the object. ➜ page 61, Settings of a Text 
Object

String Content and formatting of the text object. ➜ page 64, String of a Text 
Object

Source The content of text objects can be changed 
dynamically based on various rules.

➜ page 89, String rules

Fill A fill can be applied to the object. ➜ page 86, Object Fill

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

Tiling while 
marking

Used to mark oversized objects that are bigger than 
the marking area.

➜ page 111, Automatic Tiling

New 
text
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Settings of a Text Object
 

  

 

Every text object is assigned specific settings that can be called up and, if necessary, modified 
as follows:

￮ Right click on a text object.
￮ Select Properties.... 
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S023

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen.

Mark Style The text object is marked in either a vector-based or Dot Matrix style. 
Additional settings are available for the Dot Matrix marking style. 
See ➜ page 63, Additional Settings for Dot Style Fonts

Mark object If this function is enabled, the contour lines (shape) for the characters will 
be marked. This function is enabled by default.

Mark fill If this function is enabled, the character fill will be marked. The function can 
only be enabled for TrueType™ Fonts and if an object fill has been set.
This function is disabled by default.

Display vector jumps If this function is enabled, the entire sequence of movements is displayed 
on the screen, including the times in which the laser is deactivated while 
moving to the next vector to be marked (vector jumps). This function is 
disabled by default.



Chapter 4 Working with Objects

62 RAYLASE weldMARK 3 MN013 / v3.5.0

Marking Text Objects with long Strings
 

Example:

 

To mark text objects that are larger than the marking field, they have to be tiled. 
➜ page 109, Manual Tiling

The example shows how a text object is displayed in the working space after tiling. The rectan-
gle represents the size of the marking field. The undivided string is located above the parts 
which are lying upon each other. This option is most commonly used in connection with the 
"Mark on the Fly" function.
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Additional Settings for Dot Style Fonts
 

  

 

Example: 

Dot style fonts are special character sets in which the characters are made up of individual 
dots. The character set SEMI Dot Matrix is included in the weldMARK™ installation package. 
Special settings are available for this kind of character set:

￮ Right click on a text object.
￮ Select Properties.... 
￮ Select Settings tab.
￮ Choose the marking style Dot.

The dialogue on the right opens. 
Refer to the table below for explanations.

S037

Dot spacing Distance between the marking points in the X and Y axis.

Dot display size Dot size on the screen.
This parameter has no influence on the actual marking.

Pulse on time Laser activation time per pulse. These values are directly in interplay 
with the laser power and frequency.Pulse off time Laser deactivation time between the 

individual pulses (with > 1 pulses).

Pulses per dot Number of pulses emitted per 
marking point.

Screen display of a Dot Matrix font with vector jumps shown.
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String of a Text Object
 

Content and Display Options for multi-line Text Objects

 

The content of a text object consists a string. In turn, this string can consist of any combination 
of letters and numbers. weldMARK™differentiates between one-line and multi-line strings (with 
paragraph breaks) and provides different functions for each case.

￮ Right click on a a multi-line text object.
￮ Select Properties.... 
￮ Select String tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S027

(1) Font of the text object.

(2) Content of the text object (string).

String orientation Multiline Text objects can only be created with horizontal orientation.

 

The font styles "Bold" and/or "Italic" can be applied to text object.
The font styles are available only for TrueType™ Fonts.

  

Text alignment buttons for multi-line texts (left aligned, centered, right 
aligned).

The Windows character map is called up to make it easier to enter special 
characters. ( ➜ page 68, Unicode Character Map)

Character kerning The spacing between the individual characters can be changed. Positive 
values increase the spacing, negative values reduce it. Setting the value 
"0" uses the kerning defined in the character set.

Character width growth The width of the individual characters can be changed. Positive values 
increase the character width, negative values reduce it. Setting the value 
"0" uses the character width defined in the character set.

Line spacing The spacing between the lines can be changed. Positive values increase 
the spacing, negative values reduce it. Setting the value "0" uses the line 
spacing defined in the character set.
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Content and Display Options for single line Text Objects
 

 

 

￮ Right click on a a single line text object.
￮ Select Properties.... 
￮ Select String tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S028

(1) Font of the text object.

(2) Content of the text object (string).

 

The font styles "Bold" and/or "Italic" can be applied to text object.

The Windows character map is called up to make it easier to enter special 
characters. ( ➜ page 68, Unicode Character Map)

String orientation You can choose between Horizontal, Vertical, Radial and Radial – fixed. 
If a 4-Axis motor control card is installed, the additional option 
circumferential is also available.

Character kerning The spacing between the individual characters can be changed. Positive 
values increase the spacing, negative values reduce it. Setting the value 
"0" uses the kerning defined in the character set.

Character width growth The width of the individual characters can be changed. Positive values 
increase the character width, negative values reduce it. Setting the value 
"0" uses the character width defined in the character set.

Horizontal Vertical Radial
Clockwise (CW fit)

Radial 
Anticlockwise 
(CCW fit)

Circumferential

The difference between Radial and Radial Text – fixed lies in the extended editing functions. 
The height can be changed for example. Additionally the Radial Text fixed can directly be 
adjusted to radii.

➜ page 66, Additional Setting Options for Radial Text

➜ page 67, Additional Setting Options for Circumferential Text

➜ page 104, Size Option for Standard and radial Text Objects
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Additional Setting Options for Radial Text
    

Additional Setting Options using Keyboard Commands
 

 

S038

S039

Radial Radial - fixed

Radial orientation The text can run clockwise (CW fit) or anticlockwise (CCW fit).

Character width growth The width of the individual characters can be changed. Positive values 
increase the character width, negative values reduce it. Setting the value 
"0" uses the character width defined in the character set.

The following settings can be made exclusively using keyboard commands if the Properties 
and Dimensions windows are closed:

Radius Make sure that the required text object is selected. Hold down the ALT key 
and use the Up and Down arrow keys to enlarge or reduce the object 
radius.

Rotation Make sure that the required text object is selected. Hold down the ALT key 
and use the Right and Left arrow keys to rotate the object radius.
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Additional Setting Options for Circumferential Text
 

  

The Circumferential option is only available if 
the optional 4-Axis motor control card is 
installed and the rotary axis activated. The 
following additional settings are available:

S10
3

Part radius Radius of the cylinder.

Index step speed Step speed of the motor.

Index step delay Delay between the movement of the motor and marking of the character. 
This allows the motor to come to rest before marking is performed.

Reset indexer to Enable this function to return the motor to a defined start position before 
processing an object.

Center Text The text is placed in the middle of the range starting point.

Direction CW/CCW: Cylinder will be marked in clockwise or counter clockwise 
movement.
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Unicode Character Map
 

    

  

The Windows Unicode character map enables you to insert any characters in a font, 
particularly special characters, into the string of characters in a text object.

￮ Right click on a text object.
￮ Select Object >Properties....
￮ Select String tab.
￮ Click on the Character Map icon.

The dialogue on the right opens. 
Refer to the table below for explanations.

S103

Font This selection box can be used to select a font.

Select Clicking on this button adds the selected character to the list of Characters 
to copy.

Characters to copy This field lists the selected characters.

Group by This selection box can be used to display a subgroup of characters from 
the selected font.

Copy Clicking on this button copies the characters in the Characters to copy list 
to the clipboard.

Character Map



Working with Objects Chapter 4

MN013 / v3.5.0 RAYLASE weldMARK 3 69

4.4.7 Barcode/Data Matrix Objects

Adding a Barcode Object   

Properties of a Barcode Object
 

  

￮ Select Objects >Add >Barcode option from 
the menu. The selection can not be 
change afterwards. 
The dialogue on the right opens.

￮ Select the required barcode type.
￮ Enter the desired data for the barcode.
￮ Click on Add button.

A new barcode object is inserted in the 
center of the workspace.

S030

Properties are assigned to barcode objects, which determine how the objects are displayed on 
the screen and how they behave during laser processing. These properties are divided up as 
follows:

Profile A marking profile is assigned to the 
object. The parameters of this profile 
can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the 
object.

➜ page 76, Settings for a Data Matrix Object
➜ page 70, Defaults for 1D Barcode Objects

String Content of the barcode object. ➜ page 80, String for a Barcode/Data Matrix 
Objects

Source The content of barcode objects can 
be changed dynamically based on 
various rules.

➜ page 89, String rules

Tuner The barcode can be adapted to 
individual requirements.

➜ page 74, Tuner Values for Barcode Objects
➜ page 81, Tuner Values for Data Matrix 
Objects

Fill A fill can be applied to the object. ➜ page 86, Object Fill

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied 
to the object. If the external control is 
activated, external signals determine 
whether the object is marked or 
skipped.

➜ page 28, External Control

Tiling while 
marking

Used to mark oversized objects that 
are bigger than the marking area.

➜ page 111, Automatic Tiling

New 
barcode
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Barcode Objects (1D Code)
 

 

 

 

Defaults for 1D Barcode Objects

 

The following 1D Barcode objects are supported by weldMARK™:

Barcodes

Code 39, Extended Code 39, HIBC Interleaved 2 of 5 (ITF) 

CodeBar POSTNET (Zip+4, Zip+6) 

Code 93 UPC A, UPC E 

Code 128, EAN/UCC 128 EAN 8, EAN 13, BookLan 

EAN 8 and EAN 13 can be supplemented by 2 or 5 digits. Therefore, enter the desired string 
and, separated with a comma, the supplementary 2 or 5 digits.

The following examples sum up the possibilities:

EAN 8 EAN 13

12345678,12 123456789012,12

12345678,12345 123456789012,12345

This section describes how to call up and modify the defaults for 1D Barcode objects. The 
defaults apply to all new 1D Barcode objects.

￮ Select Objects >Defaults... option from the 
menu.

￮ Select the object type 1D Barcode. 
The dialogue on the right opens.
Refer to the table below for explanations.

S028

Style Provides the selection of hatches.

Fill spacing When marking a barcode object, each bar is created with single lines. Via 
this input box the distance between these fill lines can be set. A value of "0" 
means that the bars will not be filled.

Offset Distance between the filling and the contour.

Slope Hatching angle for parallel lines.

Mark outline If this function is enabled, the contour lines for bars will be marked. This 
function is disabled by default.

Mark fill If this function is enabled, the object fill will be marked. The function can 
only be selected if a fill has been set. This function is disabled by default.

Invert barcode Enabling this function creates a negative of the original barcode. This 
function is disabled by default.

Meander The fill of the object is marked in one go, i.e., without switching off the laser 
between end and start point of the single lines.
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Settings for a 1D Barcode Object 

  

General Settings for all Mark Styles

Specific settings are assigned to each barcode object. They can be called up and, if necessary, 
modified as follows:

￮ Right click on a 1D Barcode object.
￮ Select Properties.... 
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S033

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen.

Mark style Barcode objects can be marked by using vectors, dots or circle dots.
➜ page 72, Settings for "Dot" Mode
➜ page 73, Settings for "Circle dots" Mode
In both cases the mark style replaces the filling and the fill tab is hidden.

Mark outline If this function is enabled, the contour lines of the bars will be marked. This 
function is disabled by default.

Mark fill If this function is enabled, the object fill will be marked. The function can 
only be selected if a fill has been set. This function is disabled by default.

Display vector jumps If this function is enabled, the entire sequence of movements is displayed 
on the screen, including the times in which the laser is deactivated while 
moving to the next vector to be marked (vector jumps). This function is 
disabled by default.
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Settings for "Dot" Mode   
84

Dot spacing Defines the spacing of the dots to each other and to the cell edge. At the 
same time, the number of dots, which are placed side by side, is 
determined.

Dot display size This parameter does not influence the actual marking. Ideally, the Dot 
display size matches the effect size of the dot marking. This allows the 
prediction of the marking quality on the computer screen.

Pulse on time Laser activation time per pulse. These values interplay with 
laser power and frequency 
directly. Consequently they 
determine the effect size of 
dot marking.

Pulse off time Laser deactivation time between the 
individual pulses (with > 1 pulses).

Pulses per dot Number of pulses emitted per dot.

Show and mark cell 
outlines

If this function is enabled, the contour of the cells is displayed and marked 
even if Mark Object is deactivated.

Example:

Dot spacing: 40px Dot spacing: 20px
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Settings for "Circle dots" Mode

Circle spacing Sets the midpoints distance of the circle dots. At the same time it is 
determined how many circle dots are placed side by side.

Number of sides Each circle is made up by a number of lines. The more lines, the more 
rounded the circle appears.

Circle diameter Allows to set the circle diameter. 

Show and mark cell 
outlines

If this function is enabled, the contour of the cells is displayed and marked 
even if Mark Object is deactivated.

Example:

Circle spacing: 35bit
Circle diameter: 20bit

Circle spacing: 35bit
Circle diameter: 40bit
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Tuner Values for Barcode Objects
   

￮ Right click on a barcode object.
￮ Select Properties....
￮ Select Tuner tab.

1D Barcode objects

1D Barcode objects

(1) Norm type Selection on norm type depends on the barcode type.

Bar Width reduction The bar width can be adjusted between -99% and 99%. A positive value 
reduces the bar width, a negative value increases it.

Narrow/Wide ratio Ratio of dark and light areas in the barcode (the value must be an integer 
between 20 and 30).

Add check character Enabling this function adds a check character to the barcode.

Display check character When enabled, the check character is displayed as plain text (only 
available if Add check character is selected).

Invert barcode Enabling this function creates a negative of the original barcode. This 
function is disabled by default

Quiet zone/width The width of the quiet zone can be set relative to the 
barcode width.
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Data Matrix Objects (2D Code)

 

 

Default settings for Data Matrix Objects

This section describes how to call up and modify the defaults for Data Matrix ECC200 objects. 
The defaults apply to all new Data Matrix ECC200 objects.

  

The following Data Matrix objects are supported by weldMARK™: 

Codes

Data Matrix (ECC200) Square and rectangular shapes

Denso QR code Type 4 (max. 33x33 cells)

PDF417

￮ Select Objects >Defaults... option from the 
menu.

￮ Select the object type Data Matrix 
ECC200. 
The dialogue on the right opens.
Refer to the table below for explanations.

S028

Style Provides the selection of hatches.
➜ page 88, Set Spiral filling

Fill spacing When marking, each cell in the barcode is created with single lines. Via this 
input box the distance of these fill lines can be set. A value of "0" means 
that the bars will not be filled.

Offset Distance between the filling and the contour.

Slope Hatching angle for parallel lines.

Mark outline If this function is enabled, the contour lines of the cells will be marked. This 
function is disabled by default.

Mark fill If this function is enabled, the object fill will be marked. The function can 
only be selected if a fill has been set. This function is disabled by default.

Invert barcode Enabling this function creates a negative of the original barcode. This 
function is disabled by default.

Quiet border width Defines the width of the frame of an inverted barcode relative to the 
barcode size.

Fit to cell Adjusts the position of the elements (circles, circle dots or vector lines) in 
such a way that they fit into the respective cell. The cell size maintains 
constant.

Adjust diameter Adjusts the size of circle dots in such a way that they fit into the respective 
cell. This means that they do not overflow the cell boundary and fill the 
whole cell area.

Cell width reduction Allows percentage reduction or extension of the cell width.
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Settings for a Data Matrix Object 

  

General Settings for all Mark Styles

2D Barcode type Allows the selection of a 2D Barcode type. For each type, different settings 
are offered.Data Matrix type

Mark across adjoining cells Combines nearby cells to reduce marking time.

Mark cells individually Marks each cell individually in order to optimize the marking quality.

Autoenlarge Size Adjusts the amount of cells automatically, when the barcode content 
changes.

Enable Tilde (~) character Allows to embed the tilde character into the barcode content.

Specific settings are assigned to each barcode object. They can be called up and, if necessary, 
modified as follows:

￮ Right click on a Data Matrix ECC200 
object.

￮ Select Properties.... 
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S033

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the pre-set colors to 
display the object on screen.

Mark style Barcode objects can be marked by using vectors, dots or circle dots.
➜ page 77, Settings for Mark Style "Vector"
➜ page 78, Settings for Mark Style "Dot"
➜ page 79, Settings for Mark Style "Circle dots"

Display vector jumps If this function is enabled, the entire sequence of movements is displayed 
on the screen, including the times in which the laser is deactivated while 
moving to the next vector to be marked (vector jumps). This function is 
disabled by default.

Mark to If more than one control card is installed, this drop-down menu sets the 
desired control card for marking the object.
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Settings for Mark Style "Vector"
With this mark style the individual cells of Barcode Objects are marked by the succession of 
lines. The arrangement of these lines can be set via the Fill tab.

￮ Right click on a Data Matrix object.
￮ Select Properties.... 
￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.
See also: ➜ page 76, General Settings for 
all Mark Styles

S033

Fit to cell Adjusts the position of vector lines.
The fitting process for vector marking style takes into account the Fill 
spacing and the fill Offset defined in the Fill tab to space the lines evenly 
and to assure that the size of the cells is constant.
Fill spacing is recalculated so that the first and the last filling lines are 
placed on the same filling offset distance to the outline.
If Fit to cell is disabled, the number of lines to mark the cells may vary. This 
may lead to various cell sizes.

Mark across adjoining cells The barcode filling is processed column-wise along the Data Matrix width. 

Mark cells individually Each barcode cell is processed sequentially.

Mark outline If this function is enabled, the contour lines of the cells will be marked. This 
function is disabled by default.

Mark fill If this function is enabled, the object fill will be marked. The function can 
only be selected if a fill has been set. This function is disabled by default.

Example:

Fill with parallel lines, 
Fit to cell, 
Fill Offset,
Mark across adjoining cells

Fill with parallel lines, 
Fit to cell, 
Fill Offset,
Mark cells individually

Hint: Since Fit to cell is a relative parameter, the marking quality is obtained even if the object size has 
been changed.
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Settings for Mark Style "Dot"

  

￮ Right click on a Data Matrix object.
￮ Select Properties.... 
￮ Select Settings tab.

The corresponding dialogue opens. Refer to the table below for explanations.
See also: ➜ page 76, General Settings for all Mark Styles

84

Fit to cell The distance of dot centers is recalculated so that the edge of the 
outermost circles (dots) lay on the edge of the object (cell) reduced by the 
fill Offset.

Offset (Fill tab) Allows to set a distance to the cell edge.

Dot row/columns Sets indirectly the number of dots per cell.

Spacing growth Allows to add a percentage factor to the automatically calculated distance 
of the circle centers. Can not be used if Fit to cell is enabled.

Dot display size This parameter does not influence the actual marking. Ideally, the Dot 
display size matches the effect size of the dot marking. This allows the 
prediction of the marking quality on the computer screen.

Pulse on time Laser activation time per pulse. These values interplay with 
laser power and frequency 
directly.

Pulse off time Laser deactivation time between the 
individual pulses (with > 1 pulses).

Pulses per dot Number of pulses emitted per dot.

Show and mark cell 
outlines

If this function is enabled, the contour of the cells is displayed and marked 
even if Mark Object is deactivated.

Example:

Dot row/columns: 3 Fit to cell Offset

Hint: Since Fit to cell is a relative parameter, the marking quality is obtained even if the object size 
has been changed.
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Settings for Mark Style "Circle dots"

￮ Right click on a Data Matrix object.
￮ Select Properties.... 
￮ Select Settings tab.

The corresponding dialogue opens. Refer to the table below for explanations.
See also: ➜ page 76, General Settings for all Mark Styles

Fit to cell The distance of circle dot centers is recalculated so that the edge of the 
outermost circles lay on the edge of the object (cell) reduced by the fill Offset.
The spacing between circle dots is increased by the fill Offset value. Thus, the 
marked circles will not overlap if lasers with different spot sizes are used.

Adjust diameter Changes the diameter of the circles so that they fit exactly together to the cell.
If the diameter is smaller than the distance between circle dot centers, it is 
increased so that circles are spaced evenly and cover the whole cell.
If the diameter is larger than the distance between circle dot centers, the 
diameter is reduced so that circles dots do not overlap.
If the diameter is that large that circle dots overflow the cell outline, it is 
reduced so that the size of the cell doesn‘t increase.

Circle row/columns Sets indirectly the number of circular dots per cell.

Offset (Fill tab) Allows to specify a distance between neighbouring circle dots and also to the 
cell edge.

Spacing growth Allows to add a percentage factor to the automatically calculated distance of 
the circle centers. Can not be used if Fit to cell is enabled.

Number of sides Each circle is made up by a number of lines. The more lines, the more rounded 
the circle appears.

Circle diameter Allows to set the circle diameter.
Hint: This diameter will be also maintained if the object size has been changed.

Show and mark cell 
outlines

If this function is enabled, the contour of the cells is displayed and marked 
even if Mark Object is deactivated.

Example 1:

Circle row/columns: 
3

Fit to cell Adjust diameter Offset

Example 2:

Circle row/columns: 
3

Fit to cell Offset

Hint: Since Fit to cell and Adjust diameter are relative parameters, the marking quality is obtained 
even if the object size has been changed.
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String for a Barcode/Data Matrix Objects
  

 

￮ Right click on a barcode object.
￮ Select Properties....
￮ Select String tab.
￮ The dialogue on the right opens. 

Refer to the table below for explanations.

S034

Barcode string Content of the barcode object. If content should not be a fixed string different 
options are available. ➜ page 89, String rules

Mark human readable 
text string

If this function is enabled, in addition to the barcode the associated string is 
marked in plain text.

Font Font for the plain text.

String position The string can be positioned below, above, left or right to 
the barcode.

String 
orientation

The alphanumeric string can be rotated in 90° increments.

String height The height of the characters relative to the height of the 
barcode can be set.

Distance from 
barcode

The distance between the string and the barcode can be 
set relative to the height of the barcode.
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Tuner Values for Data Matrix Objects
 

  

 

Some barcode types require individual options and tuner settings. The tuner values in the fol-
lowing example represent the values for Data Matrix type ECC200 and QR-Code objects. 
Please refer to the respective Data Matrix specifications for non-listed tuner values of other 
Data Matrix types.

￮ Right click on a barcode object.
￮ Select Properties....
￮ Select Tuner tab.

Data Matrix ECC200 objects QR-Code objects

Data Matrix ECC200

Data Matrix type Defines the cell to column proportion as well as the amount of cells in the 
Data Matrix code. See table ➜ page 82, Code Pattern ECC200.

Cell width reduction Reduces the cell size in percentage. Empty spaces between cells can be 
created this way.

Enable Tilde (~) character Allows to embed the tilde character into the barcode content.

Invert barcode Enabling this function creates a negative of the original barcode. This 
function is disabled by default

Quiet border width In this field the relation between the width and the size of the barcode can 
be set.

Autoenlarge Size Adjusts the amount of cells automatically, when the barcode content 
changes.
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Code Pattern ECC200

Square Rectangular Fixed square

8x18 10x10 44x44

8x32 12x12 48x48

12x26 14x14 52x52

12x36 16x16 64x64

16x36 18x18 72x72

16x48 20x20 80x80

22x22 88x88

24x24 96x96

26x26 104x104

32x32 120x120

36x36 132x132

40x40 144x144

Code pattern is fixed, even if content is getting larger, unless auto-enlarge 
option is selected

8x18 Barcode size - extended option

In case of Data Matrix Barcodes with 8x18 size the maximum allowed capacity is 10 digits or 6 
alphanumeric characters.
With the new option, the allowed capacity is extended to 8 characters with not more than 1 
alphanumeric character and 7 digits, or 2 alphanumeric character and 6 digits.

Symbol Size Capacity

Digits Alphanumeric Characters

Square
min 10x10
max 144x144

3116 2335

8x18 10 6

7/6 Digits & 1/2 Alphanumeric Character 7/6 Digits & 1/2 Alphanumeric Character

8 x 32 20 13

12x26 32 22

12x36 44 31

16x36 64 46

16x48 98 72
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Denso QR-Code

Model Model 1 > Spec = AIM International Symbol Specification 97-001
Model 2 > Norm = ISO/IEC 18004 First Edition
MicroQR > Norm = (JIS Japan Industry Standard) X 0510

Error Correction Level L = Low > 7% of codewords can the restored
M = Medium > 15% of codewords can the restored
Q = Quartile > 25% of codewords can the restored
H = High > 33% of codewords can the restored

Cell Width reduction Allows percentage or extension of cell size

Capacity of QR-Codes (Type Version 4) Pattern Limit 33x33

Mode Error Content limit in [bits]

1 L ≈ 622

1 M ≈ 462

1 H ≈ 380

1 Q ≈ 253

2 L ≈ 627

2 M ≈ 495

2 H ≈ 369

2 Q ≈ 275

MicroQR L ≈ 120

Needed bits:

Small letter 8 bits

Capital letter 5,5 bits

Digit 3,3 bits
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4.4.8 Drill objects
 

Adding a Drill Object
    

 

Properties of a Drill Object
 

  

When executing drill objects, the laser is moved to the specified coordinates and activated for a 
set time. Drill objects consist of individual dots arranged in rows and columns. Drill objects are 
used for perforating or drilling through a workpiece, for example.
Drill points are always arranged alongside both axis in constant spacings and are processed in 
bidirectional order.

￮ Select Objects >Add >Drill... option from the 
menu. 
The dialogue on the right opens. 
Refer to the table below for explanations. 

S031

Columns Number of (dot) rows and columns that the drill object will consist of. 
The total amount is 1000 points for columns/cells.Rows

No. of points Number of dots that the drill object consists of. This is the product of cells 
and columns per default. If an amount of points is chosen, that is smaller 
than the product, the difference in points is subtracted at the end of the 
Dot Matrix. 
Note that a value of "1" creates a single dot.

Pulses per dot Number of pulses emitted per marking point.

Properties are assigned to drill objects, which determine how the objects are displayed on the 
screen and how the behave during laser processing. These properties are divided up as fol-
lows:

Profile A marking profile is assigned to the object. The 
parameters of this profile can be changed.

➜ page 135, Using Profiles

Settings Various settings can be made for the object. ➜ page 85, Settings of a Drill 
Object

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

Tiling while 
marking

Used to mark oversized objects that are bigger than 
the marking area.

➜ page 111, Automatic Tiling

New 
drill object
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Settings of a Drill Object
 

  

 

Every drill object is assigned specific settings that can be called up and, if necessary, modified 
as follows:

￮ Right click on a drill object.
￮ Select Properties....

￮ Select Settings tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S032

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

On screen color The color selection list can be used to select one of the pre-set colors to 
display the object on screen.

Dot display size Dot size on the screen. Points are shown squared. This parameter has no 
influence on the actual marking.

Pulse on time Laser activation time per pulse. These values are directly in interplay 
with the laser power and frequency.Pulse off time Laser deactivation time between the 

individual pulses (with > 1 pulses).

Pulses per dot Number of pulses emitted per 
marking point.

Mark object Enabling this function means that the object will be marked. This function is 
enabled by default.

Display vector jumps If this function is enabled, the entire sequence of movements is displayed 
on the screen, including the times in which the laser is deactivated while 
moving to the next vector to be marked (vector jumps). This function is 
disabled by default.

Rows Number of rows of dots in the drill object.

Columns Number of columns of dots in the drill object.

No. of points Number of dots that the drill object consists of. This is the product of cells 
and columns per default. If an amount of points is chosen, that is smaller 
than the product, the difference in points is subtracted at the end of the 
Dot Matrix. 
Note that a value of "1" creates a single dot.

Mark to If more than one control card is installed, this drop-down menu sets the 
desired control card for marking the object.
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4.5 Object Fill
 

  

 

  

 

 

 

Object fill with a distance to the object outline

weldMARK™ enables areas of objects to be filled. Only objects with a completely closed con-
tour can be filled. This may be either characters of a text object, polygon or rectangle objects, 
enclosed Bezier or polyline objects, barcode objects or objects of an imported Vector Graphic.

The exceptions are bitmap objects, laser optimized fonts, Dot Matrix fonts and drill objects.

Overlapping objects can not be filled.

The fill is created by densely packed lines that can be identified as hatching with a larger 
spacing.

Empty object Filled object

The optimum spacing between the individual lines in a fill depends on the wavelength of the 
laser, the spot size, the material and other factors. The set line spacing is saved along with the 
object and remains unchanged even if the size of the object is changed.
The examples below show different fill spacings:

Fill spacing = 150 bits Fill spacing = 30 Bits

In addition to parallel lines, a crosshatch fill with different angles is available:

Crosshatch with 0 and 90 degrees Crosshatch with –45 and +45 degrees

Via the "Offset" option a distance between the object filling and the object outline can be 
defined:
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Set Object Fill
The filling of a selected object is activated and set as following:

  

   

￮ Right click on the object you want to fill.
￮ Select Properties.... 
￮ Select Fill tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S224

Fill all closed 
paths in object

If this function is enabled, all closed paths in the selected object are filled.

Style 

 

Parallel lines

Crosshatch

Parallel lines, bidirectional

Crosshatch, bidirectional

Spiral (only for Data Matrix ECC200 barcodes)

Meander Only for barcode objects with bidirectional hatches 
(not for Data Matrix ECC200):
The filling of the objects is marked in one go, i.e. 
without switching off of the laser between end and start 
point of the single lines.

Fill spacing Spacing of the fill lines.

Skip Frame Inverts the filling of vector objects with multiple layers. All 
previously unfilled areas are filled, and vice versa.

Offset This option enables an improvement of the marking quality of a 
filled object. The laser beam creates rounded start and end dots 
with the diameter of the laser spot on each fill line. This causes a 
waved appearance of the object outline
The outline is straightened by an additional marking of the 
outline itself. Because the outline overlaps the start and end 
points of the filling lines, these areas are marked twice. This can 
be prevented by an offset, i.e. a distance between the outline 
and the filling lines.

Slope 1 Hatching angle for parallel lines.

Slope 2 Hatching angle for crosshatch.

Text as Graphic Text within the graphic object should be part of the filled layout.

Maximized Fill Use if graphic has closed and non-closed contour.

Drill fill If this function is enabled, the filling of the object is marked with details instead of 
lines. This function is available if Fill all closed paths in object is enabled. The point 
array follows the direction of fill-lines.

Drill pulse count Number of pulses per point.

Drill spacing Spacing between the drills.

Drill pixel size Size of the drills.
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Set Spiral filling
Spiral filling (only available for Data Matrix ECC200 barcodes) of a selected barcode is acti-
vated and set as following.

Example for the combination of the two 
options "Text as Graphic" and 
"Maximized Fill".

S224

￮ Optiopn is only selectable when barcode is 
optimized for quality 
(Mark cells individually)

￮ Right click on the object you want to fill.
￮ Select Properties.... 
￮ Select Fill tab.

The dialogue on the right opens. 
Refer to the table below for explanations.

S224

End Offset Offset Settings for the barcodes from inside.

Radial orientation Inside: Filling is marked from inside to outside.
Outside: Filling is marked from outside to inside.

Adjust fill spacing Spacing of the fill lines.
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4.6 String rules
 

  

 

The range of options available is reduced for multi-line text objects.

The strings on which text and barcode objects are based can be changed dynamically during 
execution of the job. The context of the string is adjusted at regular intervals according to the 
selected string rule..
The string rule for a text or barcode object can be called up and, if necessary, modified as 
follows:

￮ Right click on a text or barcode object.
￮ Select Properties.... 
￮ Select Source tab.

The dialogue on the right opens. The table 
below contains an overview of the availa-
ble string rules.

S040

Justify With strings of different lengths, this function aligns the strings with the 
selected point in the original string (left, right, centered / top, center, 
bottom).

Use current string. The content of the String tab acts as the source for the string. This is the 
default setting.

User TextMerge The source of the string is a linked text file.
➜ page 90, "Use TextMerge" string rule (one line objects)
➜ page 91, "Use TextMerge" string rule (multi-line objects)
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Use AutoDate Depending on the setting, the string will either consist of the current date, 
the current time or the current shift code.
➜ page 92, "Use AutoDate" string rule

Supply string at start The string must be entered by the user before starting each job. This entry 
is then valid until the end of the job.
➜ page 94, "Supply string at start" string rule

Supply string every 
mark 

The string must be entered by the user each time the object is marked.
➜ page 95, "Supply string every mark" string rule

Serialize w/current 
start value

The content of the string is changed in specified increments. The content of 
the String tab is used as start value.
➜ page 96, "Serialize w/current start value" string rule

Serialize w/supplied 
start value 

The content of the string is changed in specified increments. The user is 
prompted to enter a start value.
➜ page 97, "Get string from memory buffer" string rule

Get string from 
memory buffer 

The content of one of the ten weldMARK™ buffers is used as the source for 
the string.
➜ page 98, "Get string from memory buffer" string rule

Custom string The content of the string is determined by a formatting code.
➜ page 99, "Custom string" string rule
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4.6.1 "Use TextMerge" string rule (one line objects)
 

  

  

This rule enables the strings for one line text or barcode objects to be loaded from a merge file. 
A simple text file with the extension ".txt" is used as the merge file. Each string in the merge file 
must be completed with a line break (Enter key). This also applies to the last line in the merge 
file. 

The parameters of the TextMerge function can be set as follows for one line objects:

￮ Right click on a one line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Use TextMerge string rule.

The dialogue on the right opens. 
Refer to the table below for explanations.

S041

Justify With strings of different lengths, this function aligns the strings with the 
selected point in the original string (left, right, centered / top, center, 
bottom).

Restart automatically If this function is enabled, the merge file will be re-processed as soon as its 
end has been reached.

Update string If this function is enabled, the merge file will be read again before 
executing.

MergeFile The specified text file is completely loaded when starting the job. For each 
marking operation, the string for the text or barcode object is overwritten 
with the next line from the merge file. If the job is ended, weldMARK™ sets 
a bookmark in this text file to indicate the last item processed.

New The merge file can be created, searched, loaded and edited in 
weldMARK™.Edit

Browse...

# objects in group Number of text or barcode objects in current job that read their string from 
the same merge file. The value entered corresponds to the increment for 
reading the lines: For each marking operation, lines in the merge file are 
skipped corresponding to the number of objects in the group.

Start line Number of the first line to be read from the merge file.

Update string Updates the display while the marking process is ongoing. 

Upon reaching the end of the merge file, the user is prompted to start with the first entry again 
or cancel, per dialogue.
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4.6.2 "Use TextMerge" string rule (multi-line objects)

  

 

This rule enables the strings for multi-line text or barcode objects to be loaded from a merge 
file. A simple text file with the extension ".txt" is used as the merge file. Each string in the 
merge file must be completed with a line break (Enter key). This also applies to the last line in 
the merge file.

The parameters of the TextMerge function can be set as follows for multi-line objects:

￮ oRight click on a multi-line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Use TextMerge string rule.

The dialogue on the right opens. 
Refer to the table below for explanations.

S061

MergeFile The specified text file is completely loaded when starting the job. For each 
marking operation, the string for the text or barcode object is overwritten 
with the next lines from the MergeFile. If the job is ended, weldMARK™ sets 
a bookmark in this text file to indicate the last item processed.

Restart automatically If this function is enabled, the merge file will be re-processed as soon as its 
end has been reached.

Update string If this function is enabled, the merge file will be read again before 
executing.

New The merge file can be created, searched, loaded and edited in 
weldMARK™.Edit

Browse...

Update string before mark Updates the display while the marking process is ongoing. 

Upon reaching the end of the merge file, the user is prompted to start with the first entry again 
or cancel, per dialogue.
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4.6.3 "Use AutoDate" string rule
 

  

  

This rule enables text or barcode objects to be marked with the current date, the current time or 
the current shift code. This information is derived from the Windows system clock and is 
updated for each marking operation

￮ Right click on a one line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Use AutoDate string rule.

The dialogue on the right opens. 
Refer to the table below for explanations.

S042

Justify With strings of different lengths, the strings are aligned with the selected point in the 
original string (left, right, centered).

Format Format selection for the AutoDate string. The available AutoDate formats are as 
follows (example date 15th January 2006):

Format Output

YYMMDD 060115

MM/DD/YY 01/15/06

DD/MM/YY 15/01/06

Month DD, YYYY January 15, 2006

DD Month, YYYY 15 January, 2006

YWW 602 (WW: Week number)

YMD 61E (single digit alphanumeric values for year, month and 
day. Sequence: 1,2,3...9,0,A,B,C...)

DDD 015 (three digit value for day of the year)

DDDY 0156 (three digit value for day of the year and single digit 
value for the year)

YY 06

Shift code See next section.

DDMY 1516

HH:MM:SS 11:55:00

Update string 
before mark

Updates the display while the marking process is ongoing. 
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4.6.4 String rule "AutoDate", Format "Shift code"
 

  

  

This format is part of the AutoDate string rule ( ➜ page 92, "Use AutoDate" string rule). If this 
format is selected, the current shift code is applied to the object as a string for each marking 
operation. The information is derived from the Windows system clock.

￮ Right click on a one line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Use AutoDate string rule.
￮ Select the Shift code format.

The dialogue on the right opens. 
Refer to the table below for explanations.

S043

Shift 1 … Shift 5 These check boxes can be used to activate up to five shifts.

Start time These fields are used to define the start and end times for 
each shift. If the shifts overlap, the first permissible shift is 
used. The remaining shifts are ignored. If there are periods 
of time that are not assigned to an active shift, a "?" is 
output.
If a shift includes the time 0:00 (change of date), it must be 
split into two sections with the same shift code.

Stop time 

String to mark These fields can be used to enter the shift codes to be 
marked with the laser.

Update string before 
mark

Updates the display while the marking process is ongoing. 
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4.6.5 "Supply string at start" string rule
 

  

 

Starting dialogue

The following dialgue is shown after starting the job.

If this rule is selected, each time a job is started the user is prompted to enter a string for the 
text or barcode object. This string rule will be used until the end of the job and will stay the 
same during repeated cycles for example.

￮ Right click on a one line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Supply string at start string rule.

The dialogue on the right opens. 
Refer to the table below for explanations.

S044

Justify With strings of different lengths, the strings are aligned with the selected point in the 
original string (left, right, centered).

Update string 
before mark

Updates the display while the marking process is ongoing. 

OK Confirms the value.

Skip Repeats the previous value

Cancel Cancels the cycle at this point.
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4.6.6 "Supply string every mark" string rule
 

  

 

Starting dialogue

The following dialogue is shown after starting the job.

If this rule is selected, the value of a text or barcode object is automatically increased or 
reduced by a particular value. The entered string will be used for one marking only.

￮ Right click on a one line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Supply string every mark string 

rule.

The dialogue on the right opens. 
Refer to the table below for explanations.

S045

Justify With strings of different lengths, the strings are aligned with the selected point in 
the original string (left, right, centered).

Update string 
before mark

Updates the display while the marking process is ongoing. 

OK Confirms the value.

Skip Repeats the previous value

Cancel Cancels the cycle at this point.
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4.6.7 "Serialize w/current start value" string rule
 

  

 

If this rule is selected, the value of a text or barcode object is automatically increased or re-
duced by a particular value. 
When starting the job the user is prompted to enter a string as the start value.

￮ Right click on a one line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Serialize w/current start value 

string rule.

The dialogue on the right opens. 
Refer to the table below for explanations.

S046

Justify With strings of different lengths, the strings are aligned with the selected 
point in the original string (left, right, centered).

Increment Sets the increment by which the string will be changed. A positive value 
increases the value of the string, a negative value reduces it. Both letters 
and numbers can be incremented: 0001A is increased to 0001B. Note that 
an arrangement of letters is only permissible for ANSI text. It is possible 
that Unicode text consisting of letters will not be incremented correctly. 
Leading zeroes are retained.

Batch Batch size for serialization. The string is only incremented when the 
number of markings specified under Batch has been performed.

Update string before mark Updates the display while the marking process is ongoing. 
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4.6.8 "Get string from memory buffer" string rule
 

  

 

If this rule is selected, the value of a text or barcode object is automatically increased or re-
duced by a particular value.
When starting the job the user is prompted to enter a string as the start value.

￮ Right click on a one line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Serialize w/supplied start value 

string rule..

The dialogue on the right opens. 
Refer to the table below for explanations.

S047

Justify With strings of different lengths, the strings are aligned with the selected 
point in the original string (left, right, centered).

Increment Sets the increment by which the string will be changed. A positive value 
increases the value of the string, a negative value reduces it. Both letters 
and numbers can be incremented: 0001A is increased to 0001B. Note that 
an arrangement of letters is only permissible for ANSI text. It is possible 
that Unicode text consisting of letters will not be incremented correctly. 
Leading zeroes are retained.

Batch Batch size for serialization. The string is only incremented when the 
number of markings specified under Batch has been performed.

Update string before mark Updates the display while the marking process is ongoing. 
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4.6.9 "Get string from memory buffer" string rule
 

 

  

This rule enables the strings for text and barcode objects to be read from one of the ten 
weldMARK™-buffers immediately prior to the marking operation. The content of the buffer can 
constantly be changed using an external host program ( ➜ page 234, Remote Interface and 
➜ page 202, Global Settings).

￮ Right click on a one line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Get string from memory buffer 

string rule.

The dialogue on the right opens. 
Refer to the table below for explanations.

S048

Justify With strings of different lengths, the strings are aligned with the selected 
point in the original string (left, right, centered).

Buffer index Number of the weldMARK™ memory buffer to be used to obtain the data.

Buffer contents Current content of the weldMARK™ Buffer Index. When the application is 
started, the buffers are set to a value of "?".

Update string before mark Updates the display while the marking process is ongoing. 
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4.6.10 "Custom string" string rule
 

 

  

 

This rule enables the string for the text or barcode object to be created using a custom string.

￮ Right click on a one line text or barcode 
object.

￮ Select Properties.... 
￮ Select Source tab.
￮ Select the Custom String string rule.

The dialogue on the right opens. 
Refer to the table below for explanations.

S049

Justify With strings of different lengths, the strings are aligned with the selected 
point in the original string (left, right, centered).

Format specifier string Enter the custom string to be used to create a string for the object (see 
table below).

Code Code example Text created for string

%A Abbreviated day of the week (Mon, Tue, Wed, Thu, Fri, Sat, Sun)

%B Abbreviated month (Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, 
Oct, Nov, Dec)

%C Date and time (MM/DD/YY HH:MM)

%D Day of the month (01 - 31)

%H Hour (00 - 23)

%h Hour (00 - 12)

%J Day of the year (001 - 366)

%K Month code (1 - 9, O, N, D)

%L Last digit of year (0 - 9)

%M Month (01 - 12)

%N Minutes (00 - 59)

%F Seconds (00-59

%E After recall, the previously string is added by the actual string.

%O Ascending numerical value.
Starts with a value of "1" at the beginning of the process.

%o Same as code %O. 
After restart, the last used numerical value will be used as start value.

%P AM or PM

%Q# %Q1 The string is copied from the weldMARK™ buffer (# 1-10).

%R Week (01-53). Week "01" is the week that includes 1st January.

%r Week (01-53). Week "01" is the week that includes the first Thursday 
of the new year.
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%S,d,s,i,b %S,9,1,1,1 S = Consecutive number
d = End number
s = Start number
i = Increment
b = batch 

Note: Only integer values are supported. 
The parameters "i" and "b" must be positive.

%s Same as code %S. 
After restart, the last used numerical value will be used as start value.

%T Time (HH:MM)

%V’’ %V’RAYLASE’ Any text can be entered here. The text must be placed between 
quotation marks ("RAYLASE" in the code example).

%W Day of the week (coding: 1 = "Sunday" ... 7 = "Saturday")

%w Day of the week (coding: 1 = "Monday" ... 7 = "Sunday")

%X# %X5 A particular number of spaces can be inserted (5 spaces in the code 
example).

%Y Year (00 - 99)

Code Code example Text created for string
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5 TOOLS FOR EDITING MARKING OBJECTS
 

 

5.1 Aligning Objects
 

     

 

weldMARK™ provides the following tools for editing marking objects:

Align objects Objects can be aligned relative to one 
another.

➜ page 101, Aligning Objects

Dimensions Objects can be positioned, scaled, rotated 
or skewed.

➜ page 102, The "Dimensions" 
Toolbox

Grid/Guidelines The grid and the guidelines are used to 
make it easier to align objects on the 
screen. Their properties can be set.

➜ page 114, Grid Line Settings
➜ page 114, Modify Guidelines

Zoom tools The display size of the workspace on the 
screen can be enlarged or reduced.

➜ page 117, Appliance of the Zoom 
tools

The Align... tool enables the alignment relative to one another. Objects are always aligned to 
the last selected object.

￮ Select the objects you want to align.
￮ Select Tools >Align... option from the menu.

The dialogue on the right opens. Refer to the 
table below for explanations.

Top, Center, Bottom These check boxes allow you to specify the required vertical and horizontal 
alignment of the objects to one another.Left, Center, Right

Preview Clicking on this button displays the expected result of the alignment. Then 
the alignment can be reversed either by clicking on Reset or confirmed by 
clicking on OK.

Reset

Align objects
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5.2 The "Dimensions" Toolbox
 

  

5.2.1 Positioning objects
 

  

 

The "Dimensions" toolbox contains the following tools for editing marking objects:

String position ➜ page 102, Positioning objects

Scale ➜ page 103, Scaling and mirroring Objects

Size ➜ page 103, Changing the Object Size

Rotate ➜ page 106, Rotating Objects

Move to Folder... ➜ page 106, Nudging Objects

Skew ➜ page 107, Skewing Objects

Definition frame-spot:

The frame spot is defined as the lower-right corner of the virtual frame that covers objects.

The Position tool enables you to display and change an object's current position.

￮ Select a marking object.
￮ Select Objects >Dimensions... option from the menu.
￮ Select Position tool.

The dialogue on the right opens. Refer to the table below for expla-
nations.

String position The current position of the selected object is shown in the two input boxes. The 
specified position can be overwritten with your required target position.
The data relates to the frame spot of the object. Additionally a Z position for the 
lower edge can be defined for solid modellings (STL File Import).

Center Clicking on this button positions the selected object in the center of the 
workspace.

Apply Clicking on this button applies the settings made to the selected object.

Apply to Duplicate Clicking on this button copies the selected object and applies the changed 
settings to the copy.
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5.2.2 Scaling and mirroring Objects
 

  

  

 

5.2.3 Changing the Object Size
 

 

  

The Scale tool enables you to scale objects by a specified factor and, if required, to mirror 
them.

￮ Select a marking object.
￮ Select Objects >Dimensions... option from the menu.
￮ Select Scale tool.

The dialogue on the right opens. Refer to the table below for expla-
nations.

 

Scale The desired scaling factor for the X, Y and Z axis can be defined here.

Proportional If this function is activated all axis of the object will be scaled with the same 
factor.

Mirror Clicking on this button, mirrors the selected object horizontally or respectively 
vertically.

Apply to Z Scalings of 3D Vector Objects and solid modellings will be set proportionally to 
the Z axis (height axis).

Apply Clicking on this button applies the settings made to the selected object.

Apply to Duplicate Clicking on this button copies the selected object and applies the changed 
settings to the copy.

A separate tool is available for fixed radial text objects ( ➜ page 105, Changing the Object Size 
(Radial Text - fixed)).

The Size tool enables you to change the width and height of objects by entering the required 
values.

￮ Select a marking object.
￮ Select Objects >Dimensions... option from the menu.
￮ Select Size tool.

The dialogue on the right opens. Refer to the table below for 
explanations.

Size These input boxes display the current width, height and depth of the selected 
object if necessary. The values can be changed as required. The change in size 
is performed from the center of the selected object or object group.

Proportional If this function is enabled, the width and height of the object are changed by the 
same factor horizontally and vertically. Making an entry in one field changes the 
value in the other field automatically.

Apply to Z Size alteration of 3D Vector Objects and solid modellings will be set 
proportionally to the Z axis (height axis).

Apply Clicking on this button applies the settings made to the selected object.

Apply to Duplicate Clicking on this button copies the selected object and applies the changed 
settings to the copy.

The object size can also be changed by using the anchor points with the mouse. However, the 
value of the Z axis stays unchanged with 3D objects.
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Size Option for Standard and radial Text Objects
 

  

  

Example:
  

For standard text objects and for text objects with the Radial display option, in addition to the 
option of changing the size ( ➜ page 103, Changing the Object Size) the special Constraints 
function is available. This function enables assigning a different output size in relation to the 
size shown on the screen to these objects for the marking process.

￮ Select a text or radial text object.
￮ Select Objects >Dimensions... option from the menu.
￮ Select Size tool.
￮ Select Constraints option field.

The dialogue on the right opens. Refer to the table below for expla-
nations.

When marking, 
constrain size to

Enabling this function allows you to specify the output size of the radial text object.

The required output size for the radial text objects can be entered in these 
fields.

Apply Clicking on this button applies the settings made to the selected object.

Apply to Duplicate Clicking on this button copies the selected object and applies the changed settings 
to the copy.

Radial text variable Option: Constraints
The red rectangle indicates the 
output size.
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Changing the Object Size (Radial Text - fixed)
 

  

  

Example:  

Special options are available for changing the size of Radial - fixed type objects. Furthermore 
you can assign a different output size in relation to the size shown on the screen to these 
objects for the marking process.

￮ Select a fixed radial text object.
￮ Select Objects >Dimensions... option from the menu.
￮ Select Size tool.

The dialogue on the right opens.

Size The diameter for the base line of the text can be specified here.

The font size can be specified by entering the x-height and the ascender.

The font size can be specified by entering the descender.

Constraints Enabling this function allows selecting a different diameter for the marking process.

Apply Clicking on this button applies the settings made to the selected object.

Apply to Duplicate Clicking on this button copies the selected object and applies the changed settings 
to the copy.

Radial text - fixed
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5.2.4 Rotating Objects

 

 

 

5.2.5 Nudging Objects
 

 

  

The Rotate tool enables objects to be rotated by a specified angle. The middle of the object 
frame is the centre of rotation.

￮ Select a marking object.
￮ Select Objects >Dimensions... option from the menu.
￮ Select Rotate tool.

The dialogue on the right opens. Refer to the table below for expla-
nations.

Angle An angle for object rotation can be selected in this entry field.
Positive value: Rotation clockwise
Negative value: Rotation counter-clockwise

-90 | +90 Shortcuts to rotate object +90 / -90 degree.

Apply Clicking on this button applies the settings made to the selected object.

Apply to 
Duplicate

Clicking on this button copies the selected object and applies the changed settings to 
the copy.

The Nudge tool enables objects to be shifted by a specified angle.

￮ Select a marking object.
￮ Select Objects >Dimensions... option from the menu.
￮ Select Nudge tool.

The dialogue on the right opens. Refer to the table below for expla-
nations.

Nudge These input boxes can be used to specify values for the required movement of the 
object in horizontal and vertical direction.

Apply Clicking on this button applies the settings made to the selected object.

Apply to Duplicate Clicking on this button copies the selected object and applies the changed settings 
to the copy.
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5.2.6 Skewing Objects
The Skew tool enables skewing objects by a specified angle.

  

  

Example:
  

This tool is not available for fixed radial text objects.

￮ Select a marking object.
￮ Select Objects >Dimensions... option from the menu.
￮ Select Skew tool.

The dialogue on the right opens. Refer to the table below for expla-
nations.

Skew These input boxes can be used to specify values for skewing the object. Refer 
to the example below for details.

Apply Clicking on this button applies the settings made to the selected object.

Apply to Duplicate Clicking on this button copies the selected object and applies the changed 
settings to the copy.
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5.3 Tiling
 

Example:
  

 

To mark an object that is larger than the marking field, it has to be tiled. 
Two types of tiling are available, Tiling before marking ( ➜ page 109, Manual Tiling) and Tiling 
while marking ( ➜ page 111, Automatic Tiling), which are explained in the following sections. 
Tiling still shows the object as a whole and processes the parts, so they can be reassembled 
like a puzzle. The circle in the left drawing represents the marking object.

The dashed lines show the size of the marking field. The object has to be marked in 4 steps. 
Thereby, the component needs to be moved after every step.
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5.3.1 Manual Tiling
The following section specifies how to tile a marking object into a tiled object:

  

  

 

 

 

  

￮ Right click on a marking object.
￮ Select Tiling.
The dialogue on the right opens. Refer to the table below 
for explanations.

Tile Width Defines the width of each single tiled object.

Tile Height Defines the height of each single tiled object.

Object Margin Defines the space between tiled objects.

The object will be tiled in multiple tiled objects which are shown in the Object Manager. The 
naming of the tiled objects is composed out of the object name, the index number of the object 
and the coordinates of the tiled objects compared to the whole object. Parts with no content will 
not be contained in the object manager.

The following figure shows how a circle, tiled into four tiled objects, is displayed on the work 
space. The square shows the size of the marking field. Outside the untiled object is shown, 
which will can be deleted if it will no be used any more. On the insed the tiled objects stack on 
top of each other. The tiled parts can be stringed together with either automation objects 
( ➜ page 127, "XY Table" Automation Object) positioned to each other on the marking field, or 
along the marking direction (Mark on the Fly) via the Distance Encoder Steps function.
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Tiling and the "Mark-on-the-Fly" function
 

  

  

If a tiled object has to be marked with the "Mark-on-the-Fly" function, additional settings have 
to be configured. To prevent that tiled objects are marked on top of each other, a marking 
pause in the size of the previous object has to be assigned to the second object and all tiled 
objects after. The settings for the first tiled object must not be changed. After clicking the OK or 
Apply button, the specified value will be marginally changed, which has no consequences 
whatsoever.

￮ Right click on the tiled object.
￮ Select Properties....
￮ Select Ext. Control tab.
￮ Activate Before marking wait.

The red marked area, displayed in the fig-
ure on the right, will be activated. Refer to 
the table below for explanations.

MOTF control Before marking 
wait... Impulse

If bits is chosen as measuring unit.
If this function is activated and a value greater than zero 
is entered, marking of the chosen tiled object will begin 
after the marking pause.

Before marking 
wait...mm

If mmis chosen as measuring unit.
If this function is activated and a value greater than zero 
is entered, marking of the chosen tiled object will begin 
after the marking pause.

Before marking 
wait...Inch

If inch chosen as measuring unit.
If this function is activated and a value greater than zero 
is entered, marking of the chosen tiled object will begin 
after the marking pause.

Switch direction of 
the encoder

In some cases, caused by installation, the sensor signal 
arrives with the wrong moving sense. Though the 
direction of the encoder is reversed.
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5.3.2 Automatic Tiling
 

Example:  

This function is only available for vector objects (Rectangle, Polygon, Polyline and Bezier) and 
bitmap objects. 

The object is tiled in rectangle shaped parts and marked. A good comparison to this process 
would be placing floor tiles. 

There are two selectable marking types. In the Rotary Indexer mode marking takes place after 
each rotary movement, on the XY-Table Mode after each linear movement. The order of the 
tiles is autocratically defined and processed by the software. The individual tile-pieces are 
always marked in the field centre position. 

The rotary axis lay on the X axis of the field.

Rotary Indexer Marking process tiled in four parts with XY-movement. 
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Settings for the rotary indexer marking mode
  

  

￮ Right click on a Vector Graphic or bitmap 
object.

￮ Select Properties....
￮ Select Tile tab.
￮ Activate Tile object.

The dialogue on the right opens. Refer to 
the table below for explanations.

Tile object If this function is activated, the object will be tiled according to 
the following parameters.
This function is disabled by default. 

Tile Width The tile width can not be changed in the "Rotary Indexer" 
Mode.

Tile Height The tile height defines the height of the tiled parts.

Start Delay Defines the delay after the next tiled part is marked.

Go to position If this function is activated the rotary axis is brought to a 
predefined starting position. this position is the new starting 
position for the next marking. If this function is not activated 
the position of the Home Sensor will be used as reference 
points.

Center If this function is activated, the object is marked centrally to 
the starting position.

Marking Type Defines the Marking Type. The Rotary Indexer or the 
XY-Table can be chosen.

Radius This field is used to enter the radius of the cylinder generated 
surface. 

Starting position ... degrees before 
marking

Can be chosen if the presetting for the unit is mm or inch.
Defines the starting position prior to the marking of the object. 
The starting position can only be set if the Go to position 
function has been activated.

Starting position ... degrees before 
marking

Can be chosen if the presetting for the unit is bits.
Defines the starting position prior to the marking of the object. 
The starting position can only be set if the Go to position 
function has been activated.

Step speed Displays the step speed for the motor.
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Settings for the XY-table marking mode
 

 

￮ Right click on a Vector Graphic or bitmap 
object.

￮ Select Properties....
￮ Select Tile tab.
￮ Activate Tile object.
￮ Choose the XY-Table option.
The dialogue on the right opens. Refer to the 
table below for explanations.

Tile object If this function is activated, the object will be tiled according to the following 
parameters.
This function is disabled by default. 

Tile Width The width and height can be used to define the size of the tiled objects.

Tile Height

Start Delay Defines the delay after the next tiled part is marked.

Go to position When this option is enabled, the X and Y axis will be set to a predefined position. 
this position is the new starting position for the next marking. If this function is not 
activated the position of the Home Sensor will be used as reference points.

Center If this function is activated, the object is marked centrally to the starting position.

Marking Type Defines the Marking Type. The options rotary indexer and XY-table are available.

X Axis Starting position...before 
marking

Defines the starting position of the X axis before the 
marking of the object. The starting position is only 
available, if the function Go to position is selected.

Step speed Defines the step speed of the X axis before the marking 
of the object.

Y Axis Starting position...before 
marking

Defines the starting position of the Y axis before the 
marking of the object. The starting position is only 
available, if the function Go to position is selected.

Step speed Defines the step speed of the Y axis before the marking 
of the object.
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5.4 Grid/Guidelines
 

5.4.1 Grid Lines
 

Show and Hide Grid Lines
  ￮ Select View >Grid option from the menu.

Shows or hides grid lines.

Grid Line Settings
 

  

  

5.4.2 Guidelines
 

Show and Hide Guidelines
    

Modify Guidelines
 

  

  

The grid and the guidelines are used to make it easier to align objects on the screen. Their 
properties can be set.

The grid is formed out of horizontal and vertical lines in a constant distance and facilitates 
drawing and ordering objects.

The Grid Line Settings define the appearance of the grid on the screen, as well as the behav-
iour of the object when it is pulled near the Grid Lines.

￮ Select Tools >Grid/Guidelines... option from 
the menu.
The dialogue on the right opens. The figure 
shows grid line relevant information only. 
Refer to the table below for explanations. 

Horizontal Grid The horizontal and vertical distances between each grid line can be set 
here.Vertical Grid

Show Grid If this function is enabled, the grid lines are displayed.

Snap To Grid If this function is enabled, objects that are moved get aligned with the grid 
lines.

The horizontal and vertical distances between each guide line can be set here. Any combina-
tion of guide lines can be saved and loaded again later on.

￮ Select View >Guidelines option from the menu.
Shows or hides guidelines. This function is only available, if the guide lines have been set 
under ( below).

Guidelines can be added, moved or deleted. An unlimited amount of guide lines can be put on 
the workspace.

￮ Select Tools >Grid/Guidelines... option from 
the menu.
The dialogue on the right opens. The figure 
shows only the section that is relevant for 
the guidelines.
Refer to the table below for explanations.

Restore Guidelines 
when loading job

If this function is activated, the created guide lines are saved with the job,

Setup Opens a window for guide line creation.

Grid

Guidelines
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Saving Presets
 

  

  

￮ Click on the Setup button. 
The dialogue on the right opens. Refer to the table 
below for explanations.

Horizontal, Vertical There is a tab for horizontal and vertical guide lines.

(1) Entry field for the position of the created guide lines.

Add Clicking this button adds a new guide line to the selected position.

(2) List of all guide lines.

Move to Folder... Clicking this button moves the guide line from field (2) to the position set in 
field (1).

Delete Clicking this button deletes the guideline selected in field (2).

Reset Clicking this button deletes all horizontal and vertical guidelines Horizontal and 
vertical guide lines are not deleted simultaneously.

Show Guidelines If this function is enabled, guidelines are shown.

Snap To Guidelines If this function is enabled, objects that are moved get aligned with the guidelines.

Load Preset Saved Presets can be loaded for the active job ( ➜ page 116, Loading Preset).

Save Preset All guide lines can be saved and used for other. ( ➜ page 115, Saving Presets).

Organise Presets Saved Presets can be renamed or deleted ( ➜ page 116, Organizing Presets).

Clear All All guidelines contained in the job will be deleted.

Presets are all guidelines contained in one job. A Preset can be used for new jobs and is saved 
as explained below. If the preset shall only be saved with the current job, the option Restore 
Guidelines when loading job can be used. ( ➜ page 114, Modify Guidelines).

￮ Select Tools >Grid/Guidelines... option from the menu.
￮ Click on the Setup button.
￮ Click on Save Preset button.

The dialogue on the right opens.

OK After choosing a name for the preset, it can be saved.

Skip This button enables saving the preset without specifying a name. The internal 
preset will be overwritten this way.
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Loading Preset
 

 

Organizing Presets
Saved presets can be renamed and saved as follows:

 

Saved presets can be loaded as into the active job as described below. Potentially existing 
guidelines are overwritten.

￮ Select Tools >Grid/Guidelines... option from the menu.
￮ Click on the Setup button.
￮ Click on the Load Preset button The dialogue on the 

right opens.
￮ Select the desired preset and click OK.

￮ Select Tools >Grid/Guidelines... option 
from the menu.

￮ Click on the Setup button.
￮ Click on the Organise Preset button.

The dialogue on the right opens.
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5.5 Appliance of the Zoom tools
There are three different kinds of tools available for changing the zoom factor of the work-
space.

Zoom in
    

Zoom out
    

Full view
    

￮ Click on the Zoom In button. 
￮ Drag, with pressed mouse button, along the area you want to zoom in.

￮ Click on the Zoom out button.
The workspace will be displayed smaller.

￮ To further scaling down the display, click the Zoom out button again.

￮ Click the Full View button
The workspace will be extended as far as possible to enable a full view.

Zoom in

Zoom out

Full view
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6 TEMPLATES
 

Creating Templates  
   

Converting a Template into a Marking Object
 

A template is an object that cannot be modified and is not marked either. It is created from a 
marking object. In order to edit a template, it must be reconverted into a marking object first. 
Only one template can be created in each job.

Examples of using a template would include aligning objects or placing additional information 
on the workspace that should not to be marked.

￮ Add the object you want to use as a template to your job.
￮ Edit the object as required if applicable.  
￮ Select the object.
￮ Select the Objects >Convert to Template option from the menu.

The object converted into a template appears in the Job Manager (Current Job window) as 
a Template and disappears from the Object Manager.

￮ Right click on Template in Current Job window and select Convert to Object.

Convert To 
Template 
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7 USING AUTOMATION OBJECTS
 

  

Note:
Automation objects are only processed if the job was started with the Starting execution func-
tion. Automation objects are ignored with jobs that are startet with Quickmark or Run from 
Hardware.

Automation objects allow communication with external applications and control devices. They 
are used to automate processing and the internal weldMARK™ processes. weldMARK™ pro-
vides the following automation objects:

Wait for External Signal This object checks whether a signal 
is present at a selected I/O port. The 
marking process is not continued 
until the signal is present.

➜ page 120, "Wait for External 
Signal" Automation Object

Set I/O port This object sets one or more 
I/O ports to "Low" or "High".

➜ page 122, "Set I/O port" 
Automation Object

Insert Time Delay This object inserts a time delay 
between the marking of two objects. 
The marking process of the second 
object starts when the specified time 
span has been elapsed.

➜ page 124, "Insert Time Delay" 
Automation Object

Show Messagebox This object displays a message 
window on the screen during the 
marking process. The process is 
stopped until the user closes the 
message box.

➜ page 125, "Show Messagebox" 
Automation Object

XY Table This object controls an optional XY 
Table that is connected.

➜ page 127, "XY Table" Automation 
Object

Rotary axis This object controls an optional 
rotary indexer that is connected.

➜ page 129, "Rotary Indexer" 
Automation Object

Custom Axis This object controls an optional 
custom axis that is connected.

➜ page 131, "Custom Axis" 
Automation Object

Serial Output This object allows commands and 
scripts to be sent to the laser 
appliance via the serial interface of 
the pc.

➜ page 133, Automation Object 
"Serial Output"
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7.1 "Wait for External Signal" Automation Object
 

Defaults for "Wait for External Signal"
 

  

 

Adding a "Wait for External Signal" Object
  

Properties
Properties, which are classified as follows, are assigned to the automation object:

 

This object checks whether a signal is present at a selected I/O port. The marking process is 
not continued until the signal is present.

This section describes how the defaults for "Wait for External Signal" type automation objects 
can be called up and changed. The defaults apply to all new automation objects of this type.

￮ Select Objects >Defaults... option from the 
menu.

￮ Select the object type Wait for External Signal.
The dialogue on the right opens. Refer to the 
table below for explanations.

Use I/O port Preset of the I/O port to be monitored.

Message A text can be entered for a message displayed during the waiting time.

￮ Select Objects >Add >Automation... option from 
the menu.
The dialogue on the right opens.

￮ Select Wait for External Signal automation object 
type.

￮ Click on Add button.
The automation object is added to the Object 
Manager.

Settings Various settings can be made for the object. ➜ page 121, Settings

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be assigned to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control
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Settings
    

 

￮ In Object Manager, right click on a Wait for 
External Signal type automation object.

￮ Select Properties....
The dialogue on the right opens. Refer to 
the table below for explanations.

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

I/O port You can select the input port to be checked.

Message A text can be entered for a message to be displayed during the waiting 
time.
The text entered in Defaults... is used if you do not enter anything here.

(1) The marking process is not started until the start signal is terminated.

(2) The marking process is started as soon as the start signal is assented.

Test Clicking on this button reads the I/O port and displays the result.

Wait for External 
Signal
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7.2 "Set I/O port" Automation Object
This object sets the status of one or more I/O ports to "Low" or "High".

Defaults for "Set I/O port"
 

  

  

Adding a "Set I/O port" Object
  

Properties
Properties, which are classified as follows, are assigned to the automation object:

  

This section describes how the defaults for "Set I/O port" type automation objects can be called 
up and changed. The defaults apply to all new automation objects of this type.

￮ Select Objects >Defaults... option from the 
menu.

￮ Select object type Set I/O port.
The dialogue on the right opens. Refer to the 
table below for explanations.

I/O card action The required behaviour of the port can be selected.

Use I/O port You can select the input port to be set.

￮ Select Objects >Add >Automation... option from 
the menu.
The dialogue on the right opens.

￮ Select automation object type Set I/O port.
￮ Click on Add button.

The automation object is added to the Object Man-
ager.

Settings Various settings can be made for the object. ➜ page 123, Settings

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be assigned to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control
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Settings
     

 

￮ In Object Manager, right click on a 
Set I/O port type automation object.

￮ Select Properties....
The dialogue on the right opens. Refer to 
the table below for explanations.

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

I/O card action The following actions can be selected:

Set Port TRUE The selected port is set to TRUE.

Set Port FALSE The selected port is set to FALSE.

Pulse Port The selected port is alternately set to FALSE - 
TRUE - FALSE. The time span for the TRUE 
status can be adjusted.
Note that the value for the time span is only an 
approximate value.

SET WORD The word consists of 6 bits, corresponding to the 
six output ports OUT1 to OUT6 of optional 
I/O-Card. Each bit sets one output port.

Use I/O port The output port to be set either on optional I/O-Card or SP-ICE Pro card
( ➜ page 136, Marking Object Profile).

Word value This input box is only active if the Set WORD action has been selected. 
A value between 0 and 63 (decimal) can be set. It complies with a binary 
value of 6 bit.

Test Clicking on this button sets the I/O port in line with the settings made for 
testing purposes. The setted port and the current status are displayed.

Set I/O port
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7.3 "Insert Time Delay" Automation Object
 

Adding an "Insert Time Delay" Object
 

Properties
Properties, which are classified as follows, are assigned to the automation object:

  

Settings
    

 

This object inserts a time delay between the marking of two objects. The marking process of 
the second object starts when the specified time span has been elapsed.

￮ Select Objects >Add >Automation... option from 
the menu.
The dialogue on the right opens.

￮ Select automation object type Insert Time Delay.
￮ Click on Add button.

The automation object is added to the Object Man-
ager.

Settings Various settings can be made for the object. ➜ page 124, Settings

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be assigned to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control

￮ In Object Manager, right click on an Insert 
Time Delay type automation object.

￮ Select Properties....
The dialogue on the right opens. Refer to 
the table below for explanations.

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

Delay Time delay in milliseconds.

Test Clicking on this button displays a window specifying the current time delay 
setting. 

Insert Time Delay
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7.4 "Show Messagebox" Automation Object
 

Defaults for "Show Messagebox"
 

  

  

Adding a "Show Messagebox" Object
 

Properties
Properties, which are classified as follows, are assigned to the automation object: 

 

This object displays a message window on the screen during the marking process. The pro-
cess is stopped until the user closes the message box.

This section describes how the defaults for "Show Messagebox" type automation objects can 
be called up and changed. The defaults apply to all new automation objects of this type.

￮ Select Objects >Defaults... option from the 
menu.

￮ Select object type Show Messagebox. 
The dialogue on the right opens. Refer to the 
table below for explanations.

Title The text that will appear in the title bar of the message window.

Message The text that will appear as the message.

￮ Select Objects >Add >Automation... option from 
the menu.
The dialogue on the right opens.

￮ Select automation object type Show Messagebox.
￮ Click on Add button.

The automation object is added to the Object 
Manager.

Settings Various settings can be made for the object. ➜ page 126, Settings

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be assigned to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control
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Settings
    

 

￮ In Object Manager, right click on an Show 
Messagebox type automation object.

￮ Select Properties....
The dialogue on the right opens. Refer to 
the table below for explanations.

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

Title The text for the message box title bar can be adjusted.

Message The text that will be displayed in the message box can be entered in this 
field.

Test Clicking on this button displays the message box for test purposes.

Show 
Messagebox
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7.5 "XY Table" Automation Object
 

Adding an "XY Table" Automation Object
  

Properties
Properties, which are classified as follows, are assigned to the automation object:

  

This object controls an optional XY Table that is connected. A motor controller card is neces-
sary to control the table ( ➜ page 228, Operating Stepper Motors).

￮ Select Objects >Add >Automation... option from 
the menu.
The dialogue on the right opens.
Select automation object type XY Table.

￮ Click on Add button.
The automation object is added to the Object Man-
ager.

Settings Various settings can be made for the object. ➜ page 128, Settings

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be assigned to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control
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Settings
    

  

￮ In Object Manager, right click on an 
XY Table type automation object.

￮ Select Settings.
The dialogue on the right opens. Refer to 
the table below for explanations.

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

Current These fields show the current position of the motor axes.

Move to These fields can be used to enter an absolute target position, i.e. the 
position to which you want the table to move.
These fields are only available if the Absolute setting has been selected in 
the Moves are list box.

Move These fields can be used to enter a relative target position, i.e. the distance 
you want the table to move.
These fields are only available if the Relative setting has been selected in 
the Moves are list box.

Display Speed These fields can be used to enter the speed [steps per second] at which 
you want the table to move.

Units mm The distances can be entered in millimeters, 
inches or motor steps.Inches

Steps

Moves are The mode for specifying the moves must be selected:

Physical The table moves to the position specified in Move 
to field.

Relative The table moves by the values specified under 
Move.

Go Clicking on this button performs the specified table movement.

HOME Clicking on this button moves the table to its home position.

STOP Stops the movement of the XY table.

XY Table
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7.6 "Rotary Indexer" Automation Object
 

Adding a "Rotary Indexer" Automation Object
 

Properties
Properties, which are classified as follows, are assigned to the automation object:

 

This object controls an optional rotary indexer that is connected. A motor controller card is nec-
essary for this ( ➜ page 228, Operating Stepper Motors).

￮ Select Objects >Add >Automation... option from 
the menu.
The dialogue on the right opens.

￮ Select automation object type Rotary Indexer.
￮ Click on Add button.

The automation object is added to the Object Man-
ager.

Settings Various settings can be made for the object. ➜ page 130, Settings

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be assigned to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control
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Settings
  

  

￮ Right click on the object you want to 
change in the Object Manager.

￮ Select Properties....
The dialogue on the right opens. Refer to 
the table below for explanations.

Name The object name entered in this text box is used to list the object in the Object 
Manager. The name also appears in all information and dialogue boxes related to 
the object.

String position This field shows the current position of the rotary indexer.

Move to In this field, you can enter an absolute angle position, i.e. the position you want the 
rotary indexer to rotate to. 
This field is only available if the Absolute setting has been selected in the Moves are 
list box.

Move In this field, you can enter a relative target position, i.e. the angle you want the axis 
to rotate by.
This field is only available if the Relative setting has been selected in the Moves are 
list box.

Display Speed This field can be used to enter the speed [steps per second] at which you want the 
axis to rotate.

Radius This field is used to enter the radius of the rotating component. The radius is 
required to calculate the target position or distance, if they are entered in inches or 
millimeters.

Rotate every … 
process cycles

This field is used to enter the number of process cycles to be performed before the 
axis is rotated. 

Units mm The distances can be entered in millimeters, inches, 
degrees or motor steps. The length specifications 
[mm] and [inch] refer to the range.

Inches

Degrees

Steps

Moves are The mode for specifying the moves must be selected:

Physical The axis is rotated to the position specified under 
Move to.

Relative The axis is rotated by the value specified under 
Move.

Go Clicking on this button performs the specified rotary movement.

HOME Clicking on this button rotates the rotary indexer to its home position.

STOP Stops the movement of the rotary indexer.
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7.7 "Custom Axis" Automation Object
 

Adding a "Custom Axis (Z axis)" Object
  

Properties
Properties, which are classified as follows, are assigned to the automation object:

  

This object controls an optional custom axis that is connected. The custom axis can be 
configured for linear or rotating applications either. A motor controller card is necessary for this 
( ➜ page 228, Operating Stepper Motors).

￮ Select Objects >Add >Automation... option from 
the menu.
The dialogue on the right opens.

￮ Select automation object type Custom Axis.
￮ Click on Add button.

The automation object is added to the Object Man-
ager.

Settings Various settings can be made for the object. ➜ page 132, Settings

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be assigned to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control
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Settings
  

  

￮ Right click on the object you want to 
change in the Object Manager.

￮ Select Properties....
The dialogue on the right opens. Refer to 
the table below for explanations.

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

Current This field shows the current position of the custom axis.

Move to In this field, you can enter an absolute target position, i.e. the position you 
want the custom axis to move to. 
This field is only available if the Absolute setting has been selected in the 
Moves are list box.

Move In this field, you can enter a relative target position, i.e. the distance you 
want the custom axis to move by.
This field is only available if the Relative setting has been selected in the 
Moves are list box.

Display Speed These fields can be used to enter the speed [steps per second] at which 
you want the custom axis to move.

Units mm The distances can be entered in millimeters, 
inches or motor steps.Inches

Steps

Moves are The mode for specifying the moves must be selected:

Physical The axis is moved to the position specified under 
Move to.

Relative The axis is moved by the value specified under 
Move.

Go Clicking on this button performs the specified movement of the custom 
axis.

HOME Clicking on this button rotates the custom axis to its home position.

STOP Stops the movement of the custom axis.
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7.8 Automation Object "Serial Output"
 

Adding a "Serial Output" object
  

Properties
Properties, which are classified as follows, are assigned to the automation object:

  

This object allows commands and scripts to be sent to the laser appliance via the serial inter-
face of the pc. If the installed component has to be initialized, the automation object must be 
put before all marking objects. If commands have to be executed before marking of a certain 
object, the Serial Output object must be put before that object.

The automation object sends the commands to the installed component as a text string. With 
each command a request to verify can be sent and a time-out value can be set. The confirma-
tion has to be acknowledged with the text string "ACK". If this text string is not received within a 
certain time, the current job will be cancelled.

￮ Select Objects >Add >Automation... option from 
the menu.
The dialogue on the right opens.

￮ Select automation object type Serial Output.
￮ Click on Add button.

The automation object is added to the Object 
Manager.

Settings Various settings can be made for the object. ➜ page 132, Settings

Notes A note can be assigned to the object. ➜ page 27, Notes

Ext. Control A marking condition can be assigned to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped.

➜ page 28, External Control
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Settings
  

  

￮ Right click on the object you want to 
change in the Object Manager.

￮ Select Properties....
The dialogue on the right opens. Refer to 
the table below for explanations.

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialogue 
boxes related to the object.

Data A command can be entered in this field. 

Delay A Time-Out value can be entered here, if the command line hasn't been 
received and no confirmation of the component has been sent meanwhile.

Command Delimiter The text string that defines the end of a command can be entered here.

End of Line The text string that defines the end of a command line can be entered here.

I/O port In this field the COM-Port and its' command parameters can be defined.

Data Bits

Stop Bits

Baud Rate

Parity



Using Profiles Chapter 8

MN013 / v3.5.0 RAYLASE weldMARK 3 135

8 USING PROFILES 
 

This chapter provides an overview of how to manage the profiles in weldMARK™.

Every marking object is assigned a profile, which specifies the parameters for the laser mark-
ing. When you create a new object, the default profile is applied automatically. This profile can 
be adapted to your individual requirements, however, changes only affect the objects that are 
created subsequently.

If different laser settings are required (e.g. for marking different materials), any number of pro-
files can be created with different parameters. This is done using the Profile Manager.

The Profile Manager lists all available profiles. The profiles can be organized and applied to 
marking objects. In addition, the parameters of a selected profile can be applied to the default 
profile.

A profile can also be transferred from one marking object to another.

Profiles contained in the profile manager are available for all jobs.
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8.1 Marking Object Profile
 

  

  

The profile applied to the marking object determines the settings for laser processing, such as 
the power, frequency etc. These parameters are summarized on the Profile tab and can be 
changed as follows:

￮ Right click on the marking object whose 
profile you want to change and then select 
Properties....

￮ Select the Profile tab.
The dialogue on the right opens. Refer to 
the table below for explanations.

Marking profile

Mode Mark once The outlines of the object are marked once according 
to the parameters of Pen 1. These parameters are 
shown in the lower part of the screen and are 
modifiable.

Mark multiple times The object is marked the number of times entered in 
the Passes field according to the parameters of 
Pen 1.

2 pass Cut & Clean The object is marked two, three or four times, and 
different laser parameters can be set for each pass 
(according to Pen 1 up to 4). The settings can be 
called up using the passes that are available for 
selection in the Current Profile list box.

3 pass Cut & Clean

4 pass Cut & Clean 

Current Profile If variable passes are selected in the Mode list box, this field can be used to call 
up the parameters for each individual pass (Pen 1 up to 4).

Passes The Passes field is only available if Mark multiple times mode has been 
selected. In this field, you can enter the required number of passes for the 
marking object. The object is marked according to the parameters of Pen 1 the 
number of times during execution of the job even if it is only listed once in the 
object list.

Use pens This field is only available if an imported object with layers is selected. In this 
case marking parameters can be defined for each pen after activating this 
function. For visualization, the elements are displayed with the defined pen 
colour. Elements on layers which are not selected for marking (tab CAD) are not 
shown. A maximum of eight pens can be used.
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Laser power % power This field can be used to specify the laser power. The laser power can be 
entered in percent or watts depending on the settings in the laser configuration 
file.

Frequency This field can be used to set the frequency of the laser modulation signal. In 
association with YAG lasers, this is also referred to as the Q-Switch frequency. 
The setting area is also defined in the laser config file

Marking Speed This field can be used to specify the speed at which the laser beam moves over 
the object during processing. If a speed is entered in mm/s or inch/s the actual 
speed can vary depending on the calibration factor bit/mm in the selected laser 
config file.

Pulse width This field can be used to set the pulse width of the laser modulation signal. The 
maximum possible pulse width is determined by the frequency entered.
This parameter is not available when using CO2 lasers.

Simmer current Only available if SPI-laser config file selected.

State select 
(Wave form)

Pulsed vs. CW

LaserOn delay The adjacent parameters are described in detail in the application manual and/or 
in the "Commands and Functions" manual. The laser delays are entered with 
positive values only. Negative values have to be defined in the laser config file if 
required.

LaserOff delay

Mark delay

Poly delay

Spot offset Defines the offset in which the laser is positioned to the outline.

Jump speed The adjacent parameters are described in detail in the application manual and/or 
in the "Commands and Functions" manual.Jump delay

Var. jump length

Var. jump delay

Wobble frequency Defines the wobble excursion per second.

Wobble width Defines the wobble excursion width

Zero power after 
mark

If this function is activated, the laser power is set to zero after marking via Job 
>Run. This function is not available for all laser types. 

Mark on dark material Only for bitmap objects

If this function is activated, the bitmap object will be marked inverted. This allows 
you to mark a pseudo-positive image on dark materials.
In the weldMARK™ window the bitmap object is not displayed inverted.

Z position Via Z position the focal plane of the Scan Head can be adapted to the object to 
be marked. This field only is displayed if a 3-Axis subsystem with 
FOCUSSHIFTER/AXIALSCAN with 3D Head config file is set as Scan Head. 
The value for the z position can be positive or negative. It is limited to the 
maximum values of the used 3-Axis subsystem.

Delta-Z/Z-Maximum Delta-Z defines the change in the Z-Postion per pass. If Z-Maximum is entered, 
the software devides the Z-Range in the number of passes.

Marking profile
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Hints for optimizing delay times

Digital Head Tuning The available tunings for digital heads are LN (Low noise), RA (Rapid) and 
ST (Step). Switching between head tunings requires a delay. Beside a global delay 
defined in the Scan Head configuration file, this delay can be adjusted for each 
markable object. Switch Delay is a positive value in the range of 0 to 1500 ms.

Switching the tuning During marking, if the requested tuning for a certain 
object is different from the last used tuning, then a 
command for switching the tuning and a delay will be 
inserted in the list of commands, before sending 
marking parameters and vectors. This applies to all 
marking modes Run, Quick Mark and Run from 
Hardware.
In case of Vector Graphic objects, or objects which 
have the possibility to use the Use Pens flag it is 
possible to switch the tuning even within the same 
object. In this case, each Pen can have different 
Tuning settings and it will be switched when the 
Set_Pen command is encountered in the object.

Enable Skywriting ➜ page 139, Skywriting

The following filling parameters are only required, if the filling is marked with differing 
parameters to the outline.

Filling Profiles

Mode Mark once The filling of the object is marked once according to 
the current profile. You cannot select other modes for 
filling.

Current Profile With this field the parameters for up to 8 pens can be accessed. For the filling of 
the object, the selected pen is used.

Passes The number of passes cannot be changed for the filling. The count of passes is 
defined in the marking profile.

Use pens This field is not available here.

The delay times must be adapted to the application and the jump and marking speeds entered. 
Unoptimized delay times will lead to poor processing results and can increase the processing 
time. The length of the laser on and off delays has no influence on the processing time. Please 
refer to the Application-Manual for further information.

Set the delay times as described below:

￮ Optimize the laser on and off delay. 
We recommend setting a high value for the jump and mark delays.

￮ Optimize the delay times for controlling the galvanometer scanners, e. g. the jump, mark 
and poly delay. 

￮ All profile settings are effected by the option copy/paste profile. See ➜ page 143, Applying 
Profiles.

Marking profile
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8.2 Skywriting
 

Example:  

8.2.1 Skywriting Parameter
 

In the following, the object-specific way is shown:
  

  

At the reversal point of a polyline, the higher retention time of the laser causes a strengthened 
marking effect. By using the "Skywriting" function, the laser radiation switches off at the rever-
sal point. Afterwards, the scanner mirrors change direction. The laser radiation switches on 
again, when the laser arrives at the reversal point. In this way, a constant marking speed can 
be achieved.

Except of bitmap objects, this function is available for all object types.

Skywriting disabled Skywriting enabled

The adjustment of the Skywriting parameters is located in the Profile settings. They can be 
edited either individually in the object properties for each object or for each profile based on the 
Profile Manager.

￮ Right click on the desired marking object 
and select Properties....

￮ Select the Profile tab.
￮ Check Enable Skywriting.

The red bordered area is displayed. Refer 
to the table below for explanations.

Enable Skywriting If this function is disabled, all values are set to zero.

Start Length The fore-run time of the switched off laser before arriving the 
reversal point.

Stop Length The backlash time of the switched off laser after arriving the 
reversal point.

Break Angle If a value is entered into this field, Skywriting function is 
triggered only if the angle between two vectors is less than or 
equal to this value.



Chapter 8 Using Profiles

140 RAYLASE weldMARK 3 MN013 / v3.5.0

8.2.2 Preview
 

  

 

  

  

The vector jumps, which are added for the Skywriting, can be made visible as described in the 
following:

￮ Right click on the marking object.
￮ Select Properties.... 
￮ Select Settings tab.
￮ Check Display vector jumps.

The dialogue on the right opens. Refer to 
the table below for explanations.

As an example, a preview of a rectangle with displayed vector jumps is shown. To improve the 
visibility, high values for the start and the stop length were entered. 

(1) Stop Length

(2) Start Length
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8.3 Showing and hiding the Profile Manager
   

8.4 Creating and managing Profiles
 

8.4.1 Creating Profiles
  

 

￮ Select View >Profile Manager option from the menu.
The adjacent window is shown or hidden.

In the Profile Manager, you can view, delete and modify existing object profiles and apply them 
to objects. You can also add new object profiles and organize all object profiles hierarchically.

￮ Right click on the object whose profile 
you want to add to the Profile Man-
ager.

￮ Select Add to Profile Manager.
The dialogue on the right opens. Refer 
to the table below for explanations.

Parameters are added to 
the profile manager

If this function is enabled, the profile parameters for the selected object are 
applied to the default profile in the Profile Manager.
The default profile is automatically applied to all new marking objects. 

Name The name of the profile is entered in this field.

Create in << This window shows the Profile Managers folder structure. The new profile is 
saved in the selected folder. If no folder is selected, the profile is saved on 
the highest level in the Profile Managers structure.

OK Clicking on this button saves the profile in the Profile Manager. 

Show/Hide 
Profile Manager
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8.4.2 Organizing Profiles
You can structure individual profiles in folders or rename, move and delete them.

 

 

￮ Select Profiles >Organize Profiles... option 
from the menu.
The dialogue on the right opens. Refer to 
the table below for explanations.

￮ Click on OK to add the changed structure 
to the Profile Manager.

Create Folder Clicking on this button prompts the user to enter a folder name. Thereupon 
a new profile folder is created with the name entered.

Rename Clicking on this button allows you to rename a selected folder or a profile.

Move Clicking on this button allows moving a selected profile to a different folder.

Delete selection Clicking on this button deletes either a selected folder and the profiles it 
contains or a selected individual folder.
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8.5 Applying Profiles
 

8.5.1 Applying a Profile from the Profile Manager to an Object
 

8.5.2 Applying a Profile from the Profile Manager to multiple Objects
  

8.5.3 Applying a Profile from the Profile Manager to all Objects
  

8.5.4 Copying a Profile from Object to Object

8.5.5 Saving Object Profile to the Profile Manager
  

The profiles saved in the Profile Manager can be applied to selected marking objects. Further-
more the profile of a marking object can be applied to other marking objects.

￮ Select the object to which you want to apply a profile.
￮ Right click on the profile you want to apply in the Profile Man-

ager.
￮ Select Apply to Object.

￮ Select the objects to which you want to apply a profile.
￮ Right click on the profile you want to apply in the Profile Man-

ager.
￮ Select Apply to Group.

￮ Right click on the profile you want to apply in the Profile Man-
ager.

￮ Select Apply to All.

￮ Right click on the object whose profile you want to copy.
￮ Select Copy Profile.
￮ Select the objects to which you want to copy the object.
￮ Right click on the selected objects.
￮ Select Paste Profile.

￮ Right click on the object whose profile you want to save.
￮ Select Add to Profile Manager.
￮ Continue as described at ( ➜ page 141, Creating Profiles).
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8.6 Modifying a saved Profile
  

  

Note:
Any other object specific parameters can be defined in the relative object defaults.

￮ In the Profile Manager, right click on the pro-
file whose parameters you want to modify.

￮ Select Modify.
The dialogue on the right opens. Explana-
tions can be found in the section below:
➜ page 136, Marking Object Profile
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8.7 The Default Profile
 

8.7.1 Assigning the Parameters of a Marking Object to the Default Profile
  

8.7.2 Applying the Parameters of a different Profile to the Default Profile
 

8.7.3 Modifying the Default Profile
 

The default profile is listed under the name Default in the Profile Manager. It cannot be deleted 
or moved to another folder. When you create a new marking object, the default profile is 
applied automatically. Markings performed to calibrate the marking field are performed using 
the settings in the test pattern profile.

The default profile can be adapted to your individual requirements; however, changes only 
affect the objects that are created subsequently.

￮ Right click on the marking object 
whose profile parameters you want to 
apply to the default profile.

￮ Select Add to Profile Manager.
The dialogue on the right opens.

￮ Activate the checkmark Apply this 
profile when creating a new object.

￮ Confirm the operation with OK.

￮ In the Profile Manager, right click on the profile whose parame-
ters you want to apply to the default profile.

￮ Select Copy to Default.

The default profile can be modified in the same way as any other profile ( ➜ page 144, 
Modifying a saved Profile).
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8.8 Importing and exporting profiles

8.8.1 Importing profiles
 

  

Only profile folders can be imported, not individual profiles. The profile folder to be imported 
must be located in a folder with the name "Profiles".

￮ Select the File >Import and Export 
Profiles... option from the menu.
The dialogue on the right opens.

￮ Select Import Profiles from a folder and 
click on Next.
The following window is opened.

￮ Click on Browse... and then select the 
folder named "Profiles", which contains the 
profiles to be imported.

￮ Select option Replace duplicates with 
Profiles imported if you want to replace 
profiles with the same name or Do not 
import duplicates if you do not want.

￮ Click on Next to import the profiles.
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8.8.2 Exporting profiles
 

  

Only profile folders can be exported, not individual profiles. The profile folder to be exported is 
saved in a folder with the name "Profiles" (weldMARK™ creates this folder if there is no folder 
with this name at the specified location).

￮ Select the File >Import and Export 
Profiles... option from the menu. 
The dialogue on the right opens.

￮ Select Export profiles to a folder and click 
on Next.
The following window is opened.

￮ Click on Browse button.
￮ Select the location in which you want to 

save the "Profiles" folder
or
select the location of an existing "Profiles" 
folder in which you want to save the profile 
folder to be exported.

￮ Click on the Next button.
The following window is opened.

￮ Select the profile folder to be exported.
￮ Click on Next to export the profiles.
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9 MARKING APPLICATIONS WITH DIFFERENT 
FOCUS POSITIONS

9.1 Z-Range of 3-Axis System
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9.2 2.5D Marking
2.5D marking describes different options for marking on a flat surface, with focus position 
varying either from object to object or, in case of marking in multiple passes, the focus position 
changes from pass to pass.

Latter option can be used for a kind of deep engraving. In this case the outline path does not 
vary in depth and the outline should be filled.

2.5D marking requires either a FOCUSSHIFTER or AXIALSCAN RAYLASES Scan Head. 
Theses Scan Heads allow focus position to be changed during marking. 

2.5D Marking 2.5D Engraving

￭ To define the Z position of a individual 
Layout see ➜ page 136, Marking Object 
Profile

￭ When 2.5D marking is used to cut or 
engrave into material, the Object settings 
Mark multiple times with number of 
Passes and either a Delta Z per each 
pass or the total engraving depth 
Z maximum should be defined.
See ➜ page 136, Marking Object Profile.

Note: 
If an AXIALSCAN Scan Head is used, the Job Flag Mark 3D / 2.5D must be set 
( ➜ page 166, Job Settings - "Page Setup"). 
The Zero Plane (Z=0), can be adjusted and moved further down, allowing positive Z positions, 
by changing the Working Distance offset (2.5D only) ( ➜ page 148, Z-Range of 3-Axis System)
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9.3 Deep processing applications

9.3.1 Deep Cutting

The deep cutting function is currently for objects, imported as a Vector Graphic only. It is rec-
ommended to activate the option Optimize for filling in most cases. This way vectors will be 
reassessed and optimized for the filling process and deep cutting. Imported objects can be 
reworked in the Vector Graphic Designer if necessary ( ➜ page 32, Vector Graphic Designer 
(VGD)).

The Deep cutting is designed for RAYLASE FOCUSSHIFTER and AXIALSCAN only. In case 
of AXIALSCAN the Mark 3D / 2.5D setting must be set. If no focus change is needed, every 
type of RAYLASE Scan Head can be used. 

Deep cutting is realized with definable amount of parallel cuts. The cut lines can be defined to 
either cut within or outside the object. 
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9.3.2 Cutting Parameters
 

  

  

  

The cutting parameters can be defined as follows:

￮ Right click on the vector object whose 
profile you want to change and then select 
Properties.

￮ Select the Cutting tab.
The dialogue on the right opens. Refer to 
the table below for explanations.

Use advance cutting 
option

Activates the advanced cutting options.

Passes Displays how often the object has to be cut repeatedly. Definition is done in the 
profile tab ( ➜ page 136, Marking Object Profile).

Reduce linearly This option linearly reduces the offset between lines after each cycle 
automatically. Only the first row of the parameters for deep cutting is considered. 
All other parameter rows are ignored.

parameters for deep 
cutting

Deep cutting can be done with an amount of passes which are executed one 
after another. Different parameters can be set, depending on the progress 
(percentage portion of one pass compared to the total amount of passes. The 
table parameters for deep cutting shows all parameters.

% of Passes Defines from which percentage portion of the total amount of passes the 
corresponding row should be used.

Pen The pen that is used for the marking can be chosen in this field.

Number of Lines Defines the amount of parallel lines, which are offset to the outline. 
If Offset=0 no parallel lines will be marked.

Offset - Left Defines the offset of the parallel lines to the outline.
For closed objects Offset - Left stands for lines inside and Offset - Right for lines 
outside the the object. For open objects the lines are marked on the marking 
direction either left or right.

Offset - Right

Add A new parameter row is added in the parameters for deep cutting table.

Remove Deletes the currently selected parameter row.

Offset
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9.4 Trepanning

9.4.1 Trepanning Parameters
 

  

   

  

Different methods of drilling can be applied depending on the application.

Methods for fine drilling are specified here: ➜ page 84, Drill objects. 

The Trepanning function allows for drillings that are much wider than the diameter of the laser 
itself. Polygon objects with any number of sides can be used as a base. The following example 
shows a polygon with six sides and a polygon with a multitude of sides. 

For Trepanning the polygon object is marked spirally. This is accomplished with a constant 
shift of the Z axis after every marked side of the polygon.

The Trepanning parameters can be set as follows:

￭ Option only available Head config file for 
type FOCUSSHIFTER is loaded.

￮ Right click on the vector object whose pro-
file you want to change and then select 
Properties.

￮ Select Settings tab.
The dialogue on the right opens.

To use a polygon object for Trepanning, the 
option Helix (Z-step after each side) has to be 
selected.

Further setting options for the polygon object 
are found in the "Polygon Object" section 
( ➜ page 51, Settings for a Polygon Object).

￮ Select the Profile tab.
The dialogue on the right opens. Further 
Information for Trepanning are found in the 
following table. All remaining parameters 
are explained in the section "Profile" ➜ 
page 135, Using Profiles.
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9.5 Deep Engraving (Slicing)

9.5.1 Import STL file

9.5.2 Positioning of a STL object

9.5.3 STL-Object settings
 

   

To use the Deep Engraving function, a STL file is required to define the surface. This 3D sur-
face will be engraved in layers. The steps of the Z axis can be predefined as layer size or as 
layer amount, for automatic calculation. The layer size depends on the texture of the marking 
material and the cutting ability of the laser system.

STL-files can be imported just like Vector Graphics ( ➜ page 29, Importing Vector Graphic 
Files). Currently only binary data formats are supported. ASCII files will be supported in the 
future. IGES- and STEP-Files will not be supported. All non-supporting options are displayed 
gray in the dialogue. If there is no unit specified in the file, it can be specified during the import.

The positioning and scaling of the STL object can be done with the "Dimensions" tool 
( ➜ page 102, The "Dimensions" Toolbox).

For each STL object special settings can be applied, which can be opened and changed at will 
as described below:

￮ Right click on the STL object.
￮ Select Properties....

Select Settings tab.
The dialogue on the right opens. 
Refer to the table below for explanations.

S017

Name The object name entered in this text box is used to list the object in the Object 
Manager. The name also appears in all information and dialogue boxes related to 
the object.

Mark Style Defines the marking Style.

Mark outline If this function is enabled, the object contour is marked. This function is enabled by 
default.

Display vector 
jumps

If this function is enabled, the vector jumps between the individual part of the object 
are displayed on screen. This function is disabled by default.

Show STL Layers If no option is activated, the STL object will be used as XY projection of the 3D 
object. The option Show STL Layers shows the edges of all defined layers. If the 
option Show STL Triangulation is activated, the STL object is displayed with the 
resulting triangles.

Show STL 
Triangulation
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9.5.4 Adjust Layer parameters of a STL object
 

  

 

Before a STL object can be engraved, the following parameters have to be defined:

￮ Right click on the STL object.
￮ Select Properties....

Select Slice tab.
The dialogue on the right opens. 
Refer to the table below for explanations.

S017

Slice Count The amount of layers for engraving the STL object can be set in this field. The 
resulting Slice Thickness is calculated and set automatically.

Slice Thickness The size of layers for engraving the STL object can be set in this field. The resulting 
Slice Thickness is calculated and set automatically. The minimal possible slice 
thickness equals one bit. Conversion of [bit] to [mm] depends on the 
calibration factor of the Correction File.

Top-Bottom 
Marking

Layers will be marked from top to bottom if this function is activated.

Slice Settings Layers can be defined with different settings. They are commonly combined in 
groups, due to great amounts of single layers. The distribution in layer groups is 
made percent-aged. This way the last 50% of the layers can be engraved with 
different parameters to the previous layers.

Slice Position Defines when a parameter row will be used. Definition is resulting from the chosen 
percentage value and selected layers.

Pen Defines which pen is used for which parameter. If no pen is defined in the STL file, 
pen1 will be used as default.

Filling Angle 
increment

In each marking pass, when moving to the next slice, the fill angle is incremented by 
the value specified in this field.

Type of Marking Change Focus
￭ The Z position is achieved through a change of the focus position with a 

FOCUSSHIFTER Scan Heads. 
￭ AXIALSCAN can achieve the focus change with the Z-Offset by using 

3D-vectors.
Object height and layer size have to be within the technical data of the 
corresponding Scan Head.

Auxiliary Axis (currently not implemented)

Port Definition (currently not implemented)
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9.5.5 Saving options of a STL file in the job file 
 

  

 

A STL object can be saved and referenced within the job. If the file is referenced, the currently 
updated file will be loaded upon opening the job. Files saved within the job will save their file 
path, but not their contents. With the file path, the object can be manually loaded anew. These 
options can be set as follows: 

￮ Right click on the STL object.
￮ Select Properties....

Select Source tab.
The dialogue on the right opens. 
Refer to the table below for explanations.

S017

Character string rules No settings necessary.

String position Shows the path where the file is saved.

Save within job If this function is activated the file will be saved within the job. Changes on the 
original file will not be loaded automatically.
If this function is deactivated, the newest file will be loaded automatically upon 
opening the job. The job can only be accessed from another computer, it the 
original file can be found in the saved file path. Loading times can increase due 
to the loading the STL file.
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9.6 3D Applications
 

9.6.1 Preparation for 3D Applications

Selecting a Scan Head for 3D Surfaces 
  

3D application needs dynamic focus adaptation to any 3D shaped surface. There are several 
possibilities for 3D marking in weldMARK™. A proper Scan Head (AXIALSCAN or 
FOCUSSHIFTER) and a special 3D Dongle has to be available for the 3D marking.
Particular 3D Correction Files can be created, objects can be imported as 3D vectors and 2D 
objects can be projected onto a 3D surface.

To use the different 3D functions in weldMARK™ a 3D surface marking compatible Scan Head 
(either 3D Scan Head config file of AXIALSCAN or 3rd Axis for FOCUSSHIFTER) has to be 
used and the proper Correction File has to be selected. 

￮ Select System >Preferences option from 
the menu. 

￮ Select Hardware tab. 
￮ Select the Scan Head you want to 

change from the directory tree.
￮ Click on Change button.
￮ Read and acknowledge the security 

query that appears.
The dialogue on the right opens.

￮ Select a 3D Application compatible 
Scan Head and confirm your choice with 
OK (➜ page 193, Select/change Type of 
Scan Head).
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Add a new Correction  
￮ Select System >Preferences option 

from the menu. 
￮ Select Hardware tab. 
￮ In directory tree, click on the Correc-

tion File of the deflection unit you want 
to optimize. 

￮ Click on Change button. 
￮ Read and acknowledge the security 

query that appears.
￮ Click on Install New File button.

The dialogue on the right opens.
￮ Click on Next button.

The following window is opened.

￮ Select the correspondent configura-
tion file by clicking the Search button.
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9.6.2 Importing 3D Vector-Objects

9.6.3 Projection of a 2D-layout onto a 3D-surface

This method allows to directly import vector-objects (3Ddxf) as a three-dimensional Layout. 
Alternatively the 3D-coordinates can be provided in a separate txt-File. Import Details ➜ page 
29, Importing and editing Vector Graphic Objects.

After the import, the Z position (height position) of the layout has to be set, so the complete lay-
out is underneath the zero level, meaning all Z-coordinates have to be negative. This is done in 
the Vector Graphic Designer. ➜ page 32, Vector Graphic Designer (VGD) (Tab: Surface > 
Offset Object)

To finally mark the object in 3D the Mark3D option has to be activated ➜ page 166, Job Set-
tings - "Page Setup".

This method allows to project 2D-layouts onto a 3D-surface within the Vector Graphic Designer 
➜ page 32, Vector Graphic Designer (VGD).

a) Tab: Surface > Import Surface File (=STL File with 3D surface information)

b) The Surface will be displayed as a purple out-bounding rectangle. Positioning the surface to 
the layout: Tab: Surface > OffsetX + OffsetY

c) Tab: Surface > Surface to Object

d) Afterwards, the Z position (height position) of the layout has to be set, so the complete 
layout has to be within the available Z-Range. (Tab: OffsetZ > Offset Object)

To finally mark the object in 3D the Mark3D option has to be activated ➜ page 166, Job Set-
tings - "Page Setup".

Note: 
9.4.2 and 9.4.3 can be used with either AXIALSCAN or FOCUSSHIFTER. 
Both methods process 3D-Vectors.
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9.6.4 Marking with modified Correction Files

Correction File Generator

The following table shows all functions of the Correction File generator:

This type of marking depends on Correction Files, that can be changed to adjust to different 
surfaces. Standard Correction Files for 3-Axis Scan Heads, as well as Correction Files for 3D 
surface markings can be created with the Correction File generator.

Note: This method works only with AXIALSCAN.

To start the Correction File generator choose the menu point Tools >Generate Correction. This 
option is only available for type "Professional 3D" dongles. The following window is opened.

  

New File Creating a new Correction File

Open File Opening a Correction File

Save File Saving a Correction File

Save File As Choose path & save Correction File

Scanning Parameters Values from the Scan Head Correction File are entered here. They can be 
changed at will. The values have to be verified with the function Validate 
Values and Calculate a new.

Z-Offset If the standard Correction File uses an integrated offset this value must be 
entered here to be integrated into the new 3D Correction File.

Z inverted Do not use this option!

Open STL-File Loads the STL-File which contains the 3D surface information.

Offset X, Offset Y, Offset Z Position of the surface of STL-File relative to coordinate origin of the 
working field. By default software puts origin of surface to origin of working 
field and position surface in Z axis so that peak of surface equals Z=0.

Working Distance Offset Value must be positive! It defines the Z value of all the area besides the 
surface of STL-File. Only values between Z=0 and Z=Working Distance 
Offset are valid for the calculation of 3D Correction File.

Validate Values Checks if the Scanning Parameters function is valid and shows an error 
message if the values are not in the area of validity.

Calculate Calculates changed values after the function Validate Values has been 
checked for it's validity. After successful evaluation the options Save File 
and Save File As become available.
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Creating Correction Files for different surfaces

Create a Correction File for spheres

weldMARK™ enable the creation of Correction Files which can be adjusted to different sur-
faces. Standard options for surfaces are sphere, cylinder and inclined plane. By assigning a 
STL-File other surfaces can be defined. To create a Correction File based on a STL File follow 
the steps below: 

￮ In the Correction File generator click on Open 
STL file.

￮ Choose the corresponding STL-File and -con-
firm with Open. 

￮ The STL-File data is displayed in the right are 
of the Correction File generator, as shown in 
the adjacent picture.

￮ If necessary, change the correspondent val-
ues (especially offset), confirm them with Vali-
date Values, and click on the button Calculate. 

￮ Save new 3D Correction File with either Save 
File or Save File As.

￮ Click on the tab Sphere in the Correction File 
generator.

￮ The area pictured adjacent opens. 
￮ Enter values to define sphere surface, confirm 

them with Validate Values, and click on the 
button Calculate. 

￮ Save new 3D Correction File with either Save 
File or Save File As.
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Create a Correction File for cylinders

Create a Correction File for inclined planes

￮ Click on the tab Cylinder in the Correction File 
generator.

￮ The area pictured adjacent opens. Depending 
on the chosen direction of X and Y the view is 
altered.

￮ Enter values to define cylinder surface, con-
firm them with Validate Values, and click on 
the button Calculate. 

￮ Save new 3D Correction File with either Save 
File or Save File As.

￮ Click on the tab Inclined Plane in the Correc-
tion File generator.

￮ The area pictured adjacent opens.
￮ To specify the inclined plane, the points A, B 

and C are defining a restricting triangle in a 
X/Y/Z coordinate system.

￮ Change the correspondent values, confirm 
them with Validate Values, and click on the 
button Calculate. 

￮ Save new 3D Correction File with either Save 
File or Save File As.
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10 EXECUTING MARKING OBJECTS (QUICKMARK)
 

  

    

  

This chapter provides an overview of the QuickMark function. The function enables you to exe-
cute the marking process without automation objects or additional functions (e.g. serialization). 
It is also possible to mark only certain marking objects of a job.

Before using QuickMark function, you should familiarize with the job settings (➜ page 165, Job 
Settings, run Job).

Warning 
The laser beam can cause severe injury to the eyes and the skin. Make sure that 
there are no reflective objects in the beam path before starting the QuickMark 
function and turning on the laser. Note that laser beams can be reflected even 
by apparently matt objects.

All persons in the room must wear appropriate laser protection goggles, or the 
marking area must be covered completely. Follow the local safety regulations, 
which can be obtained from the person responsible for laser safety.

￮ Select the objects you want to mark.
It you want to process all objects, you 
do not need to select an object.

￮ Select Job >QuickMark... option from 
the menu.
The dialogue on the right opens. 
Refer to the table below for explana-
tions.

Repeat Process Enabling this function means that once the marking process has been 
started it will be repeated until you stop it by clicking the Stop button.

All Executes all marking objects of the current job.

Selected Executes only the selected marking objects.

Stop Clicking on this button stops the marking process immediately. Alternatively, 
you can do this by pressing the ESC key.

(1) When laser marking has been completed, the attended marking time is 
displayed in the status bar.

QuickMark
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10.1 Preview Mark
 

  

  

Arrow keys are normally reserved for navigating through forms and moving from one control to 
another, similarly as with TAB button.

In order to avoid uncertainties and not limit the standard functionality of these keys a new 
‘Move / Resize / Rotate’ field is introduced.

When ‘Move / Resize / Rotate’ field is selected then arrow keys are used for adjusting the size, 
position and rotation of the object. Otherwise, they are used the same as on any other form.

Use TAB key to move between the controls.

The PreviewMark can be used if the laser system is fitted with a visible pointer and you have 
selected a laser driver file that supports a visible pointer in the system preferences. Note that 
the visible pointer needs to be calibrated in order to represent the position of the marking laser 
correctly ( ➜ page 222, Calibrating the Visible Pointer). 

The PreviewMark shows the shape of a marking object or a group of marking object using the 
visible pointer. Thereby the marking laser remains off. The shape can be used to position and 
scale marking objects exactly on the target Furthermore, the workspace can be rotated.

￮ Select the marking objects whose 
marking position and size you want 
to set.

￮ Select Job >PreviewMark...option 
from the menu.
The dialogue on the right opens. 
Refer to the table below for expla-
nations.

Object position These buttons can be used to change the marking position of the selected 
objects.

Object size These buttons can be used to change the size of the selected objects.

Rotate Job Workspace These buttons can be used to rotate the workspace of the selected job. 
Thereby the arrow key down rotates clockwise (negative angle) and the 
arrow key up rotates anti-clockwise (positive angle).
The angle can be entered into the field below the arrow keys, too. Please 
mind the algebraic sign. 
The rotation of the job workspace can also be set via Job Settings >Page 
Setup.

Settings Selection of preview shape and ruler to adjust speed of the visible pointer.

Shape Preview 
Profile

The object is shown as a rectangle whose shape symbolizes the object 
dimensions. This option should not be used for 2.5D or 3D objects.

Display 
Speed

The visible pointer represents the object outline, even if only the filling is 
selected for marking. It is used for the preview of the Bitmap linked with the 
PLT outline. Only available with a SPICE control card.
Use this option for 2.5D or 3D objects.

Preview Profile The speed of the outline preview is set by profile. 

Display Speed This slider can be used to adjust the speed of the preview rectangle.

Apply Clicking on this button applies the settings made.
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10.2 Object Preview

The following options are available:

Object is an option available for some 
marking objects in

Object > Properties > Settings tab.

This option can be used to preview an 
object for a defined time before it gets 
marked.

The object preview will start when it is 
the objects turn to be processed.

(In case the object is used for preview 
reason only, uncheck the Mark outline 
flag.). 

Wait for signal to de-assert 
before triggering

Object gets outline-previewed until a signal de-asserts. 
New drop down for selection of signal-input pin becomes available.

Trigger Immediately while 
signal is asserted 
(level sensitive)

Object gets outline-previewed until a signal low sensitive signal assert. 
New drop down for selection of signal-input pin becomes available.

Wait until timeout Object gets outline-previewed until a defined time elapses.

Wait for number of passed Object gets outline-previewed until a defined number of passes is carried 
out.
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11 JOB SETTINGS, RUN JOB
 

11.1 The Job Manager
 

Showing and hiding the Job Manager
    

11.2 Editing the Job Settings
 

  

This chapter provides an overview about the sequence of a job, which settings you can make 
and how you run a job. 

When executing a job, all objects contained in the job are executed, including the automation 
objects and all additional functions of the objects, e.g. serialization.

The Job Manager gives an overview about the job settings. The settings can only be changed 
at the All editing functions access level. In Operator interface only mode, the Job Manager is 
displayed only, while it does not appear at all in Touchscreen interface mode.

￮ Select View >Job Manager option from the menu.
The adjacent window is shown or hidden.

The job settings enable you to adapt the execution of a job to specific requirements. The job 
settings are saved within the job. They are divided up as follows:

Page Setup Allows you to set the format and size of the 
workspace.

➜ page 166, Job Settings - 
"Page Setup"

Repeat Process Execution of the job can be repeated several 
times or continuously.

➜ page 167, Job Settings 
"Repeat Process"

Step & Repeat The Step & Repeat function allows a job content 
to be marked several times. The duplication is 
based on adjustable row and column 
arrangements.

➜ page 168, Job settings - 
"Step & Repeat"

Job Initialize When starting the job, external components can 
be automatically prepared for the marking 
process.

➜ page 169, Job Settings "Job 
Initialize"

External Start The start of job execution can be controlled by 
external signals.

➜ page 170, Job Settings - 
"External Start"

Stop Mark Sets the behaviour of the laser if an external 
stop signal appears.

➜ page 172, Job Settings - 
"Stop Mark"

Scan head Offsets ➜ page 174, Job Settings - "Scan head Offsets"

Notes A note can be added to the job. ➜ page 174, Job Settings - 
"Notes"

Interlocks Execution of the job can be interrupted by 
external interlock loops. This option is only 
available, if the Interlock card is installed.

➜ page 175, Job Settings - 
"Interlocks"

Show/Hide Job 
Manager
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11.2.1 Job Settings - "Page Setup"
  

  

￮ Select Job >Settings... option from 
the menu 
or
double click on Page Setup option 
in the Job Manager.
The dialogue on the right opens. 
Refer to the table below for 
explanations.

Format You can select a rectangular or circular workspace.

Width The size of the workspace can be adjusted. The maximum size of the 
workspace is determined by the size of the deflection unit's operating field.Height

Rotate Into this field, a rotation angle to rotate the job workspace can be entered. 
A negative value rotates the workspace clockwise, a positive one anti-
clockwise.
These settings can also be modified via Job >Preview Mark....

Switch to job Correction 
File

If this option is selected, the path for the currently selected Correction File 
is saved and the Correction File will be loaded automatically upon the next 
opening of the job.

Switch to job laser file If this option is selected, the path to the currently selected file will be saved 
and is automatically loaded upon the next opening of the job.

Mark 3D / 2.5D If this option is selected, vectors with 3-dimensional coordinates can be 
processed if a suitable Scan Head is connected.

Working Distance Offset 
(2.5D only)

Possibility to offset Zero Plane when doing 2.5D marking with AXIALSCAN. 
Value is always positive. 
See ➜ page 148, Z-Range of 3-Axis System

Apply Hardware defaults Clicking on this button sets the workspace to its maximum possible size 
(size of deflection unit's operating field).

Save Settings as Default Clicking on this button allows to save the current settings as defaults for the 
Page Setup.
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11.2.2 Job Settings "Repeat Process"
 

  

￮ Select Job >Settings... option from 
the menu.

￮ Select Repeat Process tab.
The dialogue on the right opens. 
Refer to the table below for expla-
nations.

FOR OPERATION FROM 
THE CONSOLE

If you select a manual repeat function, each new execution of the job must 
be started manually.

(1) The job is executed as many times you wish.

(2) The frequency of execution is limited by the specified number of 
Cycles.

AUTOMATION ONLY If you select an automatic repeat function, execution of the job is 
automatically restarted after completion of a cycle.

(3) The job is automatically and continuously repeated until it is 
cancelled manually.

(4) Execution of the job is repeated automatically for the specified 
number of Cycles. The limitation is not considered with the Run form 
Hardware mode.

(5) Only selectable if a SP-ICE Control Card is used

If this function is enabled, the settings are also used in Run from Hardware 
mode.
This option is available only if Run from Hardware mode is enabled (➜ page 
178, Run from Hardware).

Save Settings as Default Clicking on this button uses the current settings as defaults for Repeat 
Process.
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11.2.3 Job settings - "Step & Repeat"
 

  

  

The Step & Repeat function allows marking of objects several times on the workspace. Repro-
duction takes place in an adjustable row and column arrangement and applies to all marking 
objects in the job.

￮ Select Job >Settings... option from 
the menu.

￮ Select Step & Repeat tab.
The dialogue on the right opens. 
Refer to the table below for expla-
nations.

Use Step & 
Repeat

If this function is enabled, the following parameters can be set:

Layer If a standard I/O card is installed, up to four 
matrix layouts can be created. Each layout can 
have a different matrix arrangement. The 
layout can be selected using the ports on the 
standard I/O card.

Columns Count The matrix is made up of columns and rows. 
You can specify the number of rows and 
columns and the distance between them 
(pitch). The offset is based on the bottom-left 
corner.

Pitch

Rows Count

Pitch

Pattern offset X axis The position of the matrix on the marker can be 
adjusted using these offset values.Y axis

Preview Clicking on this button updates the preview 
window.

Reset All Clicking on this button resets all settings to the 
defaults.

Save Settings as Default Clicking on this button uses the current settings 
as defaults for Step & Repeat.
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11.2.4 Job Settings "Job Initialize"
 

  

  

When the job is started, the RS232 port can be used to output a string for initialization of exter-
nal components. In addition, you can specify a port to report execution of the job to external 
components. As initialization is job specific, the components can be initialized in a different way 
for each loaded job.

￮ Select Job >Settings... option from 
the menu.

￮ Select Job Initialize tab.
The dialogue on the right opens. 
Refer to the table below for expla-
nations.

Don't send a script No script is sent to initialize external components.

Send script using RS-232 
COM port

A script is sent to initialize external components using an RS232 port.

I/O port Select an RS232 port for sending the script.

Data Bits These parameters are used to adapt the RS232 port to 
the parameters of the script recipient.Stop Bits

Baud Rate

Parity

Script file Selection of the script file to be sent using the RS232 
port.Browse...

I/O card action A port of the I/O-card can be selected. An action that should be executed 
when the job is started must be assigned to this port.Use I/O port

Save Settings as Default Clicking on this button uses the current settings as defaults for 
Initialization.
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11.2.5 Job Settings - "External Start"
 

Wait for an external Start Signal
  

  

The "External Start" function allows the control of job execution by an external signal. This tab 
is available only if the standard I/O card is installed and/or SP-ICE/RLC series control cards 
are installed.

￮ Select Job >Settings... option from 
the menu.

￮ Select External Start tab.
￮ Enable Wait for an external start 

signal.
The dialogue on the right opens. 
Refer to the table below for expla-
nations.

(1) If this check box is selected, the External Start function is deactivated.

(2) If this check box is selected, the External Start function is activated and the following setting 
options are available:

Use I/O port This choice box can be used to choose the port for the start signal. The 
options vary depending on the cards installed.

Message A text can be entered for a message displayed during the waiting time.

Timeout A time limit can be placed on the waiting time for the external start signal. 
When this time has elapsed, an error message will be output. If the value 
"0" is entered, the waiting time is unlimited.

(3) The job is not started until the start signal is terminated.

(4) The job is started as soon as the start signal is assented.

(5) If this function is enabled, the selected parameters are also used in 
Run from Hardware mode.
This option is available only if Run from Hardware mode is enabled 
( ➜ page 178, Run from Hardware).

Save Settings as 
Default

Clicking on this button uses the current settings as defaults for 
External Start.
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Mark after n Encoder Counts
  

  

￮ Select Job >Settings... option from 
the menu.

￮ Select External Start tab.
￮ Enable Mark after n encoder 

counts.
The dialogue on the right opens. 
Refer to the table below for expla-
nations.

This option is only useful in combina-
tion with MOTF-Function.

(1) If this option is enabled, the mark starts after an adjustable number of encoder counts.

First mark Number of encoder counts before the marking operation starts.

Subsequent 
marks

Number of encoder counts before starting the following marks.

(2) In some cases, caused by installation, the sensor signal arrives with the 
wrong moving sense. Though the direction of the encoder is reversed.

Save Settings as 
Default

Clicking on this button uses the current settings as defaults for 
External Start.
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11.2.6 Job Settings - "Stop Mark"
This function sets the reaction at an external stop signal or if the Scan Head reports an error.

  

  

￮ Select Job >Settings... option from 
the menu.

￮ Select Stop Mark tab.
The dialogue on the right opens. 
Refer to the table below for expla-
nations.

(1) Mark stops immediately after the external stop signal has appeared.
This function is enabled by default.

(2) The marking laser switches off immediately after the external stop signal has appeared. 
Subsequently, the job runs to end.

(3) If this function is enabled the job is repeated without waiting for a confirmation by the user.

(4) Function to stop marking automatically if any error is read back from deflection unit. 
Additionally, the external signal on the controller card "Remote_Execute_2" is set. This signal 
is reset when the error message is confirmed. (Also applies to all non-digital Scan Heads)
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Displaying Scan Head error status
  

Run mode
Scan Head error status is displayed in the the 
same way as if the Stop Mark was detected, 
i.e. in the Cycle time field.

On top of this, depending on the error status, 
an Error message is also shown:

￭ If an invalid status was read from the Scan 
Head

￭ If a valid status was read, but some of the 
error signals were set

Confirming the OK button will reset the error, 
enabling further marking.

If the error still persists, it will be reported 
again.

Quick mark mode

In case of Quick mark mode:

￭ Marking will be stopped
￭ Error will not be displayed on the Quick 

mark form. 

￭ An error message will be shown in the 
same way as for Run mode.

Confirming the OK button will reset the error, 
enabling further marking.

If the error still persists, it will be reported 
again.
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11.2.7 Job Settings - "Scan head Offsets"
 

  

  

11.2.8 Job Settings - "Notes"
 

 

  

If several Scan Heads are used, it can be necessary to balance the offset. For this purpose, 
individual settings can be specified for every Scan Head.

￮ Select Job >Settings... option from 
the menu.

￮ Select Scan head Offsetst tab.
The dialogue on the right opens. 
Refer to the table below for expla-
nations.

Scan head 1 X offset It is possible to set the X and Y offset for each single Scan Head.

Y offset

Scan head 2 X offset

Y offset

Scan head 3 X offset

Y offset

Scan head 4 X offset

Y offset

A note can be added to the job. weldMARK™ can be set up in such a way that the job note is 
displayed automatically when loading the job and has to be acknowledged by the user 
( ➜ page 197, Settings for the Job File).

￮ Select Job >Settings... option from 
the menu.

￮ Select Notes tab.
The dialogue on the right opens. 
Refer to the table below for 
explanations.

Save Settings as Default Clicking on this button uses the text entered as default for Notes.
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11.2.9 Job Settings - "Interlocks"
 

  

  

Use the settings on the Interlocks tab to set when and how weldMARK™ will report interlock 
events. The Interlocks tab is only available if an interlock card is installed.

￮ Select Job >Settings option and 
then select the Interlocks tab.
The dialogue on the right 
opens. Refer to the table below 
for explanations.

Always check interlock 
before...

If this check box is enabled, the interlock status is checked before starting 
each job. If there is an interlock event, the job is not started and an error 
message is output.

Always check interlock 
while...

If this check box is enabled, the interlock status is checked while the 
system is waiting for the external start signal and, if necessary, an error 
message is output. If the check box is not enabled, an interlock event does 
not result in an error message. However the start signal is ignored and the 
READY signal on the standard I/O card changes to BUSY.

Save Settings as Default Clicking on this button uses the current settings as defaults for Interlocks.
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11.3 Executing a Job
 

  

Starting a Job at "All editing functions" Access Level
  

Starting a Job at "Operator interface only" Access Level
  

Starting a Job at "Touch screen interface" Access Level
￮ If necessary, open the required job.
￮ Touch the Run button.

The job is executed.

Stopping the Job
￮ Touch the Stop button or press the ESC key.

In order to be able to execute a job, the Object Manager must contain at least one object that 
can be marked. The procedure for starting a job differs depending on the access level and is 
described below.

Warning 
The laser beam can cause severe injury to the eyes and the skin. Make sure that 
there are no reflective objects in the beam path before starting a job and turning 
on the laser. Note that laser beams can be reflected even by apparently matt 
objects. All persons in the room must wear appropriate laser protection goggles, 
or the marking area must be covered completely. Follow the local safety regula-
tions, which can be obtained from the person responsible for laser safety.

￮ If necessary, open the required job.
￮ Select Job >Run option from the menu.

The dialogue on the right opens.
￮ Click on Go button.

The job is executed.

Stopping the Job
Click on Stop button or press the ESC key.
Upon restarting the execution of the job 
begins with the first object

￮ If necessary, open the required job.
￮ Select Job >Runoption from the menu. 

The dialogue on the right opens.
￮ Click on Go button.

The job is executed.

Stopping the Job

￮ Click on Stop button or press the ESC key.
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11.3.1 Displays during a Job
While the job is executed, the following values are displayed in the status bar:

  

11.3.2 Events during a Job
 

Entering a String
  

  

Parameters for TextMerge
 

  

Cycle count How often the entire job has been executed so far.

Object count Number of objects processed so far.

Cycle time Required time for the execution of the current job (current cycle).

Current object The object that is currently being processed.

Depending on the objects included in the job and their properties, the program may ask the 
user for input during execution.

If an object has been created for which the user needs to 
enter a string, The dialogue on the right opens.

Refer to the table below for explanations.

(1) Input box for the string with which the object is marked. Execution of the job 
is continued as soon as the entry is confirmed by clicking the OK button.OK

Skip Clicking on this button skips the input prompt. The object is marked with the 
last string used.

If an object has been created that uses a Text-
Merge function, The dialogue on the right opens. 
Refer to the table below for explanations.

The beginning of the file The first string for the object is taken from the first line of the merge file.

At line number The first string for the object is taken from the specified line of the merge 
file. The available line numbers are specified in brackets.

The previous bookmark 
location

The first string is taken from the line in the merge file that is bookmarked. 
This option is not available until at least one line has been read from the 
merge file.
The bookmark is inserted each time a line from the merge file is read and 
specifies the next line to be read. This allows serialization to continue 
seamlessly after restarting the job.
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11.3.3 Run from Hardware
  

Activating "Run from Hardware" Mode
 

weldMARK™ allows loading all marking objects of a job to the control card's memory. Thus, the 
job can be executed very quick and potential delays caused by the operating system are 
avoided. With this function, no automation objects run and no signals for "External Control" 
processed.

To allow direct operation, the following conditions must be met:

￭ A SP-ICE control card must be used.
￭ The Run from Hardware mode must be activated.

￮ Select System > Preferences option 
from the menu.

￮ Select Hardware tab.
The dialogue on the right opens.

￮ Select the control card for which 
you want to activate the mode.

￮ Click on Configure… button.
The following window is opened.

￮ Select Display tab.
￮ Activate the check box Job > Run 

from Hardware.
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Running a Job from Hardware
  

  

  

Note:

The job is saved only in virtual memory of the card and gets deleted once weldMARK-Software 
is closed.

Warning 
The laser beam can cause severe injury to the eyes and the skin. Make sure that 
there are no reflective objects in the beam path before starting a job and turning 
on the laser. Note that laser beams can be reflected even by apparently matt 
objects. All persons in the room must wear appropriate laser protection goggles, 
or the marking area must be covered completely. Follow the local safety regula-
tions, which can be obtained from the person responsible for laser safety.

￮ Select Job >Run from Hardware option 
from the menu.
The dialogue on the right opens. Refer to 
the table below for explanations.

Download Clicking on this button sends the marking objects to the control card.

Go This button becomes active only when all marking objects have been 
saved on the control card. Clicking on the button starts the execution 
of the job.

(1) If this function is enabled, the job is not executed until the hardware 
signal is present ( ➜ page 170, Job Settings - "External Start"). 

(2) If this function is enabled, the job is executed repeatedly (➜ page 167, 
Job Settings "Repeat Process").

Stop Clicking on this button or pressing the ESC key stops execution 
immediately.



Chapter 11 Job Settings, run Job

180 RAYLASE weldMARK 3 MN013 / v3.5.0

11.3.4 Stand Alone Operation
 

Enabling "Save to stand alone control card" Mode
  

Saving a Job to a Stand Alone Control Card
  

weldMARK™ allows loading all objects of a job to the memory of a stand alone control card. 
Then the job can be executed from the control card itself without connection to weldMARK™. 
This function is available only with SP-ICE control cards.

In order to be able to save a job on a stand alone control card, the following conditions must be 
met:

￭ The appropriate hardware must be available
￭ The function must be enabled.
￭ The job may not contain more objects that can be saved on the controller.

￮ Select System >Preferences option 
from the menu.

￮ Select Hardware tab.
￮ Select the control card for which 

you want to activate the mode.
￮ Click on Configure… button.

The dialogue on the right opens.
￮ Select Display tab.
￮ Select File >Save Job to Embedded 

Controller.

￮ Select File >Save Job to Embedded 
Controller.
The dialogue on the right opens.

￮ Select a script file from the list.
￮ Click on the Send button to start saving. 
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11.4 The "Mark on the Fly" Option
 

Activating the "Mark on the Fly" Option
  

  

The "Mark on the Fly" option allows marking of moving target. The vectors of a job are cor-
rected corresponding to the respective velocity. 

In order to use the "Mark on the Fly" option, the following conditions must be met:

￭ A suitable SP-ICE control card and a suitable encoder signal need to be available. Please 
note the hints in the respective manual to the SP-ICE control card.

￭ The "Mark on the Fly" option must be enabled.

￮ Select System >Preferences option 
from the menu.

￮ Select Hardware tab.
￮ Select the control card for which 

you want to activate the mode.
￮ Click on Configure… button.
￮ Select Mark on the Fly tab.

The dialogue on the right opens. 
Refer to the table below for expla-
nations.

Enable Mark on 
the Fly

If this function is enabled, the following settings are available

Scale factor This field can be used to enter the number of pulses emitted by the 
encoder per adjusted measuring unit.

String orientation Rough setting for the direction of 
movement of the marked target. "0" 
corresponds to a horizontal movement 
from the left to the right. The orientation 
which is entered under System 
>Preferences, tab Marker is not 
considered. Rotation is clockwise.

If the marker is moving 
at a 20° angle relative to 
the X axis, enter "0" in 
the Orientation field and 
"20" in the Angle field.

Angle Precise setting for the direction of 
movement of the marked target. You 
can enter an angle between -45° and 
+45°.
Rotation is clockwise, relative to the 
X axis configured under System 
>Preferences... on the Marker tab.

Scan head lag 
time

Scan Head 1: 
Master

The Tracking Error Compensation can not be 
used, if the inertia of the Galvos is affecting 
the Mark-on-the-Fly-function. Therefore, it is 
possible to set individual lag times for each 
single Scan Head. The Tracking Error 
Compensation is activated automatically as 
soon as one value bigger than zero is entered 
into one of the fields. 

Scan Head 2: 
Slave

Scan Head 3: 
Slave

Scan Head 4: 
Slave
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11.4.1 Mark-on-the-Fly extended (2. channel)

11.5 Master-Slave-Operating
 

Activating "Master-Slave" Option
  

  

Activate edge following control If this function is activated, the following settings are available tor the 
second MOTF-channel.

Scale factor This field can be used to enter the number of pulses emitted by the 
encoder per adjusted measuring unit.

String orientation Rough setting for the direction of movement of the marked target. "0" 
corresponds to a horizontal movement from the left to the right. The 
orientation entered under System > Preferences, tab register Marker 
will not be considered. Rotation is clockwise.

Angle Precise setting for the direction of movement of the marked target. 
You can enter an angle between -45° and +45°.
Rotation is clockwise, relative to the X axis configured under System 
>Preferences, on the Marker tab.

In a PC one SP-ICE control card can be defined as master card and up to three cards as slave 
cards. 

In master/slave operation weldMARK™ sends the job file to the master control card. This mas-
ter card controls the connected Scan Head and the laser by means of the job file – like in nor-
mal operation the SP-ICE control card. Additionally, the SP-ICE card in master mode controls 
the slave control cards. Thus the content of a job file can be sent to up to four SP-ICE control 
cards (one master and three slave cards). Slave cards can control Scan Heads but not the 
laser itself.

Information in detail about hardware configuration can be found in the hardware manual of the 
SP-ICE control card.

￮ Select System >Preferences option 
from the menu.

￮ Select Hardware tab.
￮ Select the control card for which you 

want to activate the mode.
￮ Click on Configure… button.
￮ Select Master-Slave tab.

The dialogue on the right opens. 
Refer to the table below for explana-
tions.

Scan Head 1 (Master) This check box shows, that Scan Head "1" is defined as 
master.

Scan head 2 Via these check boxes the built-in SP-ICE control cards can 
be activated for slave operation.Scan head 3

Scan head 4

An individual Correction File can be loaded for each slave card in the system configuration
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11.6 Importing a Job
 

  

 

11.7 Printing a Job
The content of the workspace can be printed as described below:

  

  

A job is a collection of objects and settings. The settings determine the actions of the Scan 
Head, the laser and the additional equipment. If a job is imported into another job, the objects 
and settings it contains will be added to the currently opened job.

￮ Select File >Import Job.
The dialogue on the right 
opens.
Refer to the table below 
for explanations.

S019

Look in Allows you to choose the folder in which the job to be imported is saved.

File name This text box displays the name of the currently selected file.

File type The file type of a job file must be selected. Only files of the selected type will be displayed.
The following file formats can be imported:

weldMARK 3 Job (*.wmj) A weldMARK™ job file format. weldMARK™ jobs can be 
imported 1.x, 2.x and 3.x

TruvVewJob (*.job) A file type developed by the GSI Group Inc. which is bas on 
the Truview® software package.

WinLase Job (*.wlj) A WinLase job file format.

further ➜ page 29, Importing Vector Graphic Files
➜ page 41, Importing Bitmap Files

￮ Select File >Print Setup... option from the 
menu and do the required settings (printer, 
paper size, orientation). 

￮ Select File > Print  option from the menu. 
The dialogue on the right opens. Refer to the 
table below for explanations.

As in job (1:1) The objects are printed at actual size.

Fit to page The printout is scaled to use the full size of the page.

Center image on page The printout is scaled as specified and centered on the page.

Width The width and height of the printout can be changed 
as a percentage of the actual size.Height 

Maintain aspect 
ratio 

If this function is enabled, the aspect ratio of the 
printout remains unchanged even if the print size is 
changed (no distortion).

Show field size boundary If this function is enabled, the boundaries of the workspace are printed as a 
frame.

Setup or Print buttons Clicking on these buttons calls up the printer settings.

Import job
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12 SYSTEM TOOLS
weldMARK™ provides the following system tools:

  

12.1 Configure Tools
 

  

  

Adding / editing Tools
  

  

Configure Tools The tool menu can be extended with 
options for calling up external 
programs.

➜ page 184, Configure Tools

Configure I/O Cards... This tool allows you to configure 
newly installed I/O cards.

➜ page 185, Configure I/O Cards

Laser Diagnostics Tool This tool allows you to check the 
positioning and power of the marking 
laser.

➜ page 186, Laser Diagnostics Tool

I/O Card diagnostics ➜ page 187, "I/O Card Diagnostics" 
Tool

The weldMARK™ Tools menu can be extended with additional tools (external programs). 
These programs can then be launched from weldMARK™.

￮ Select Tools >Configure Tools... option from the menu.
The dialogue on the right opens. Refer to the table below 
for explanations.

Tools This section of the window lists all programs added.

Add Clicking on this button allows the addition of new tools to the Tools list 
( ➜ page 184, Adding / editing Tools).

Delete Element Clicking on this button removes the selected tool from the list.

Edit Clicking on this button allows you to edit the settings for the tool selected in 
the Tools list ( ➜ page 184, Adding / editing Tools).

 

These buttons can be used to change the position of a program in the list 
(and also in the Tools menu).

￮ Select Tools >Configure Tools... option from 
the menu.

￮ Click on Add button.
The dialogue on the right opens. Refer to 
the table below for explanations.

Title The name of the selected program file is automatically entered in this field 
when the Browse button has been used to select a program. This name 
can be changed as required. The entry in the Title field is used in the Tools 
menu.

Program The location of the selected program file is automatically entered in this 
field when the Browse button has been used to select a program. The path 
to the selected program can also be entered manually.

Parameters This field can be used to enter parameters for calling up the program. Refer 
to the manual of the respective program for details about the available 
parameters.
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12.2 Configure I/O Cards
 

  

  

If a new standard I/O card and/or interlock I/O card (type: CIO-DIO24H card) has been 
installed in the computer, it must be configured using the Configure I/O Cards... tool. 

Configuration must be performed again if a PCI card is removed, added or moved within the 
computer.

Warning
This tool is only necessary when using I/O cards with a PCI slot. Do NOT use this 
tool for ISA I/O cards, otherwise the communication with the ISA card may be lost.

￮ Select Tools >Configure I/O Cards... 
option from the menu.
A warning message relating to 
ISA I/O cards appears.

￮ Read and acknowledge the warning 
message that appears.
The Instacal program is opened with 
the adjacent window.
All installed I/O cards are displayed in 
the list. The cards are now set up for 
use with weldMARK™.

￮ Exit Instacal by selecting File >Exit.
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12.3 Laser Diagnostics Tool
 

 

 

 

The Laser Diagnostics tool can be used to diagnose and, if necessary, adjust the impact point 
and power of the marking laser you are using.

Warning
The laser beam can cause severe injury to the eyes and the skin. Make sure that 
there are no reflective objects in the beam path before starting a job and turning 
on the laser. Note that laser beams can be reflected even by apparently matt 
objects. All persons in the room must wear appropriate laser protection goggles, 
or the marking area must be covered completely. Follow the local safety regula-
tions, which can be obtained from the person responsible for laser safety.

￮ Select Tools >Laser Diagnostics....
The dialogue on the right opens. Refer to 
the table below for explanations.

X: The values in these input boxes determine the position to which the laser 
beam is directed after clicking the Fire button.Y:

Laser power % power This input box determines the laser power.

Frequency This input box determines the frequency of the laser modulation signal.

Pulse width This input box determines the pulse width of the laser modulation signal.

Select Card This selection field allows the user to map the control signals which are 
output to the laser, if more than one control card is installed.

Fire Clicking this button turns the laser on immediately.

Stop Clicking this button turns the laser off immediately.

Save and Exit Clicking this button closes the Laser Diagnostics tool.
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12.4 "I/O Card Diagnostics" Tool
 

Reading Inputs of the Standard I/O Card
The following function is available only if a standard I/O card is installed:

 

 

Testing Outputs on the Standard I/O Card
The following function is available only if a standard I/O card is installed: 

 

  

This tool allows testing the ports of the standard I/O card and the interlock I/O card 
(type: CIO-DIO24H card). The tool is available only if one of these cards is installed.

￮ Select Tools >I/O Card Diagnostics... 
option from the menu. 
A warning message appears.

￮ Read and acknowledge the warning mes-
sage that appears.

￮ Select the Inputs option under Standard 
I/O Card.
The dialogue on the right opens. Refer to 
the table below for explanations.

Function This column lists the names used for the input ports in weldMARK™. 

Pin # This column lists the PIN numbers on the 37-pin connector of the I/O card.

Status This column specifies the current status of the input ports. If the status is 
TRUE, the corresponding port is connected to GND.

￮ Select Tools >I/O Card Diagnostics... 
option from the menu. 
A warning message appears.

￮ Read and acknowledge the warning mes-
sage that appears.

￮ Select the Outputs option under 
Standard I/O Card.
The dialogue on the right opens.

Function This column lists the names used for the output ports in weldMARK™.

Pin # This column lists the PIN numbers on the 37-pin connector of the I/O card.

FALSE Clicking on these buttons allows you to switch the corresponding output to 
the status FALSE or TRUE for testing purposes. If the status is TRUE the 
corresponding input is connected to GND.

TRUE
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Reading Inputs from the Interlock I/O Card
The following function is available only if an interlock I/O card is installed:

  

  

￮ Select Tools >I/O Card Diagnostics... 
option from the menu. 
A warning message appears.

￮ Read and acknowledge the warning mes-
sage that appears.

￮ Select the Inputs option under Interlock 
Card.
The dialogue on the right opens.

Function This column lists the names used for the input ports in weldMARK™.

Pin # This column lists the PIN numbers on the 37-pin connector of the I/O card.

Status This column specifies the current status of the ports. Each interlock port 
can have the status HIGH or LOW. If the status is LOW, the corresponding 
port is connected to GND.
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13 SYSTEM SETTINGS
This chapter provides an overview of the configuration of the weldMARK™ environment:

  

13.1 Preferences
 

 

Preferences... The settings for the weldMARK™ user interface 
can be changed throughout the system.

➜ page 189, Preferences

Properties... The current system properties for Windows and 
all of the configured hardware can be changed.

➜ page 201, System 
Properties Displays

Globals... The laser power, the marking speed and the 
position of the marking objects can be changed 
throughout the system.

➜ page 202, Global Settings

Security Access to weldMARK™ can be controlled using 
access rights and passwords.

➜ page 203, System Security 
Settings

Backup.../ Restore... All system settings used by weldMARK™ can be 
saved in a backup file and respectively loaded 
from a backup file.

➜ page 204, Backing up 
System Settings

The weldMARK™ system preferences are divided into groups and split across several tabs:

Marker ➜ page 190, Settings for Marking Field

Page Setup ➜ page 190, Workspace Settings

Hardware weldMARK™ can be adapted to various 
deflection units, control cards and laser 
systems. 

➜ page 191, Hardware 
Configuration (without Control Card)
➜ page 191, Hardware configuration 
(with control card)

Job Files Job files can be automatically saved and 
loaded. In addition, you can also specify a 
folder in which jobs are saved to be loaded 
when using the  Operator interface only and 
Touchscreen interface access levels.

➜ page 197, Settings for the Job File

Host Interface weldMARK™ can communicate with external 
programs using different protocols and 
parameters.

➜ page 197, Editing the Host 
Interface Settings

Languages The weldMARK™ user interface can be set to 
one of the supported languages.

➜ page 198, Language Settings

LaserSaver After a certain time has elapsed, the laser can 
be automatically blocked and/or the laser 
power reduced.

➜ page 199, Setting the LaserSaver

Beam Home 
position

The scanner mirrors in the deflection unit can 
automatically be moved to a particular 
position at the end of a processing sequence.

➜ page 200, Setting up the Beam 
Home Position

Motor control The parameters for an installed motor control 
card can be adjusted.

➜ page 228, Operating Stepper 
Motors
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13.1.1 Settings for Marking Field 
  

  

13.1.2 Workspace Settings
  

  

￮ Select System >Preferences option 
from the menu.

￮ Select Marker tab.
The dialogue on the right opens. 
Refer to the table below for explana-
tions.

Warn about out of 
bounds objects...

If this function is enabled, a warning is displayed on the screen if one of the 
objects is located outside the marking field.

Enable laser power 
knob on controller

If this function is enabled, the laser power settings specified in the object 
profiles are ignored. The laser power can then be adjusted externally.
This function can only be enabled if it has been released when installing the 
laser driver ( ➜ page 218, Configuring a Laser Driver).

Enable 
autosegmentation

Activates the autosegmentation function.

Break angle Indicates the critical angle between two vectors, from which the 
autosegmentation is used.

Rotation Note the orientation of the marking field, which is represented in the figure next 
to the check boxes.

￮ Select System >Preferences option 
from the menu.

￮ Select Workspace tab.
The dialogue on the right opens. 
Refer to the table below for explana-
tions.

Interface display units Selection box for the unit for the ruler display and for the input dialogues.

Keyboard nudge This field determines how far an object is moved when it is nudged using 
the arrow keys (arrow + CTRL key).

Start a new job on 
application startup

If this function is enabled, a new job opens automatically when 
weldMARK™ is started.
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13.1.3 Hardware Configuration (without Control Card)
 

  

  

13.1.4 Hardware configuration (with control card)
 

  

  

If weldMARK™ does not find a control card when it is started for the first time, the defaults for 
the Correction File and for the laser driver are automatically activated. If you want to create 
jobs without connected hardware, however, it is necessary to adjust the Correction File for the 
deflection unit and the laser that you will use later. This means that weldMARK™ sets the cor-
rect workspace size and releases all options for the selected laser.

￮ Select System >Preferences option 
from the menu.

￮ Select Hardware tab.
The dialogue on the right opens. 
Refer to the table below for explana-
tions.

Lens, Change... ➜ page 196, Select Correction File

Laser, Change... ➜ page 193, Select Laser Driver

If a control card is installed, the currently set laser driver file and the Correction File for the 
deflection unit can be viewed and, if necessary, changed as follows:

￮ Select System >Preferences option 
from the menu.

￮ Select Hardware tab.
The dialogue on the right opens.

￮ Select the driver you want to change 
from the list.
Refer to the table below for explana-
tions.

(1) Control Card Configure... ➜ page 192, Configure Control Card

(2) Laser Driver Configure... ➜ page 218, Configuring a Laser Driver

Change... ➜ page 193, Select Laser Driver

Visible pointer Calibrate ➜ page 222, Calibrating the Visible Pointer

(3) Scan Head Configure... Selectable only with a connected Dongle and after 
selecting a suitable Scan Head.
➜ page 197, Settings for the Job File

Change... ➜ page 193, Select/change Type of Scan Head

(4) Correction File Calibrate ➜ page 205, Calibrating the Marking Field

Change... ➜ page 196, Select Correction File
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Configure Control Card
Only valid for SP-ICE control cards   

  

  

￮ Select System >Preferences option 
from the menu.

￮ Select Hardware tab.
￮ Click on the required control card in 

the hardware list.
￮ Click on Configure… button.
￮ Select Display tab.

The dialogue on the right opens. 
Refer to the table below for expla-
nations.

Display Run from Hardware 
menu items and controls

If this function is enabled, marking objects can be completely saved on 
the control card first and then executed directly from the card.

Display Embedded Controller 
menu items and controls

If this function is enabled, marking objects can be completely saved on a 
control card first and then executed directly from the card without a PC 
connection.

Mark on the Fly ➜ page 181, The "Mark on the Fly" Option

Mark-on-the-Fly - Extended ➜ page 182, Mark-on-the-Fly extended (2. channel)

Master-Slave ➜ page 182, Master-Slave-Operating

Settings Setting of minimum step period. 
￭ 20 µsec for RLC and SP-ICE-1 PCI PRO cards
￭ 60 µsec for SP-ICE cards

Digital Scan Heads Digital Scan Head Monitor settings: 
Enable the information you want to display from the digital Scan Head 
( ➜ page 200, Digital Scan Head Status Monitor Window)
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Select Laser Driver
 

  

  

Select/change Type of Scan Head
  

  

This section describes how to select a laser driver if a control card is connected:

￮ Select System >Preferences option from the 
menu.

￮ Select Hardware tab.
￮ In the hardware list, click on the laser driver file 

you want to change.
￮ Click on Change button.
￮ Read and acknowledge the security query that 

appears.
The dialogue on the right opens. 
Refer to the table below for explanations.

Laser Driver This text box displays the currently selected laser driver file.

Available Laser Drivers This list box displays all available laser driver files.

Install New Laser... Clicking on this button starts the wizard for installing laser driver file that 
is not included in the list.

￮ Select System >Preferences option from the 
menu.

￮ Select Hardware tab.
￮ In the hardware list select the desired Scan 

Head.
￮ Click on Change button.
￮ Read and acknowledge the warning mes-

sage that appears.
The dialogue on the right opens.
Refer to the table below for explanations.

Scan Head Shows the actually selected Scan Head.

Available Scan Head 
Configuration files

Selection list of all Scan Heads for which configuration files are installed.

Standard 2 Axis: All standard 2-Axis Scan Heads.

2 Axis digital: For all digital 2-Axis Scan Heads.

Standard 2 Axis galvo Calibration Sensor: 2-Axis Scan Heads with auto 
calibration.

Standard 3 Axis: All AXIALSCAN Scan Heads without a motor.

3 Axis Motorized LT: All AXIALSCAN Scan Heads with a motor.

3 Axis Digital Scan Head w/ Pointer: Choose for AXIALSCAN Type 
NewGen with integrated Pointer and digital Scan Head. 
Slave Scan Heads with a Pointer are not supported at the moment. Only 
Scan Heads connected to the Master card can be used with a pointer.

3 Axis | aperture | focal length | wave length: For specific type of Scan 
Head with FOCUSSHIFTER and F-Theta Objective.

3D | field size | AXIALSCAN description: For specific type of 
AXIALSCAN and field size, required for 3D / 2.5D marking.

OK Confirm the selection and returns to the hardware configuration.
➜ page 191, Hardware configuration (with control card)
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Examples for Scan Head Configuration Files

Configure 3-Axis Subsystem
Only valid for 3-Axis subsystems with motorised linear translator    

  

  

.

This is an example of a Scan Head 
configuration file with the LTM pointer 
settings.

 

Information whether a head is digital or not is supplied in 
the head configuration.

￮ Select System >Preferences option 
from the menu.

￮ Select Hardware tab.
￮ In the hardware list select the 

desired Scan Head.
￮ Click on Configure… button.

The dialogue on the right opens.
Refer to the table below for 
explanations.

Enable automatic LT 
Adjustment

Enables the control of the linear translator.

Use Motor Controller Allows selecting the motor controller.

Axis Allows the mapping of the motor axis.
For the linear translator, axis 3 is set as default. 

Adjust LT position ➜ page 195, Positioning of Linear Translator
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Positioning of Linear Translator
Only valid for Scan Heads with motorised linear translator    

  

  

 

 

The 3-Axis subsystem has to be focused on the working plane manually prior to initial opera-
tion. The linear translator is gradually moves until the test pattern output from weldMARK™ is in 
focus 

In case the working plane field size has been changed, the 3-Axis subsystem has to be 
focused again.

Warning 
The laser beam can cause severe injury to the eyes and the skin. Make sure that 
there are no reflective objects in the beam path before marking the test pattern 
and turning on the laser. Note that laser beams can be reflected even by appar-
ently matt objects. All persons in the room must wear appropriate laser protec-
tion goggles, or the marking area must be covered completely. Follow the local 
safety regulations, which can be obtained from the person responsible for laser 
safety.

￮ Select System >Preferences option from the 
menu.

￮ Select Hardware tab.
￮ In the hardware list select the desired Scan 

Head.
￮ Click on Configure… button.
￮ Click on Adjust LT position button .

The dialogue on the right opens.
Refer to the table below for explanations.

Beam Home position Displays the linear translator’s home position.

Offset Displays the saved working position of the linear translator.
It is indicated relative to the home position.

Physical Displays the absolute position of the linear translator.

Current Displays the actual position of the linear translator relative to the home 
position.

Move To Field to enter a nominal value for the position of the linear translator.

Mark Test Pattern Issues a test pattern for judgement of the focusing quality.

Reset The value of Move To is reset to the last saved position of the linear 
translator.

STOP Stops the movement of the linear translator.

Move Moves the linear translator to the position defined in field Move To.

Save Saves the actual position of the linear translator.

Save and Exit Saves the actual position of the linear translator and exits the adjustment 
window.
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Select Correction File
 

  

  

This section describes how to select a Correction File if a control card is installed:

￮ Select System >Preferences option from the 
menu.

￮ Select Hardware tab.
￮ In the hardware list, click on the Correction 

File displayed under the deflection unit you 
are using.

￮ Click on Change button.
￮ Read and acknowledge the security query 

that appears.
The dialogue on the right opens. 
Refer to the table below for explanations.

Correction File This text box displays the currently selected Correction File.

Available Correction Files This list box displays all available Correction Files.

2-Axis: Name includes: Aperture, focal length and wave length.

3-Axis: Name includes: Field size, description LTM.

Install New File... Clicking on this button starts the wizard for installing a Correction File that 
is not included in the list.
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13.1.5 Settings for the Job File
The settings for job files are shown in the window below.

  

  

13.1.6 Editing the Host Interface Settings
 

  

￮ Select System >Preferences option 
from the menu.

￮ Select Job Files tab.
The dialogue on the right opens. 
Refer to the table below for 
explanations.

(1) If this function is enabled, a backup file (with the extension .bak) is created automatically when 
saving a job file. This function is enabled by default.
The backup file is saved in the specified folder. Clicking on Browse button allows you to select a 
different folder.

(2) If this function is enabled, the job file specified in the text box will be opened automatically each 
time you start weldMARK™. Clicking on Browse button allows you to select a different job file.

(3) When enabled, the text box specified job file is automatically executed after starting weldMARK™ 
(serialization).

(4) This field specifies the location for jobs that can be loaded when working in the access levels 
Operator interface only and Touchscreen interface.

(5) If this function is enabled, any job notes will be displayed automatically when a job is loaded 
( ➜ page 174, Job Settings - "Notes").

(6) If this function is enabled, the job will be saved during execution, if it is changed during 
processing (serialization).

(7) When enabled, warnings from weldMARK™ are supressed.

The host interface provides an interface that external programs can use to communicate with 
weldMARK™.

￮ Select System >Preferences option 
from the menu.

￮ Select Host Interface tab.
The dialogue on the right opens.
For further information on the set-
tings, refer to the RAYLASE Remote 
Interface Manual, which you will 
receive separately.

More details are in the "Remote" 
manual.
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13.1.7 Language Settings
 

  

 weldMARK™ offers the option to translate the GUI text into other languages. Please refer to 
App.-Note "Translation Manager".

weldMARK™ supports various languages for the user interface. After installation, English 
(United States) is set as default language.

￮ Select System >Preferences option 
from the menu.

￮ Select Languages tab.
The dialogue on the right opens. 
Refer to the table below for 
explanations.

Available languages This list box shows all available languages.
When you change the language, you must first click on the Set as Default 
button and then restart weldMARK™. The user interface will then be 
available in the selected language.
The selection depends on the installed language files (*.stl) and the code 
page selected in the operation system, in support of the language.

Set as Default Clicking on this button sets the language selected in the list box as default 
language.
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13.1.8 Setting the LaserSaver
 

Note: The LaserSaver is intended for Nd:YAG lasers primarily.
  

  

After a certain time has elapsed, the laser can be automatically blocked and/or the laser power 
reduced. Furthermore, an optional error message can be set.

￮ Select System > Preferences option 
from the menu.

￮ Select LaserSaver tab.
The dialogue on the right opens. 
Refer to the table below for explana-
tions.

(1) If this function is enabled, the time controlled LaserSaver is activated; options (2) to (4) are 
available then.

(2) If this function is enabled, the interface that controls the laser power is set to its minimum 
settings when the time entered has been elapsed.

(3) If this function is enabled, a corresponding script is sent to the laser via the RS233 port 
when the time entered has been elapsed. Further information on this function is available 
from the manufacturer.

(4) If this function is enabled, the error port on the standard I/O card is set when the time 
entered has been elapsed.
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13.1.9 Setting up the Beam Home Position
 

  

 

13.2 Digital Scan Head Status Monitor Window

The scanner mirrors in the deflection unit can be moved to a particular position automatically at 
the end of a processing sequence. If this function is disabled, the mirrors remain at the end 
position of the object marked last.

￮ Select System >Preferences option 
from the menu.

￮ Select Beam Home tab.
The dialogue on the right opens. 
Refer to the table below for explana-
tions.

(1) If this function is enabled, the beam moves to the home position entered at 
the end of a job initiated using the Job >Run command in the menu.

(2) If this function is enabled, the beam moves to the home position entered at 
the end of a job initiated using the Job >QuickMark command in the menu.

Home to These input boxes are used to 
define the home position.

The unit used can be changed 
( ➜ page 190, Workspace Settings).

Display Speed This input box is used to specify the 
speed with which the beam moves 
to the home position.

Note: This option is not considered under the job setting Run from hardware.

Digital Scan Head status window is 
displayed on the Main Form as a 
separate window and can be moved 
around freely.

Selection of parameters which will get 
monitored during operation. 
➜ page 192, Configure Control Card
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13.3 System Properties Displays
You can display the software and hardware properties of weldMARK™:

Software properties
   

Hardware Properties
  

￮ Select System >Properties... option 
from the menu.

￮ Select Windows tab.
The dialogue on the right opens.

￮ Select System >Properties... option 
from the menu.

￮ Select Hardware tab.
The dialogue on the right opens.
You can view the respective hard-
ware properties by opening the asso-
ciated tree view.
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13.4 Global Settings
 

  

  

  

The "Globals..." allow weldMARK™ to be adapted to changed external conditions. For example, 
this can be necessary because of a slowly declining laser power or a slight change in the posi-
tion of the objects to be marked. The windows to carry out these adaptations can differ in the 
various access levels.

Globals at the "All editing functions" 
access level:

￮ Select System >Globals... option 
from the menu.
The dialogue on the right opens.
Refer to the table below for explana-
tions.

Globals at the "Touchscreen interface" access 
level:

￮ Touch the OPTIONS button.
￮ Touch the ADJUST button.

The dialogue on the right opens. 
Refer to the table below for explanations.

Laser power % power Adapting the laser power or the marking speed affects all marking objects 
included in the job. Enter value in range between 80-120 percent.Mark speed % change

X offset All objects included in the job are marked offset by the X and Y values 
entered here.Y offset

Apply when application 
starts

Only available at "All editing functions" access level:

If this function is enabled, the settings will be saved along with weldMARK™. 
Then they apply throughout the system.

Global Buffers Usage ➜ page 98, "Get string from memory buffer" string rule.

Buffer Used to select the ten buffers.

Value The buffer contents can be edited in this selection field.

Save on change The buffer is overwritten after a change (e.g. serial number) with current 
value, if this option is enabled. This option applies to all ten buffers and will 
affect the values that are carried out via the REMOTE-Interface.

Apply when application 
starts

If this option is enabled, the initial values are read  from the buffers each 
time weldMARK™ is started.
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13.5 System Security Settings

13.5.1 Password Protection
 

  

 

13.5.2 Job Files for restricted Access Levels
 

weldMARK™ provides three access levels, which allow full or limited access to the program's 
functions ( ➜ page 12, Access levels). Changing the access level can be protected by a pass-
word.

￮ Select System >Security >Change Password 
option from the menu. 
If a password has been entered already, you will be 
prompted to enter it.

The dialogue on the right opens. 
Refer to the table below for explanations.

New password Enter the password of your choice in the input boxes. The password can 
consist of any string of characters.
If you want to disable password protection, do not enter a password.

Confirm password

At the Operator interface only and Touchscreen interface access levels, you can only load jobs 
that are located in the preset folder. The folder set during installation of weldMARK™ can be 
changed ( ➜ page 197, Settings for the Job File). All jobs which should be accessible at the 
restricted access levels must be stored in this folder.
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13.6 Backing up System Settings
 

13.6.1 Backing up System Settings
  

13.6.2 Restoring System Settings
 

  

The entries in the operating system's registry can be saved in a backup file. This backs up the 
entries or allows to transfer them to a different weldMARK™ system.

￮ Select System >Backup... option from the menu. 
￮ Select the folder where you want to save the backup 

file. 
The system settings will be saved in the file 
"system.rbk".

Note:
The following procedure overwrites all existing system settings in the weldMARK™ system!

￮ Select System >Restore... option from the 
menu. 

￮ Browse to the file to be loaded - system.rbk.
￮ Select the file and click Open.

The system settings saved in the backup file 
are loaded.
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14 CALIBRATING THE MARKING FIELD
 

14.1 Correction of Mechanical Tolerances

   

    
  %o  

Because of the construction of the X/Y deflection units and the optical properties of F-Theta 
lenses, a distorted marking field is output. Therefore, a specific Correction File is provided for 
each deflection unit, which allows the software to compensate this distortion. Further informa-
tion on field distortion can be found in the application manual available by RAYLASE.

The type-specific field distortion of a deflection unit is compensated automatically when the 
corresponding weldMARK™ Correction File has been assigned. However, because of laser 
divergence, optical and mechanical tolerances every deflection unit can also produce its own 
individual field distortion. The procedures below allow the compensation of this distortion as 
well.

￮ Select System >Preferences option from the menu. 
￮ Select Hardware tab. 
￮ In directory tree, select the lens under the deflection unit you want to calibrate. 
￮ Click on Calibrate button.

Warning
The marking is activated, if this symbol appears in the following diagram.

The laser beam can cause severe injury to the eyes and the skin. Make sure that 
there are no reflective objects in the beam path before starting a job and turning 
on the laser. Note that laser beams can be reflected even by apparently matt 
objects.

All persons in the room must wear appropriate laser protection goggles, or the 
marking area must be covered completely. Follow the local safety regulations, 
which can be obtained from the person responsible for laser safety.
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14.2 The Correction-File Calibration Wizard
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14.2.1 2D Multipoint Correction

Creating a new Correction File

The multi-point correction is a field-correction based on Correction Files. More points are taken 
into account by dividing the field with horizontal and vertical lines into squares. The points of 
contact can be changed in order to achieve correction of the field distortion.

Important Note:
The multipoint correction must be executed with 0 degrees field orientation!

￮ After starting the calibration wizard, 
select Yes for the multipoint correction 
and then click the Next button.

￮ Previous calibration values can be 
reset by activating the corresponding 
checkboxes and clicking on the Next 
button.

￮ It is recommended to reset the param-
eters Gain, Offset and Rotation.

￮ If necessary, select Use new 
Correction File to create a new 
Correction File.

￮ Choose a name for the Correction 
File.

￮ The specified name can not be empty 
and not a name of an existing file.

￮ Click the Next button to continue with 
the multipoint correction.



Chapter 14 Calibrating the Marking Field

208 RAYLASE weldMARK 3 MN013 / v3.5.0

Performing the Multipoint Correction
￮ The dialogue on the right opens.

The following table shows all 
parameters.

Field size (mm) Display the field size in mm

Resolution (µm/bit) Display the resolution in µm/bit

Edit Correction The of the grid to be marked, and the correction for the X and Y axis can be set 
here.

Number of Points Number of points for the correction.
Available patterns are: 3x3, 5x5, 9x9, 11x11, 17x17, 33x33, 
65x65... grid points.

Edit X Setting the correction on the X axis

Edit Y Setting the correction on the Y axis

Mark Test Grid Starts the marking process. Prepare the work piece to mark the test-grid. Note 
that the complete marking field is used. Confirm the warning message when 
you are ready to mark, or cancel the operation.

Calculate Verification of the changes on the X and Y axis. An invalid area can be 
indicated as the case may be.
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14.2.2 3rd Axis Multi Point Correction

Creating a new Correction File

This correction is used to correct local focus deviations in working field working with 
AXIALSCAN deflection unit. The tools marks line pattern at virtual grid points and changes 
focus per line. By entering index number of best fitting line, tool calculates adaptations. 

Important Note:
The multipoint correction must be executed with 0 degrees field orientation!

￮ On the Multipoint Correction selection 
form select Yes for Multipoint Correc-
tion in the 3rd axis multipoint 
correction box and the regular (2D) 
Multipoint correction must select No.

On the next screen, it is recommended 
that values for Z-Offset, Gain, Offset or 
Rotation are kept as they are. These val-
ues should, in general, be reset only in 
case of Gain calibration.

￮ Choose a name for the Correction 
File.

￮ The specified name can not be empty 
and not a name of an existing file.

￮ Click the Next button to continue with 
the multipoint correction.
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Performing the Multipoint Correction
￮ The dialogue on the right opens.

The following table shows all 
parameters.

Field size (mm) Setting the field size in mm

Resolution (µm/bit) Setting the resolution in µm/bit
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Edit Correction The of the grid to be marked, and the correction for the X and Y axis can be set 
here.

Number of Points By selecting one of the options for Number of Points on the 
form it is possible to increase / reduce the number of points 
used for marking the test pattern and then using them for 
interpolating the values for the rest of the points in the 
Correction File.
If more points are selected then the accuracy is better, but 
on the other side requires more work for entering data in 
the table used for correcting the values.
Available sizes are: 3x3, 5x5, 9x9, 11x11, 17x17, 33x33, 
65x65 (By selection 65x65 a complete Correction File table 
is shown).

View Z When checked the current 3rd axis positions read from the 
currently active Correction File can be viewed.
This information can be used for checking if and how the 
values are changed after the corrections are applied to the 
Correction File.

Edit Correction When checked the Best Fit Focus Line table is shown. The 
lower left cell is shown in "turquoise" colour and correspond 
to the lower left corner of the x, y coordinate system, maxi-
mum negative x and y positions.
For the selected "Number of Points" (3 x 3, 5 x 5, …) a row 
/column field is available. By de-fault all the values are 
zero, meaning that the centre marked line has the best 
focus. After marking a test pattern, and inspecting marking 
results, index numbers of lines with best focus should be 
entered in the corresponding cells.
If the "best fit" marked lines is on the left of the centre line then 
the Index number should be entered with a negative sign. 

Mark Test Lines Starts the marking process. A certain number of lines, each with an own 
Z-value around intersection points.

Number of lines per 
point

Total number of lines marked at each grid intersection point
There is always a centre line and then 2 sets of lines left and right of the centre 
line.
The number of lines per pattern are limited as well, in case that either the 
number of lines or the line spacing is too large.
Valid value is an odd number and in the range 3 to 99.

Line spacing Distance between marked lines in a pattern. Valid range is 0.1 to 100 mm.
The number of lines and the distance between them must be smaller than the 
possible cell width.
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Defining the test pattern 

Delta Z between lines Defines the change in focus for each line of the pattern. 
This value is the 3rd lens offset value that will be applied between lines.
For the lines left of the centre line, 3rd lens will be moved in the negative 
direction, causing the focus in the field to shift up to-wards the head. For the 
lines on the right side of the centre line, the position of the 3rd lens will move in 
the positive direction causing focus to go further away from the head.
If Delta Z is a negative value then the reverse logic will apply.
This can be useful in case when the marking plane has a different slope.
Valid range is -100,000 to 100,000 mm, although only +/- allowed Lens 
Translator movement range, usually 9 or 11 mm, should be used for most of 
the Scan Heads.

Z Offset This value can be useful when an additional offset is required to already 
defined Global Z Offset value or if the Global Z Offset value is reset.
IMPORTANT: This value will be taken into account when modifying the 
Correction File.
After pressing calculate it is reset to zero since the values in the Correction File 
are al-ready modified to take this offset into account.
A global 3rd lens offset can be used. Care must be taken that if a negative 
Z Offset is used it might overflow the minimum zero value

Global Z Offset The value for Global Z Offset is displayed in the lower right corner of the form.
Global Z-Offset is preserved and taken into account during Test pattern 
marking.
If the Global Z Offset is to be included in the modified Correction File, then it 
should be reset to zero on the Reset calibration values form and then entered 
in the Z Offset value on the 3rd Axis Multipoint Correction form.

Calculate Verification of the changes on the X and Y axis. An invalid area can be 
indicated as the case may be.

Rotate by 90° When checked, the test pattern is marked in the y direction.

￮ Test pattern is a set of lines marked at 
the grid intersection point. The centre 
line a little bit longer then the side 
lines. Each 5th line, counted from the 
centre is slightly longer than other 
non-centre lines.

￮ In the centre of the field an additional 
+ sign is marked so that the coordi-
nate system is bet-ter visible once the 
marked material is taken away from 
the marking area.

￮ Patterns at the edge of the field are 
marked only partially so that the field 
is not exceeded.

￮ Here is an example of the pattern in 
the left upper corner, where the lines 
on the left are not marked:

￮ In the lower, left corner (-x,-y) the fol-
lowing pattern is marked in addition:
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Focus adjustment procedure
A usual way of doing the fine adjustment would be to

￮ Select the number of points used to investigate the focus (3 x 3, 5 x 5, etc.)
￮ Set the pattern parameters

￭ Number of lines per point 
￭ Line spacing
￭ Delta Z
￭ Optionally Z Offset
￭ In case that the surface is inclined in the y direction, check Rotate by 90° and/or set the 

Line spacing to a negative value. 
￮ Mark test pattern by pressing Mark Test Lines
￮ Inspect the marking result and notify the ordinal number of the best fitting line in the pattern
￮ Open the Best Fit Focus Line table by checking the Edit Correction check box
￮ Enter index numbers of lines that are best fitting the focus for each pattern. For lines left 

from the centre line use negative values, and for lines on the right positive values
￮ Press Calculate
￮ Mark test patterns again and check if the middle lines are marked with best focus in all 

places.
￮ If not re-adjust the values for "not so good" table fields and repeat the procedure.

On Calculate a temp file is created and sent to the card.

Only on Next is the original corr file overwritten.
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14.2.3 Saving Modified Correction Files

During parameter adjustment, a temporary version of the Correction File is created in the 
original Correction File folder.

For example, if the original Correction File is "AS-20-C_0100-500st_0400.gcd", then the 
temporary file with the name "AS-20-C_0100-500st_0400Temp.gcd" is created in 

"C:\Program Files\RAYLASE\Correction Files\"

A temporary Correction File is calculated and sent to the controller card each time when 
Calculate and then Mark test Lines is pressed.

The "*Temp" file is deleted when the Wizard proceeds to the next step regardless if Cancel or 
Next is pressed.

If this step of the wizard is exited with Next, then the original Correction File is saved in the 
backup folder 

"C:\Program Files\RAYLASE\Correction Files\backup"

and the last Temp version of the Correction File replaces the original one.

If the backup folder already contains previous versions of the same Correction File then 
additional backup versions are created with an index number which is always increased.

For example, if the original Correction File was AS-20-C_0100-500st_0400.gcd then after 

running 3rd axis multipoint correction 3 times and always changing the values, the backup 
folder would contain the following files:

-  AS-20-C_0100-500st_0400.gcd 

- AS-20-C_0100-500st_0400_1.gcd

- AS-20-C_0100-500st_0400_2.gcd

If Cancel is pressed, then the original Correction File is preserved and it is sent to the card so 
that the Temp versions of the card are removed.
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14.3 Adding a new Correction File
 

This wizard enables the import of Correction Files into the standard correction folder and if only 
the gcd-file is present the txt-file will be created. Information in the txt-file will be displayed in 
weldMARK™ while loading.

￮ Select System >Preferences option 
from the menu. 

￮ Select Hardware tab. 
￮ In the directory tree, click on the Cor-

rection File of the deflection unit you 
want to optimize. 

￮ Click on Change button.

￮ Click on Install New File button.
The following window is opened.

￮ Click on Browse... and select the Cor-
rection File you want to add to the list.

￮ It will be imported in the Correction 
File folder, If both the gcd- and the 
txt-file are present 
Click on the Next button. The wizard 
will quit at this point.

or

￮ The wizard continues and creates a 
txt-file, if no gcd-file is present.
Click on Next button to open the 
following window.

￮ Enter a name for the new Correction 
File (max. 25 characters).

￮ Click on Next button.
The following window is opened.
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￮ Specify the type of focusing system 
used.

￮ Click on Next button.
The following window is opened.

￮ Enter the calibration factor in bits/mm. 
This value can be obtained from the 
manufacturer of the deflection unit.

￮ Click on Next button.
The following window is opened. 

￮ Enter the focal distance of the lens 
used. 

￮ Click on Next button.
The following window is opened.

￮ Enter the input aperture of the deflec-
tion unit.
This value can be obtained from the 
manufacturer of the deflection unit.

￮ Click on Next button.
The following window is opened.
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￮ Exit the wizard by clicking on Done.
The new Correction File is added to 
the list.
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15 CONNECTING THE LASER
 

15.1 Configuring a Laser Driver
 

 

weldMARK™ supports SP-ICE, RLC-USB and RLC-PCI control cards. For details of how to 
connect a laser to the respective control card, refer to the corresponding control card manual. 

weldMARK™ is supplied with drivers for various laser systems. If any changes to the settings of 
these drivers are necessary, the procedure is as follows: 

￮ Select System >Preferences option 
from the menu. 

￮ Select Hardware tab.
￮ In the directory tree, click on the laser 

driver file you want to configure.
Note: The directory tree is visible only 
if a Scan Head card is detected after 
starting the software.

￮ Click on Configure… button. 
Note: The button is available only if a 
valid dongle is connected.

￮ Read and acknowledge the security 
query that appears.
The dialogue on the right opens.

￮ Click on Next button.
See the flow diagram on the following 
pages for settings.
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15.2 Adding a new Laser Driver
 

 

 

A laser driver is a file that contains the operating parameters for the laser. This file enables 
weldMARK™ to control the laser correctly and to display the accurate laser parameters.

weldMARK™ is supplied with various drivers for standard lasers. If the laser type you want to 
use is not included in the list of available laser driver files, you can add a new driver file:

￮ Select System >Preferences option from the menu. 
￮ Select Hardware tab.
￮ In directory tree, click on the laser driver you want to configure.

Note: The directory tree is visible only if a Scan Head card is detected after starting the soft-
ware.

￮ Click on Change button.
Note: The button is available only if a valid dongle is connected.

￮ Read and acknowledge the security query that appears.

￮ Click on Install New Laser... button.
The dialogue on the right opens.

￮ Click on Next button.
The following window is opened.

￮ Enter a name for the laser driver file in 
the input box. 
This name will appear in the list of 
available laser drivers.

￮ Click on Next button.
￮ Continue with the procedure as 

described in the next section: 
➜ page 218, Configuring a Laser 
Driver
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15.3 Calibrating the Visible Pointer
 

 

 

 

As a result of wavelength differences between the visible pointer and the marking laser, the 
position of the visible pointer in the marking field does not always correspond exactly to that of 
the marking laser. It is therefore necessary to calibrate the visible pointer. This chapter 
describes how to do this.

￮ If necessary, activate the visible 
pointer in the laser driver ( ➜ page 
218, Configuring a Laser Driver). 

￮ Select System >Preferences option 
from the menu. 

￮ Select Hardware tab. 
￮ Click on the visible pointer in the 

directory tree.
￮ Click on Calibrate button.

The dialogue on the right opens.
￮ Click on Next button.

￮ Place a sufficiently large sample in the 
center of the marking field and click on 
Next. 
The dialogue on the right opens.

Warning
The next action activates the marking laser.

The laser beam can cause severe injury to the eyes and the skin. Make sure that 
there are no reflective objects in the beam path before starting a job and turning 
on the laser. Note that laser beams can be reflected even by apparently matt 
objects.

All persons in the room must wear appropriate laser protection goggles, or the 
marking area must be covered completely. Follow the local safety regulations, 
which can be obtained from the person responsible for laser safety.

￮ Optional menu when an NewGen 
AXIALSCAN with integrated Pointer is 
selected, so that it would be possible 
to reset the values for the pointer 
Gain, Offset and Tilt Values.
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￮ Click on Mark test pattern button.
The pattern is marked using the 
parameters set in the test pattern 
profile.

￮ Click on Next button.
The following window is opened.

The following dialogue is optional and 
opens when a NewGen AXIALSCAN with 
integrated pointer is selected:

￮ The maximum and minimum values of 
X and Y mirror tilt angles are retrieved 
from the Scan Head. 
During this procedure the system will 
try to position the mirrors to the maxi-
mum possible positive and negative 
positions. The Scan Head will allow it 
to go only up to the maximum stored 
value in the Scan Head and report 
back the allowed value.
These values are shown on the form 
on the right side of the Tilt values.

￮ The pointer is turned on and starts 
marking a cross.

Observe the position of the cross. 
Change the Tilt values by pressing up/
down arrows. Mirrors will move to a new 
position. Repeat until the previewed 
cross matched the marked cross.

￮ Use the arrow keys to adjust the posi-
tion and size of the test pattern shown 
by the visible pointer. 

￮ Click on Next button.
The following window is opened.
Note:
In case of 3-Axis Digital Scan Heads 
with pointer only adjust size, not posi-
tion.
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￮ Click on Done to exit the wizard.
￭ Calibration results are saved, as in 

case of a laser pointer, in the system 
ini file "atlens.ini".

￭ Two additional entries are added for 
Scan Heads with pointer:

￭ XMirrorTiltValue
￭ YMirrorTiltValue
￭ The values from the calibration wizard 

will be written in these entries.
￭ The same values are written in the 

calibrated heads "*.ini" file "cardN-
headM.ini", for the corresponding 
card, head under the active Correction 
File.

￭ When weldMARK™ starts the values 
from these *.ini files will overwrite the 
values taken from the Scan Head 
configuration file, if they are read from 
them correctly

Screenshot shows sample display of 
calibration values.
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16 CONNECTING DEFLECTION UNITS
 

16.1 Connecting multiple Control Cards (Master-Master setup)
 

16.2 Connecting multiple Deflection Units to a Control Card 
(Master-Slave setup)

 

weldMARK™ uses the XY2-100 or XY2-100Enhanced protocol to operate deflection units with 
RAYLASE control cards. Deflection units made by other manufacturers can also be used, pro-
vided they support this protocol. Detailed information on connecting the deflection units to the 
control cards can be found in the manual of the respective control card.

weldMARK™ can operate with multiple control cards in one computer. Each card can be used 
to operate one laser and one deflection unit. This is only possible with control cards that have 
multi-card capability. With the SP-ICE control card, up to four cards can be installed in one 
computer.

Installation of control cards is described in the supplied manuals. Starting weldMARK™ after 
installation of control cards, the program detects the new cards and shows them in Job Man-
ager.

If the SP-ICE control card is used, multiple deflection units and a laser can be connected to a 
single SP-ICE card. Output of the vectors to the individual deflection units is synchronized. For 
details, refer to the SP-ICE card manual.
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17 CONNECTING TO EXTERNAL DEVICES
 

17.1 Standard I/O Card / Interlock Card
 

  

  

I = Input, O = Output

 

weldMARK™ supports various I/O interfaces for the communication with external devices. In 
addition, weldMARK™ can be operated with up to four stepper motor controls.

weldMARK™ uses the same card type as the standard I/O card and the interlock card. The 
mode is set by a bridge from GND to the corresponding pin (CARD ID). Depending on the 
mode, it results in one of the following pin assignments:

Standard I/O card Interlock card

Signal Explanation

UserI1-4 I Trigger (>50mS LOW)

STEPREPEAT1-2 I

START PROCESS I

PROCESS ENABLED1-6 O LOW active

MARK IN PROGRESS O LOW during mark

ERROR FLAG O LOW on error

USEROUT1-6 O programmable

BUSY/READY O programmable

INTERLOCK1-23 I Trigger (>50mS LOW)

All inputs and outputs are TTL connected and have a pull-up resistance of 2.2kΩ. The ports 
must be electrically isolated from the connected hardware. Electrical interference pulses must 
be prevented as far as possible. When using a relay a recovery diode has to be used. The con-
necting cables must be shielded and kept as short as possible. Moreover the shield must be 
connected to the computer housing.
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I/O card
 

Interlock Card
 

  

 

The optional standard I/O card allows job sequences to be controlled by external signals using 
automation objects. In addition, weldMARK™ can use automation objects to output control sig-
nals to operate external components.

The optional interlock card enables weldMARK™ to respond to interlock signals from external 
components. Each interlock input (INTERLOCK1 to INTERLOCK23) can be configured as 
HIGH or LOW when active. This configuration is carried out in the file "\Program Files\ray-
lase\weldmark\bin\intmsg.txt", as shown below.

Interlock Messages

[ASSERTION]
AssertLevel0=0
AssertLevel1=0
AssertLevel2=0
AssertLevel3=0
AssertLevel4=0
AssertLevel5=0
AssertLevel6=0
AssertLevel7=0
AssertLevel8=0
AssertLevel9=0
AssertLevel10=0
AssertLevel11=0
AssertLevel12=0
AssertLevel13=0
AssertLevel14=0
AssertLevel15=0
AssertLevel16=0
AssertLevel17=0
AssertLevel18=0
AssertLevel19=0
AssertLevel20=0
AssertLevel21=0
AssertLevel22=0

AssertLevel22=0

[MESSAGE]
Msg0=Interlock 1 error !
Msg1=Interlock 2 error !
Msg2=Interlock 3 error !
Msg3=Interlock 4 error !
Msg4=Interlock 5 error !
Msg5=Interlock 6 error !
Msg6=Interlock 7 error !
Msg7=Interlock 8 error !
Msg8=Interlock 9 error !
Msg9=Interlock 10 error !
Msg10=Interlock 11 error !
Msg11=Interlock 12 error !
Msg12=Interlock 13 error !
Msg13=Interlock 14 error !
Msg14=Interlock 15 error !
Msg15=Interlock 16 error !
Msg16=Interlock 17 error !
Msg17=Interlock 18 error !
Msg18=Interlock 19 error !
Msg19=Interlock 20 error !
Msg20=Interlock 21 error !
Msg21=Interlock 22 error !
Msg22=Interlock 23 error !

In the lines AssertLEVEL0 to AssertLEVEL22, the active status of each interlock input can be 
set to "0" or "1".

A name using the lines Msg0-Msg22 is assigned to each interlock input. This name is dis-
played by weldMARK™ if there is a corresponding interlock event.

In some situations, it may be necessary to use different interlock names and AssertLevels for 
different laser types. weldMARK™ supports this function by linking the interlock configuration 
file with the laser driver file. Please contact RAYLASE for further details.
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17.2 Operating Stepper Motors
 

Note:
RAYLASE provides the OMS-Motor-Control-Card PCIx04 for activation.
This cards allows activation only for stepper motors.

17.2.1 Installing the Plug&Play Drivers in Windows
 

  

17.2.2 Configuring the Motor Control Settings
  

weldMARK™ can be operated with up to four stepper motor controls. For example, this allows 
the control of an XY table, a Z axis and a rotary axis.

The card for operating stepper motors must be installed in your computer.

￮ Start the computer.
Windows detects the new 
hardware and starts the wiz-
ard for installing the driver 
files.

￮ Click on Browse button.
￮ Select the directory …\Pro-

gram Files\raylase\weld-
mark\oms.

￮ Click on the Next button.
Windows installs the OMS 
driver.

￮ Select System >Preferences option 
from the menu.

￮ Select Motor Control tab. 
The dialogue on the right opens.

￮ Edit the settings as described in the 
next section.
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Editing the Motor Settings
 

  

  

The settings for the stepper motor control determine the default speed, the default acceleration 
and the functions for moving the individual axes and moving to the home position.

￮ Select System >Preferences option 
from the menu.

￮ Select Motor Control tab. 
￮ Click on Properties button.
￮ Select Controller Settings tab.

The dialogue on the right opens. 
The displayed values are default 
settings used with motorized linear 
translators. 

Current axis This list box can be used to select the required axis.

Velocity Base These input boxes can be used to determine the basic, 
maximum and minimum speed of the stepper motor.Default Maximum

Default Minimum

Acceleration Ramp These input boxes can be used to determine the acceleration 
characteristics, the maximum acceleration and the number of 
acceleration steps.

Maximum

Ramp steps

Axis Travel Invert direction bit If this function is enabled, the direction of movement is inverted.

Limits are active 
high

If this function is enabled, the status of the limit switch is set from 
active LOW to active HIGH.

Enable overtravel 
detection

If this function is enabled, the limit switches are monitored during 
movement.

Enable soft travel 
limits 

If both, the Enable overtravel detection function and this function, 
are enabled the control card stops the axis when a limit switch is 
detected.

Homing At home when Status of the limit switch when the home position is reached.

Direction Driving direction of the movement unit when searching for the 
home position.

Moves are Absolute For destinations, the coordinates to which the movement unit 
should move are specified.

Relative For destinations, the distances by which the movement unit 
should move are specified.
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Editing the Settings for the XY Table
  

  

￮ Select System >Preferences option 
from the menu. 

￮ Select Motor Control tab. 
￮ Click on Properties button.
￮ Select XY Table tab. 
￮ Carry out the required changes. 

The dialogue on the right opens. 
Refer to the table below for expla-
nations.

(1) This check box can be used to activate the movement unit. Then, the corresponding 
functions in the program interface are available.

Axis Name These text boxes can be used to specify the names of the movement unit X- 
and Y-axes. The names are used in the corresponding dialogs of the program 
interface then.

Cal factor Calibration factor for the axes in steps per millimeter.

Home Clicking on this button returns the movement unit to its home position. The 
home position is defined in the field right to the Home button.

Fwd Clicking on these buttons determines the limit switch position. As soon as the 
movement unit arrives at the limit switch, the position is saved and displayed. 
This information advises the user of the physical boundaries in the program 
sequence.

Rev

Timeout A time value can be entered in this field. If no limit switch is found before this 
time has elapsed, the movement unit stops as a precaution.

Go Clicking on this button moves the movement unit with the following parameters 
for testing purposes:

Move to This field can be used to specify the position to which the XY table 
moves when clicking on the GO button.

At speed This field can be used to specify the speed at which the XY table 
moves when clicking on the GO button.

Stop Clicking on this button stops movement of the motor immediately.

Moves 
are

Absolute For destinations, the coordinates to which the movement unit should move are 
specified.

Relative For destinations, the distances by which the movement unit should move are 
specified.
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Editing the Settings for the Z axis (Laser Lift or Linear Translator)
  

  

￮ Select System >Preferences option 
from the menu. 

￮ Select Motor Control tab. 
￮ Click on Properties button. 
￮ Select Custom Axis tab. 
￮ The dialogue on the right opens. 

The displayed values are default 
settings used with motorized linear 
translators. 

(1) This check box can be used to activate the movement unit. Then, the corresponding 
functions in the program interface are available.

Z axis Name This text box can be used to specify the name of the movement unit's Z axis. 
The name is then used in the corresponding dialogs in the program interface.

Display 
Settings

Rotary These check boxes specify whether you want to operate a rotary 
or a linear axis. Linear

Cal factor Calibration factor for the axis in steps per millimeter.

Home Clicking on this button returns the movement unit to its home position. The 
home position is defined in the field right to the Home button.

Fwd Clicking on these buttons determines the limit switch position. As soon as the 
movement unit arrives at the limit switch, the position is saved and displayed. 
This information advises the user of the physical boundaries in the program 
sequence.

Rev

Timeout A time value can be entered in this field. If no limit switch is found before this 
time has elapsed, the movement unit stops as a precaution.

Go Clicking on this button moves the movement unit with the following parameters 
for testing purposes:

Move to This field can be used to specify the position to which the Z table 
moves when clicking on the GO button.

At speed This field can be used to specify the speed at which the Z table 
moves when clicking on the GO button.

Stop Clicking on this button stops movement of the motor immediately.

Moves 
are

Absolute For destinations, the coordinates to which the movement unit should move are 
specified.

Relative For destinations, the distances by which the movement unit should move are 
specified.
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Editing the Settings for the Rotary Axis (Indexer)
  

  

￮ Select System >Preferences option 
from the menu. 

￮ Select Motor Control tab. 
￮ Click on Properties button.
￮ Select Rotary tab. 
￮ The dialogue on the right opens. 

Refer to the table below for expla-
nations.

(1) This check box can be used to activate the movement unit. Then, the corresponding 
functions in the program interface are available.

T Axis 
Name

This text box can be used to specify the name of the movement unit's rotary 
axis. The name is then used in the corresponding dialogs in the program 
interface.

Display 
Settings

Cal factor Calibration factor for the axis in steps per millimeter.

Home Clicking on this button returns the movement unit to its home position. The 
home position is defined in the field right to the Home button.

Fwd Clicking on these buttons determines the limit switch position. As soon as the 
movement unit arrives at the limit switch, the position is saved and displayed. 
This information advises the user of the physical boundaries in the program 
sequence.

Rev

Timeout A time value can be entered in this field. If no limit switch is found before this 
time has elapsed, the movement unit stops as a precaution.

Go Clicking on this button moves the movement unit with the following parameters 
for testing purposes:

Move to In this field, you can specify the position to which the movement 
unit moves when clicking on the GO button.

At speed In this field, you can specify the speed at which the movement 
unit moves when clicking on the GO button.

Stop Clicking on this button stops movement of the motor immediately.

Moves 
are

Absolute For destinations, the coordinates to which the movement unit should move are 
specified.

Relative For destinations, the distances by which the movement unit should move are 
specified.
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Stepper Motor Control Properties
  

￮ Select System >Preferences option 
from the menu. 

￮ Select Motor Control tab. 
￮ Click on Properties button.
￮ Select Card Properties tab.

The dialogue on the right opens. 
This window shows the stepper 
motor control properties.
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18 PROGRAMMABLE INTERFACES

18.1 Remote Interface

18.1.1 TCP/IP Test Client   
 

Starting the TCP/IP test client
 

 

￮ Enter the following command lines (with variations 
on meaning), and send each line with the button 
Send>>>.
weldMARK™ acknowledges each accepted com-
mand line with "ACK".
- SET,control,host
- OPEN,file,c:\Ts00t.wmj
- RUN
- MODIFY,filed,01,123456
- OFFLINE
- SET,control,local

The remote interface enables the control of weldMARK™ by using a remote program. The 
external program can run jobs, dynamically change the content of marking objects and execute 
jobs. After each command executing, weldMARK™ sends a response to the remote program.

While weldMARK™ is being controlled by the remote program, the normal weldMARK™ user 
interface is blocked to prevent the user from intervening in processes that are in progress.

Detailed information about the remote interface can be found in the weldMARK™Remote Inter-
face manual.

The TCP/IP test client is a tool for testing the weldMARK™ remote interface functionality. For 
further information about the remote interface refer to the corresponding manual. This is avail-
able separately from RAYLASE.

￮ Start the program tcptestclient.exe, located in the 
directory …\Program Files\raylase \weldmark\bin.

￮ If the TCP/IP test client is running on the same com-
puter as weldMARK™, enter the IP address 
"127.0.0.1".
If the TCP/IP test client is running on a different 
(remote) computer, you must enter the IP address of 
the computer on which weldMARK™ is running in the 
Addr. field.

￮ Enter the value "350" in the Port field.
￮ Make sure that weldMARK ™ is running on the local 

computer or on the remote computer.
￮ Click on the Connect button. 

The TCP/IP test client connects to the weldMARK™ 
instance and is ready to exchange data with 
weldMARK™.

Note: 
For this example, weldMARK™ must be configured in such a way that the program will accept 
commands from the TCP/IP port. Detailed information can be found in the remote interface 
manual.
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18.2 COMserver Interface
The COMserver Interface allows weldMARK functions to be used with an ActiveX Interface, to 
customize different user specific Automations. The wmCOM.exe is started instead of the 
wmgui.exe. Refer to the COMserver manual for more detailled information.
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